Bug 22092 - Kernel v2.6.36 trouble on USB disconnect
Kernel v2.6.36 trouble on USB disconnect
Status: CLOSED OBSOLETE
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: linux-scsi@vger.kernel.org
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-11-04 18:28 UTC by Maciej Rutecki
Modified: 2012-06-14 17:34 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.36
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-04 18:28:32 UTC
Subject    : Kernel v2.6.36 trouble on USB disconnect
Submitter  : Ketil Froyn <ketil@froyn.name>
Date       : 2010-10-29 8:05
Message-ID : AANLkTik5qVxkEGVAA1PSOGk2KTW+ekHpSwttsQEWzWj+@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=128833956503607&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Alan Stern 2010-11-19 15:19:04 UTC
This bug is misclassified.  It is a problem with the block layer (or possibly the SCSI layer) and has nothing to do with USB.  It should be reassigned.
Comment 2 Greg Kroah-Hartman 2010-11-19 18:01:31 UTC
reassigning...
Comment 3 Rafael J. Wysocki 2010-12-19 14:44:59 UTC
On Sunday, December 19, 2010, Heinz Diehl wrote:
> On 19.12.2010, Rafael J. Wysocki wrote: 
> 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.35 and 2.6.36.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.35 and 2.6.36.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=22092
> > Subject		: Kernel v2.6.36 trouble on USB disconnect
> > Submitter	: Ketil Froyn <ketil@froyn.name>
> > Date		: 2010-10-29 8:05 (52 days old)
> > Message-ID	: <AANLkTik5qVxkEGVAA1PSOGk2KTW+ekHpSwttsQEWzWj+@mail.gmail.com>
> > References	: http://marc.info/?l=linux-kernel&m=128833956503607&w=2
> 
> I guess this may be a duplicate of this one:
> http://bugzilla.kernel.org/show_bug.cgi?id=24722
Comment 4 Rafael J. Wysocki 2010-12-19 14:48:12 UTC
Closing as a duplicate.

*** This bug has been marked as a duplicate of bug 24722 ***
Comment 5 Alan Stern 2010-12-20 04:45:39 UTC
On Sun, 19 Dec 2010 bugzilla-daemon@bugzilla.kernel.org wrote:

> --- Comment #4 from Rafael J. Wysocki <rjw@sisk.pl>  2010-12-19 14:48:12 ---
> Closing as a duplicate.
> 
> *** This bug has been marked as a duplicate of bug 24722 ***

Are you sure about this?  The error messages don't look at all similar.  
The error for bug #24722 is a WARN_ONCE in ehci_endpoint_reset(),
whereas the error in this bug report is some unspecified problem in
disk_replace_part_tbl().

Alan Stern
Comment 6 Rafael J. Wysocki 2010-12-20 20:36:06 UTC
Not at all, I wanted someone more familiar with the code in question to
speak up. :-)
Comment 7 Florian Mickler 2011-03-29 21:49:40 UTC
Is this still a problem on 2.6.38.y?
Comment 8 Florian Mickler 2011-04-20 20:02:50 UTC
*ping*

Note You need to log in before you can comment on or make changes to this bug.