Bug 22082 - 2.6.36-git11 -- kernel/pid.c:419 invoked rcu_dereference_check() without protection!
2.6.36-git11 -- kernel/pid.c:419 invoked rcu_dereference_check() without prot...
Status: CLOSED CODE_FIX
Product: Process Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: process_other
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2010-11-04 18:24 UTC by Maciej Rutecki
Modified: 2010-12-02 20:48 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.36-git11
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-04 18:24:33 UTC
Subject    : 2.6.36-git11 -- kernel/pid.c:419 invoked rcu_dereference_check() without protection!
Submitter  : Miles Lane <miles.lane@gmail.com>
Date       : 2010-10-29 5:22
Message-ID : AANLkTimGgzOZb8EwUQO16cZcL+ycveKTYzg_AAX+D+Kw@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=128832975924288&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Dan Carpenter 2010-11-24 10:06:52 UTC
Fixed in 4221a9918e38 "Add RCU check for find_task_by_vpid()."

Note You need to log in before you can comment on or make changes to this bug.