Bug 2183 - Regression: halt -p nolonger kills the power - ACPICA 20031203
Summary: Regression: halt -p nolonger kills the power - ACPICA 20031203
Status: REJECTED DUPLICATE of bug 2109
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Off (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-24 15:21 UTC by Hartwig Felger
Modified: 2004-03-04 14:45 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.4.25 and 2.6.3
Tree: Mainline
Regression: ---


Attachments

Description Hartwig Felger 2004-02-24 15:21:56 UTC
Distribution: SuSE 8.1 
Hardware Environment: Laptop Acer TM630 
Software Environment: sysvinit-2.82-187 
Problem Description: Till 2.4.24, respectively 2.6.2, halt -p -d -f did kill 
off the power of the laptop. With 2.4.25, as well as 2.6.3 it no longer does. 
If I do an echo 0xffff > /proc/acpi/debug_level before shuting down, I got 
lots of messages, afer the halt-command. It seems to be a loop, but it scrolls 
so fast, that I could not read any of them.  
 
cow:~ # cat /proc/acpi/info 
version:                 20040116 
states:                  S0 S3 S4 S5 
 
 
Steps to reproduce: shutdown -h now
Comment 1 Hartwig Felger 2004-03-03 04:08:56 UTC
After further digging I found out, that starting with a vanilla 2.4.24 kernel 
(which by itself works as it should), applying acpi-20031203-2.4.24.diff.bz2 
introduces the regression. If I have /proc/acpi/debug_level set to 7, it 
reports me after the "power down." message the following: 
hwsleep-0265 [33] acpi_enter_sleep_state: Entering sleep state [S5] 
 
After that nothing more happens. The machine has to be cut power by pressing 
the power-button >4sec. 
Comment 2 Len Brown 2004-03-04 14:45:51 UTC
looks like the same regression spotted in bug 2109


*** This bug has been marked as a duplicate of 2109 ***

Note You need to log in before you can comment on or make changes to this bug.