Bug 216894 - Regression in commit 2aca4f3734bd717e04943ddf340d49ab62299a00
Summary: Regression in commit 2aca4f3734bd717e04943ddf340d49ab62299a00
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
: 216893 (view as bug list)
Depends on:
Blocks:
 
Reported: 2023-01-06 10:58 UTC by Christian Marillat
Modified: 2023-01-28 08:59 UTC (History)
2 users (show)

See Also:
Kernel Version: 6.0.17 and 6.1.3
Tree: Mainline
Regression: Yes


Attachments
increase invalid max flowring limit (1.54 KB, patch)
2023-01-09 09:59 UTC, Arend van Spriel
Details | Diff

Description Christian Marillat 2023-01-06 10:58:26 UTC
Hi,

With this commit the kernel doesn't load the firmware and I lost my wifi device, But without this commit the firmware load fine without a kernel panic.

kernel 6.0.15/6.1.3
brcmfmac 0000:02:00.0: brcmf_pcie_init_ringbuffers: invalid max_flowrings(264)

kernel 6.0.17
brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4366c-pcie for chip BCM4366/4
brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4366/4 wl0: Nov  5 2018 03:19:56 version 10.28.2 (r769115) FWID 01-d2cbb8fd

PCI info :

02:00.0 Network controller: Broadcom Inc. and subsidiaries Device 43c3 (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device 86fb
	Flags: bus master, fast devsel, latency 0, IRQ 45
	Memory at f7000000 (64-bit, non-prefetchable) [size=32K]
	Memory at f6800000 (64-bit, non-prefetchable) [size=8M]
	Memory at f2400000 (64-bit, prefetchable) [size=4M]
	Capabilities: <access denied>
	Kernel driver in use: brcmfmac
	Kernel modules: brcmfmac

Christian
Comment 1 Christian Marillat 2023-01-06 11:00:21 UTC
kernel version should be  6.0.17/6.1.3 and 6.0.15

Christian
Comment 2 Christian Marillat 2023-01-06 23:39:17 UTC
*** Bug 216893 has been marked as a duplicate of this bug. ***
Comment 3 Artem S. Tashkinov 2023-01-08 09:54:29 UTC
Please CC (send your entire bug report): wright dot feng AT cypress dot com

He's not on this bugzilla.
Comment 4 Christian Marillat 2023-01-08 10:26:11 UTC
CC sent to Wright Feng
Comment 5 Christian Marillat 2023-01-08 10:40:30 UTC
This address return bounces.

Sent with two different address email.
Comment 6 Arend van Spriel 2023-01-09 09:04:12 UTC
The regression was introduced by following commit:

https://lore.kernel.org/all/20220929031001.9962-3-ian.lin@infineon.com/

This has also been reported on the linux-wireless list.

Regards,
Arend
Comment 7 Arend van Spriel 2023-01-09 09:59:35 UTC
Created attachment 303558 [details]
increase invalid max flowring limit

Attached possible patch for the reported issue. Please provide feedback.
Comment 8 Christian Marillat 2023-01-09 11:04:54 UTC
Of course this patch solve this issue.
Comment 9 Christian Marillat 2023-01-18 12:04:20 UTC
Would be nice to know why the patch proposed in this bug isn't applied to 6.1.7

Christian
Comment 10 Arend van Spriel 2023-01-19 11:15:18 UTC
(In reply to Christian Marillat from comment #9)
> Would be nice to know why the patch proposed in this bug isn't applied to
> 6.1.7

It would be nice if you pay attention. It has been applied earlier this week on the wireless repo. It has to go to networking repo and then land in Linus' tree before it will be taken by the stable maintainers. So it will take a week or two. Please be patient.

Regards,
Arend

Note You need to log in before you can comment on or make changes to this bug.