Bug 216643 - Speaker recognized as headphones & Invalid AFG subtree for codec Conexant CX11970 on HP ZBook Studio G5 Mobile
Summary: Speaker recognized as headphones & Invalid AFG subtree for codec Conexant CX1...
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
Depends on:
Reported: 2022-10-30 22:25 UTC by Nils Kaiser
Modified: 2022-10-31 07:02 UTC (History)
2 users (show)

See Also:
Kernel Version: 5.19,6.0
Tree: Mainline
Regression: No

alsa-info generated on k6.0.6-1-MANJARO (29.72 KB, text/plain)
2022-10-30 22:25 UTC, Nils Kaiser

Description Nils Kaiser 2022-10-30 22:25:12 UTC
Created attachment 303107 [details]
alsa-info generated on k6.0.6-1-MANJARO


I have a HP ZBook Studio G5 Mobile which I use as a daily driver. I run manjaro and noticed that my internal speaker stopped working a few kernel versions ago. Sound works fine on windows. On affected versions internal speaker is not available and headphones are displayed as active.

While trying to analyze the issue, I ran into errors running hda analyzer which crashes with an error message "Invalid AFG subtree for codec Conexant CX11970?". I filed a bug here https://github.com/gm-vm/hda-analyzer/issues/1 and the author pointed to some kernel function not returning correct values (snd_hdac_get_sub_nodes)

I haven't done a full analysis of the affected versions, but 6.0.x-MANJARO seems to be affected, as well as 5.19.17-1-MANJARO. I don't have the issue on 5.15.76-1-MANJARO which I will run for the time being. I ran a couple of live usbs (fedora, manjaro) but those were not affected (I need to check exact versions but fedora was on 5.19 and manjaro on 5.15).

I am appending output of alsa-info.sh on 6.0.6-1-MANJARO.

It's been a while since I had to play with kernel stuff so feel free to send me in the right direction to provide more helpful info.

Comment 1 Takashi Iwai 2022-10-31 07:02:05 UTC
If the old kernel worked while the newer not, the best would be git bisect.

Note You need to log in before you can comment on or make changes to this bug.