Bug 21662 - 2.6.35->2.6.36 regression, vanilla kernel panic, ppp or hrtimers crashing
2.6.35->2.6.36 regression, vanilla kernel panic, ppp or hrtimers crashing
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Arnaldo Carvalho de Melo
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-11-01 19:45 UTC by Maciej Rutecki
Modified: 2010-12-19 13:41 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.36
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-11-01 19:45:37 UTC
Subject    : 2.6.35->2.6.36 regression, vanilla kernel panic, ppp or hrtimers crashing
Submitter  : Denys Fedoryshchenko <nuclearcat@nuclearcat.com>
Date       : 2010-10-25 9:22
Message-ID : 201010251222.37191.nuclearcat@nuclearcat.com
References : http://marc.info/?l=linux-kernel&m=128799855826011&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Denys Fedoryshchenko 2010-12-05 20:36:34 UTC
Here is suggested patch and problematic commit (55c95e738da85)
http://marc.info/?l=linux-kernel&m=129138181231513&w=2
Comment 2 Rafael J. Wysocki 2010-12-19 13:39:38 UTC
Fixed by commit 2a27a03 pppoe.c: Fix kernel panic caused by __pppoe_xmit .

Note You need to log in before you can comment on or make changes to this bug.