Bug 216508 - [regression] snd-usb-audio - GoXLR Audio no longer working
Summary: [regression] snd-usb-audio - GoXLR Audio no longer working
Status: RESOLVED DUPLICATE of bug 216500
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-20 16:53 UTC by Craig McLure
Modified: 2022-09-20 18:08 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.19.9
Tree: Mainline
Regression: No


Attachments

Description Craig McLure 2022-09-20 16:53:41 UTC
Since Kernel 5.19.9 the GoXLR no longer works, presenting the following error in dmesg:

[25554.653323] usb 5-3: parse_audio_format_rates_v2v3(): unable to find clock source (clock -71)
[25554.653821] usb 5-3: uac_clock_source_is_valid(): cannot get clock validity for id 41
[25554.653822] usb 5-3: clock source 41 is not valid, cannot use

My guess is that this is related to ff878b408a03bef5d610b7e2302702e16a53636e (usb-audio: Split endpoint setups for hw_params and prepare), I've not been able to directly bisect yet, but it was the only change that would apply.

We ran into a similar problem in 5.11 where the sync ep wasn't initialised prior to the data endpoint resulting in no audio (Bug #215079), I'm wondering if we've hit the same thing again now that prepare and configure are split.
Comment 1 Takashi Iwai 2022-09-20 18:08:57 UTC
The commit is reverted / revisited; see the bug 216500.

*** This bug has been marked as a duplicate of bug 216500 ***

Note You need to log in before you can comment on or make changes to this bug.