Bug 216499 - MOTU M2 : snd_pcm_hw_params failed: Device or resource busy
Summary: MOTU M2 : snd_pcm_hw_params failed: Device or resource busy
Status: RESOLVED DUPLICATE of bug 216500
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-17 19:10 UTC by Matteo Beniamino
Modified: 2022-09-19 07:28 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.19.9
Tree: Mainline
Regression: No


Attachments
Output of alsa-info.sh (151.51 KB, text/plain)
2022-09-17 19:10 UTC, Matteo Beniamino
Details
Output of spa-acp-tool -vvv -c 5 in kernel 5.19.7 (10.55 KB, application/x-troff-man)
2022-09-17 19:11 UTC, Matteo Beniamino
Details
Output of spa-acp-tool -vvv -c 5 in kernel 5.19.9 (5.36 KB, application/x-troff-man)
2022-09-17 19:11 UTC, Matteo Beniamino
Details

Description Matteo Beniamino 2022-09-17 19:10:06 UTC
Created attachment 301822 [details]
Output of alsa-info.sh

After upgrading to 5.19.9 pipewire won't create any profile for my MOTU M2 interface. With kernel 5.19.8 it's working as expected. I'm using alsa-ucm-conf at commit 3a6acaa5090a0c5a0d29c8a4906b6a60378774e2 , that is a commit after the official 1.2.7.2 release: that commit fixes the ucm profile for the M2. 

I've found out that "spa-acp-tool -vvv -c 5" gives different output in the two cases. Here is an excerpt of the interesting lines.

kernel 5.19.7:

```
Maximum hw buffer size is 100 ms
Set buffer size first (to 4800 samples), period size second (to 1200 samples).
Device hw:M2 doesn't support sample format s16le, changed to s32le.
Profile Direct supported.
ALSA device close 0x5635c1df90b0
```

kernel 5.19.9:

```
Maximum hw buffer size is 100 ms
Set neither period nor buffer size.
snd_pcm_hw_params failed: Device or resource busy
ALSA device close 0x5618eebc2130
```

(as I wrote I eventually tested with 5.19.8 and the interface still works).

This behaviour is consistent, the only difference between the tests was the kernel version. I'm using the kernel from my distro (Arch), but I've checked that there were no patches applied or options changed between the two releases.
Comment 1 Matteo Beniamino 2022-09-17 19:11:12 UTC
Created attachment 301823 [details]
Output of spa-acp-tool -vvv -c 5 in kernel 5.19.7
Comment 2 Matteo Beniamino 2022-09-17 19:11:31 UTC
Created attachment 301824 [details]
Output of spa-acp-tool -vvv -c 5 in kernel 5.19.9
Comment 4 Takashi Iwai 2022-09-19 07:28:21 UTC
Yes, this must be the same.

*** This bug has been marked as a duplicate of bug 216500 ***

Note You need to log in before you can comment on or make changes to this bug.