Bug 216395 - XP-Pen Star G430S stops working on any kernel newer than 5.18.7
Summary: XP-Pen Star G430S stops working on any kernel newer than 5.18.7
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: Intel Linux
: P1 blocking
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-22 16:28 UTC by gomapo2868
Modified: 2022-08-26 11:03 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.19
Tree: Mainline
Regression: No


Attachments

Description gomapo2868 2022-08-22 16:28:00 UTC
XP-Pen Star G430S stops working on newer kernels than 5.18.7 (5.18.8, 5.19, 6.0rc1 tested)
It seems to use the uclogic drivers.
Comment 1 The Linux kernel's regression tracker (Thorsten Leemhuis) 2022-08-26 11:03:01 UTC
(In reply to gomapo2868 from comment #0)
> stops working on newer kernels than 5.18.7

IOW: 5.18.6 worked? That's odd, the diff between those two versions is small and it seems all changes touch totally other areas of the kernel (but I might have missed something). https://lwn.net/Articles/899092/

Note You need to log in before you can comment on or make changes to this bug.