Bug 216382 - [bisected][regression] mediatek bluetooth 13d3:3563 (mt7921e) doesn't work with audio devices.
Summary: [bisected][regression] mediatek bluetooth 13d3:3563 (mt7921e) doesn't work wi...
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Bluetooth (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: linux-bluetooth@vger.kernel.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-19 16:15 UTC by Arek Ruśniak
Modified: 2022-09-13 18:11 UTC (History)
1 user (show)

See Also:
Kernel Version: 6.0-rc1
Tree: Mainline
Regression: No


Attachments
btmon -w log # 6.0-rc1 (12.45 KB, application/octet-stream)
2022-08-19 20:12 UTC, Arek Ruśniak
Details
btmon -w log # 5.19x (690.19 KB, application/octet-stream)
2022-08-19 20:19 UTC, Arek Ruśniak
Details
Patch (1.80 KB, patch)
2022-09-02 00:29 UTC, Luiz Von Dentz
Details | Diff

Description Arek Ruśniak 2022-08-19 16:15:30 UTC
After update to new 6.0rc1 I can't use any bt-earphones.  
I've checked in bluetoothctl: devices are still connected but none of endpoint/transport entries are creates.

XB1S gamepad works without any issues.

bisecting result:
---
26afbd826ee326e63a334c37fd45e82e50a615ec is the first bad commit
commit 26afbd826ee326e63a334c37fd45e82e50a615ec
Author: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
Date:   Mon Jul 29 18:15:43 2019 +0300

    Bluetooth: Add initial implementation of CIS connections
    
    This adds the initial implementation of CIS connections and introduces
    the ISO packets/links.
---

can't revert this commit. 

*Aditionally, I've tried this kernel on second machine with AX210 wifi/bt combo and issue doesn't appear. So I assume problem is limited to mediatek module.
Comment 1 Luiz Von Dentz 2022-08-19 18:39:01 UTC
I suspect this could be due some HCI command during initialization, could you please collect the HCI using btmon?
Comment 2 Arek Ruśniak 2022-08-19 20:12:44 UTC
Created attachment 301608 [details]
btmon -w log # 6.0-rc1

Hi,
this is log for rc1, hope it's not a big problem.
Comment 3 Arek Ruśniak 2022-08-19 20:19:57 UTC
Created attachment 301609 [details]
btmon -w log # 5.19x

this is log for connected/worked device.
Comment 4 Luiz Von Dentz 2022-09-02 00:29:43 UTC
Created attachment 301727 [details]
Patch

This shall fix the problem, weird that CI didn't find it though since it quite clear that ACL buffers will not be initialized thus preventing any ACL traffic.
Comment 5 Arek Ruśniak 2022-09-02 19:06:02 UTC
thanks Luiz for fix this, i've tested it on top rc3 & master and my headphones live again.
Comment 6 Arek Ruśniak 2022-09-13 18:11:53 UTC
fixed in rc5

Note You need to log in before you can comment on or make changes to this bug.