Bug 215661 - S2idle suspend still draining battery to zero over night , Appear from Kernel 5.16.10
Summary: S2idle suspend still draining battery to zero over night , Appear from Kernel...
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: EC (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: acpi_ec
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-05 01:24 UTC by plum
Modified: 2022-06-27 03:37 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.16.10
Tree: Fedora
Regression: Yes


Attachments
dmesg.log (99.17 KB, text/plain)
2022-03-05 01:24 UTC, plum
Details

Description plum 2022-03-05 01:24:10 UTC
Created attachment 300534 [details]
dmesg.log

Laptop: ThinkPad X1C 9th,

Fedora 35 64bit

After upgraded Fedroa 35 to Kernel 5.16.10. Laptop in s2idle suspend is still drain battery quickly.

The Red led on the top is breathing it seems laptop is in suspend mode. But it's also running hot with fan.

I checked the dmesg log and it looks like a s2idle EC issue.

It's normal with kernel 5.16.9

There is:

  ACPI: PM: s2idle: Cancel wakeup before dispatching EC GPE

in Kernel 5.16.10 changelog,maybe something to do with this.

Somethread with this issue:

https://bbs.archlinux.org/viewtopic.php?id=274292

https://bugzilla.redhat.com/show_bug.cgi?id=2057909
Comment 1 Artem S. Tashkinov 2022-03-05 10:03:33 UTC
It's very unlikely you'll get any help unless you git bisect this issue.
Comment 2 Zhang Rui 2022-06-27 03:06:35 UTC
As this is a 5.16.10 regression, please run git bisect to find out which commit introduces the issue.

if you suspect this commit "ACPI: PM: s2idle: Cancel wakeup before dispatching EC GPE" introduces the issue, please confirm if the problem still exists with the commit reverted.
Comment 3 plum 2022-06-27 03:37:32 UTC
It seems this issue is solved in Kernel 5.17

By the way in Kernel 5.18 suspend is broken again.
https://bugzilla.kernel.org/show_bug.cgi?id=215768

But that's another issue

Note You need to log in before you can comment on or make changes to this bug.