Bug 215658 - arch/powerpc/mm/mmu_context.o Assembler messages: Error: unrecognized opcode: `dssall' (PowerMac G4)
Summary: arch/powerpc/mm/mmu_context.o Assembler messages: Error: unrecognized opcode:...
Status: RESOLVED INVALID
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-32 (show other bugs)
Hardware: PPC-32 Linux
: P1 normal
Assignee: platform_ppc-32
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-04 08:07 UTC by Erhard F.
Modified: 2022-03-10 13:25 UTC (History)
2 users (show)

See Also:
Kernel Version: 5.16.12
Tree: Mainline
Regression: Yes


Attachments
kernel .config (5.16.12, PowerMac G4 DP) (107.59 KB, text/plain)
2022-03-04 08:07 UTC, Erhard F.
Details

Description Erhard F. 2022-03-04 08:07:56 UTC
Created attachment 300528 [details]
kernel .config (5.16.12, PowerMac G4 DP)

5.16.12 kernel build for my G4 DP on my Talos II fails with:

[...]
  CC      arch/powerpc/mm/init_32.o
  CC      arch/powerpc/mm/pgtable_32.o
  CC      arch/powerpc/mm/pgtable-frag.o
  CC      arch/powerpc/mm/ioremap.o
  CC      arch/powerpc/mm/ioremap_32.o
  CC      arch/powerpc/mm/init-common.o
  CC      arch/powerpc/mm/mmu_context.o
{standard input}: Assembler messages:
{standard input}:30: Error: unrecognized opcode: `dssall'
make[2]: *** [scripts/Makefile.build:287: arch/powerpc/mm/mmu_context.o] Fehler 1
make[1]: *** [scripts/Makefile.build:549: arch/powerpc/mm] Fehler 2
make: *** [Makefile:1846: arch/powerpc] Error 2


This seems to have been introduced by commit d51f86cfd8e378d4907958db77da3074f6dce3ba "powerpc/mm: Switch obsolete dssall to .long"

Reverting this commit fixes the build for my G4.
Comment 1 Christophe Leroy 2022-03-10 11:23:47 UTC
This description is puzzling.

Commit d51f86cfd8e3 ("powerpc/mm: Switch obsolete dssall to .long") is not in v5.16.12

For me, applying that commit to v5.16.12 should fix your problem, not the reverse.
Comment 2 Erhard F. 2022-03-10 13:25:32 UTC
This was Gentoo Sources v5.16.12 not upstream sources. But now I am not able to reproduce it which is even more strange... Also Gentoos' v5.16.13 builds ok.

What I did in the meantime was downgrading to binutils 2.37 (had 2.38 before) and rebuilding the toolchain afterwards.

So this probably was never a bug but an issue with my setup. ;) Closing here.

Note You need to log in before you can comment on or make changes to this bug.