Bug 215546 - High IRQ 16 CPU usage
Summary: High IRQ 16 CPU usage
Status: RESOLVED DUPLICATE of bug 215533
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCI (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: drivers_pci@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-30 04:24 UTC by David Spencer
Modified: 2022-01-31 19:06 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.16
Tree: Mainline
Regression: No


Attachments
dmesg output (82.89 KB, text/plain)
2022-01-30 04:24 UTC, David Spencer
Details
lspci output (14.46 KB, text/plain)
2022-01-30 04:25 UTC, David Spencer
Details

Description David Spencer 2022-01-30 04:24:49 UTC
Created attachment 300347 [details]
dmesg output

System:
Dell XPS 9550 (2015)
Distro:
Arch Linux

On 5.15 and 5.16 kernels, if my laptop is plugged in prior to booting or is plugged in at any time after booting I see high CPU usage (80-100% of a core) by IRQ 16, with a constant 15k+ IRQ events per second, whether the system is in use or not. Unplugging the laptop does not make the events stop. If I boot the system without it being plugged in the issue does not occur until I plug it in. Downgrading to 5.14 fixes the issue completely, with only 3 total IRQ 16 interrupts after the system as been running for > 20 minutes. I do not see IRQ16 interrupts increase by using the touch pad, keyboard, or touch screen. I believe I was able to bisect the introduction of the issue to commit 357cf0cdddceea974a7d32668a0df0d9f77055cb, but this was the first time I've done kernel bisects before, so I may be incorrect. I tested with 5.17 RC1 and the issue was still present.

I've attached dmesg output and the contents of lspci -vvvv, as well as included IRQ 16 info from /proc/interrupts. Please let me know if I can provide anything else.

/proc/interrupts:
  16:          0          0    7513443          0          0          0          0          0  IR-IO-APIC   16-fasteoi   idma64.0, i801_smbus, i2c_designware.0
Comment 1 David Spencer 2022-01-30 04:25:37 UTC
Created attachment 300348 [details]
lspci output
Comment 2 David Spencer 2022-01-30 04:32:02 UTC
I think I was incorrect when I said it was in kernel 5.15, when I was bisecting to find the issue the Makefile release information said 5.15-rc2 so I assumed it was in 5.15, but that looks like I was incorrect. I'll test on 5.15 and verify whether it is present there.
Comment 3 David Spencer 2022-01-30 05:41:37 UTC
I've confirmed that I do not see the issue on kernel 5.15, only on 5.16.
Comment 4 joey.corleone 2022-01-31 12:49:00 UTC
Duplicate of https://bugzilla.kernel.org/show_bug.cgi?id=215533.

Thanks for adding your observations on the IRQ events though.
Comment 5 David Spencer 2022-01-31 19:06:05 UTC
Agreed, marked as duplicate.

*** This bug has been marked as a duplicate of bug 215533 ***

Note You need to log in before you can comment on or make changes to this bug.