Bug 215401 - iwlwifi loosing connection to AP (regression from 5.4.143)
Summary: iwlwifi loosing connection to AP (regression from 5.4.143)
Status: RESOLVED UNREPRODUCIBLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless-intel (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Default virtual assignee for network-wireless-intel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-23 20:25 UTC by Martin Mokrejs
Modified: 2022-02-02 23:57 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.4.167
Tree: Mainline
Regression: No


Attachments
dmesg-5.4.167.txt (146.05 KB, text/plain)
2021-12-23 20:25 UTC, Martin Mokrejs
Details

Description Martin Mokrejs 2021-12-23 20:25:45 UTC
Created attachment 300133 [details]
dmesg-5.4.167.txt

Hi,
  I jumped from 5.4.143 to 5.4.167 but the connection to wifi was so unstable I had to reboot to use the old kernel. I never used git bisect and am not sure I have that much time to play with that. However, let me say that I lost about 5x connection to AP. Sooner or later after each situation I disconnected from the AP using nm-applet and re-connected. That has helped for a short while, liek a few minutes, then I again lost network connection. Maybe you can find the event in the dmesg output.

  Once, for some reason, there is also a stacktrace from the kernel. Why just onceinstead of about 5 times I have no idea.

  I could provide the same kernel messages supplemented with daemon messages from syslog.

Hope this helps to some extent,
Comment 1 Thorsten Leemhuis 2022-01-30 09:59:11 UTC
Just wondering: is this issue still present in the latest 5.4 kernel? If it is it would be a great help to bisect this
Comment 2 Martin Mokrejs 2022-02-02 23:55:17 UTC
Hi,
  indeed I was already thinking to report back. I recompile dteh kernel with extra debug info but since then I am using this 5.4.167 kernel which I believed suffered from a regression. I have to admit it must have been a temporary wifi issue not related to my Linux device. if I could speculate, maybe it was related to speed negotiation or some re-keying.

  These messages were logged time to time.

[674957.141940] userif-2: sent link down event.
[674957.141945] userif-2: sent link up event.
[676532.057814] userif-2: sent link down event.
[676532.057819] userif-2: sent link up event.
[678107.096258] userif-2: sent link down event.
[678107.096263] userif-2: sent link up event.
[679682.298049] userif-2: sent link down event.
[679682.298055] userif-2: sent link up event.
[681257.025414] userif-2: sent link down event.
[681257.025419] userif-2: sent link up event.
[682832.324419] userif-2: sent link down event.
[682832.324424] userif-2: sent link up event.
[684407.011530] userif-2: sent link down event.
[684407.011535] userif-2: sent link up event.
[685982.598926] userif-2: sent link down event.
[685982.598927] userif-2: sent link up event.
[687557.098667] userif-2: sent link down event.
[687557.098672] userif-2: sent link up event.
[687782.108076] Rekeying PTK for STA 00:78:88:a4:76:1f but driver can't safely do that.
[687785.108726] wlp1s0: deauthenticated from 00:78:88:a4:76:1f (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
[687785.308905] userif-2: sent link down event.
[687785.308906] userif-2: sent link up event.
[687786.619934] wlp1s0: authenticate with 00:78:88:a4:76:1f
[687786.629229] wlp1s0: send auth to 00:78:88:a4:76:1f (try 1/3)
[687786.631163] wlp1s0: authenticated
[687786.637285] wlp1s0: associate with 00:78:88:a4:76:1f (try 1/3)
[687786.638951] wlp1s0: RX AssocResp from 00:78:88:a4:76:1f (capab=0x1111 status=0 aid=3)
[687786.641025] wlp1s0: associated
[687786.672756] wlp1s0: Limiting TX power to 17 dBm as advertised by 00:78:88:a4:76:1f
Comment 3 Martin Mokrejs 2022-02-02 23:57:24 UTC
# dmesg |  grep -B 4 -A 4 HANDS
[207763.925468] userif-2: sent link up event.
[209339.188608] userif-2: sent link down event.
[209339.188613] userif-2: sent link up event.
[209564.332637] Rekeying PTK for STA 00:78:88:a4:76:1f but driver can't safely do that.
[209567.335854] wlp1s0: deauthenticated from 00:78:88:a4:76:1f (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
[209567.536140] userif-2: sent link down event.
[209567.536142] userif-2: sent link up event.
[209568.360180] wlp1s0: authenticate with 00:78:88:a4:76:1f
[209568.369435] wlp1s0: send auth to 00:78:88:a4:76:1f (try 1/3)
--
[685982.598927] userif-2: sent link up event.
[687557.098667] userif-2: sent link down event.
[687557.098672] userif-2: sent link up event.
[687782.108076] Rekeying PTK for STA 00:78:88:a4:76:1f but driver can't safely do that.
[687785.108726] wlp1s0: deauthenticated from 00:78:88:a4:76:1f (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
[687785.308905] userif-2: sent link down event.
[687785.308906] userif-2: sent link up event.
[687786.619934] wlp1s0: authenticate with 00:78:88:a4:76:1f
[687786.629229] wlp1s0: send auth to 00:78:88:a4:76:1f (try 1/3)
--
[867770.825801] userif-2: sent link up event.
[869345.857771] userif-2: sent link down event.
[869345.857773] userif-2: sent link up event.
[869797.404220] Rekeying PTK for STA 00:78:88:a4:76:1f but driver can't safely do that.
[869800.383105] wlp1s0: deauthenticated from 00:78:88:a4:76:1f (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
[869800.583282] userif-2: sent link down event.
[869800.583288] userif-2: sent link up event.
[869801.713964] wlp1s0: authenticate with 00:78:88:a4:76:1f
[869801.723195] wlp1s0: send auth to 00:78:88:a4:76:1f (try 1/3)

Note You need to log in before you can comment on or make changes to this bug.