Bug 215317 - Unable to launch QEMU Linux guest VM - "Guest has not initialized the display (yet)"
Summary: Unable to launch QEMU Linux guest VM - "Guest has not initialized the display...
Status: RESOLVED CODE_FIX
Alias: None
Product: Virtualization
Classification: Unclassified
Component: kvm (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: virtualization_kvm
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-13 01:38 UTC by Richard Herbert
Modified: 2021-12-20 05:32 UTC (History)
3 users (show)

See Also:
Kernel Version: 5.16.0-rc4
Tree: Mainline
Regression: No


Attachments
qemu-kvm stack trace kernel 5.16.0-rc5 (2.69 KB, text/plain)
2021-12-14 04:25 UTC, Richard Herbert
Details

Description Richard Herbert 2021-12-13 01:38:39 UTC
Something changed between kernel 5.16.0-rc3 and -rc4, and remains unfixed between -rc4 and -rc5. Attempting to start a QEMU VM, the display is stuck at "Guest has not initialized the display (yet)". The QEMU version I'm trying is 6.2.0-rc4, but QEMU version 6.1.0 has also been tried. I noticed many changes in the KVM code between Linux 5.16.0-rc3 and 5.16.0-rc4, and I apologize for not being able to narrow it down.
Comment 1 Richard Herbert 2021-12-14 04:25:51 UTC
Created attachment 300019 [details]
qemu-kvm stack trace kernel 5.16.0-rc5

Qemu-kvm bug when starting VM with kernel 5.16.0-rc5.
Comment 2 The Linux kernel's regression tracker (Thorsten Leemhuis) 2021-12-14 09:10:06 UTC
Hi, this is your Linux kernel regression tracker speaking.

[TLDR: adding this regression to regzbot; most of this mail is compiled
from a few templates paragraphs some of you might have seen already.]

On 13.12.21 02:38, bugzilla-daemon@bugzilla.kernel.org wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=215317
> [...]
> Something changed between kernel 5.16.0-rc3 and -rc4, and remains unfixed
> between -rc4 and -rc5. Attempting to start a QEMU VM, the display is stuck at
> "Guest has not initialized the display (yet)". The QEMU version I'm trying is
> 6.2.0-rc4, but QEMU version 6.1.0 has also been tried. I noticed many changes
> in the KVM code between Linux 5.16.0-rc3 and 5.16.0-rc4, and I apologize for
> not being able to narrow it down.

Thanks for the report.

Adding the regression mailing list to the list of recipients, as it
should be in the loop for all regressions, as explained here:
https://www.kernel.org/doc/html/latest/admin-guide/reporting-issues.html

To be sure this issue doesn't fall through the cracks unnoticed, I'm
adding it to regzbot, my Linux kernel regression tracking bot:

#regzbot ^introduced v5.16-rc3..v5.16-rc4
#regzbot title Unable to launch QEMU Linux guest VM - "Guest has not
initialized the display (yet)"
#regzbot ignore-activity
#regzbot link: https://bugzilla.kernel.org/show_bug.cgi?id=215317

Reminder: when fixing the issue, please add a 'Link:' tag with the URL
to the report (the parent of this mail), then regzbot will automatically
mark the regression as resolved once the fix lands in the appropriate
tree. For more details about regzbot see footer.

Sending this to everyone that got the initial report, to make all aware
of the tracking. I also hope that messages like this motivate people to
directly get at least the regression mailing list and ideally even
regzbot involved when dealing with regressions, as messages like this
wouldn't be needed then.

Don't worry, I'll send further messages wrt to this regression just to
the lists (with a tag in the subject so people can filter them away), as
long as they are intended just for regzbot. With a bit of luck no such
messages will be needed anyway.

Ciao, Thorsten (wearing his 'Linux kernel regression tracker' hat).

P.S.: As a Linux kernel regression tracker I'm getting a lot of reports
on my table. I can only look briefly into most of them. Unfortunately
therefore I sometimes will get things wrong or miss something important.
I hope that's not the case here; if you think it is, don't hesitate to
tell me about it in a public reply. That's in everyone's interest, as
what I wrote above might be misleading to everyone reading this; any
suggestion I gave thus might sent someone reading this down the wrong
rabbit hole, which none of us wants.

BTW, I have no personal interest in this issue, which is tracked using
regzbot, my Linux kernel regression tracking bot
(https://linux-regtracking.leemhuis.info/regzbot/). I'm only posting
this mail to get things rolling again and hence don't need to be CC on
all further activities wrt to this regression.
Comment 3 Sean Christopherson 2021-12-14 16:30:33 UTC
This is my goof.  We're bikeshedding over a minor detail, but the fix should definitely be in rc6.

https://lore.kernel.org/all/20211209060552.2956723-2-seanjc@google.com/
Comment 4 The Linux kernel's regression tracker (Thorsten Leemhuis) 2021-12-20 03:41:58 UTC
(In reply to Sean Christopherson from comment #3)
> This is my goof.  We're bikeshedding over a minor detail, but the fix should
> definitely be in rc6.
> 
> https://lore.kernel.org/all/20211209060552.2956723-2-seanjc@google.com/

Thx, the fix landed now:

#regzbot fixed-by: 18c841e1f4112d3fb742aca3429e84117fcb1e1c
Comment 5 Richard Herbert 2021-12-20 05:32:26 UTC
Perfect!  Thanks to all!

Note You need to log in before you can comment on or make changes to this bug.