Bug 215239 - rtw88_8821ce pci bus timeout
Summary: rtw88_8821ce pci bus timeout
Status: RESOLVED DUPLICATE of bug 215131
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-06 09:11 UTC by Jian-Hong Pan
Modified: 2021-12-13 07:52 UTC (History)
0 users

See Also:
Kernel Version: 5.16-rc4
Tree: Mainline
Regression: No


Attachments
Full dmesg log (147.71 KB, text/plain)
2021-12-06 09:11 UTC, Jian-Hong Pan
Details

Description Jian-Hong Pan 2021-12-06 09:11:47 UTC
Created attachment 299913 [details]
Full dmesg log

I tested kernel 5.16-rc4 on the laptop equipped with the Realtek RTL8821CE WiFi adapter.  It recognizes the RTL8821CE type 4 chip.  However, it keeps showing error: 'rtw_8821ce 0000:02:00.0: pci bus timeout, check dma status'.

Here is the related log:

[    7.266469] rtw_8821ce 0000:02:00.0: enabling device (0000 -> 0003)
[    7.272050] rtw_8821ce 0000:02:00.0: Firmware version 24.8.0, H2C version 12
[    7.355882] rtw_8821ce 0000:02:00.0 wlo1: renamed from wlan0
[   20.976995] rtw_8821ce 0000:02:00.0: start vif 20:4e:f6:77:ca:87 on port 0
[   20.981375] rtw_8821ce 0000:02:00.0: stop vif 20:4e:f6:77:ca:87 on port 0
[   21.438262] rtw_8821ce 0000:02:00.0: start vif 1a:1c:bb:02:af:b0 on port 0
[   26.033725] rtw_8821ce 0000:02:00.0: stop vif 1a:1c:bb:02:af:b0 on port 0
[   26.498292] rtw_8821ce 0000:02:00.0: start vif 20:4e:f6:77:ca:87 on port 0
[   30.599807] wlo1: authenticate with 3c:7c:3f:e8:a7:6c
[   31.087769] wlo1: send auth to 3c:7c:3f:e8:a7:6c (try 1/3)
[   31.089905] wlo1: authenticated
[   31.110747] wlo1: associate with 3c:7c:3f:e8:a7:6c (try 1/3)
[   31.113375] wlo1: RX AssocResp from 3c:7c:3f:e8:a7:6c (capab=0x1011 status=0 aid=4)
[   31.113425] rtw_8821ce 0000:02:00.0: sta 3c:7c:3f:e8:a7:6c joined with macid 0
[   31.114153] wlo1: associated
[   31.221094] IPv6: ADDRCONF(NETDEV_CHANGE): wlo1: link becomes ready
[   31.611729] rtw_8821ce 0000:02:00.0: failed to get tx report from firmware
[   34.274689] rfkill: input handler disabled
[   36.937904] rtw_8821ce 0000:02:00.0: timed out to flush queue 1
[   37.047903] rtw_8821ce 0000:02:00.0: timed out to flush queue 2
[   37.157906] rtw_8821ce 0000:02:00.0: timed out to flush queue 1
[   37.267904] rtw_8821ce 0000:02:00.0: timed out to flush queue 2
[   45.405568] rfkill: input handler enabled
[   76.513937] rfkill: input handler disabled
[   82.702142] rfkill: input handler enabled
[   95.560868] rfkill: input handler disabled
[   97.131937] (heduled1) (1619) used greatest stack depth: 12944 bytes left
[   98.015833] rtw_8821ce 0000:02:00.0: firmware failed to leave lps state
[  101.983721] rtw_8821ce 0000:02:00.0: firmware failed to leave lps state
[  102.077449] gdm-session-wor (521): drop_caches: 2
[  105.987944] rtw_8821ce 0000:02:00.0: pci bus timeout, check dma status
[  105.987966] rtw_8821ce 0000:02:00.0: pci bus timeout, check dma status
...
Comment 1 Jian-Hong Pan 2021-12-09 07:25:23 UTC
Forgot to mention:  This error leads system hangs up, after it keeps showing awhile.
Comment 2 Jian-Hong Pan 2021-12-09 08:07:46 UTC
Tried to disable PCI ASPM support by appending `rtw88_pci.disable_aspm=1` into boot command, then 'pci bus timeout, check dma status' error disappears.

Can only use this as the temporary workaround ...
Comment 3 Jian-Hong Pan 2021-12-13 07:52:41 UTC
According to the discussion [1], this is the bug same as Realtek 8821CE makes the system freeze after 9e2fd29864c5 ("rtw88: add napi support").

[1]: https://patchwork.kernel.org/project/netdevbpf/patch/20211210081659.4621-1-jhp@endlessos.org/

*** This bug has been marked as a duplicate of bug 215131 ***

Note You need to log in before you can comment on or make changes to this bug.