Bug 214297 - bnx2x driver appears broken on 5.4.126 when using 6+ network interfaces. bnx2x: probe of 0000:06:00.X failed with error -22
Summary: bnx2x driver appears broken on 5.4.126 when using 6+ network interfaces. bnx2...
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: Other Linux
: P1 normal
Assignee: drivers_network@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-02 18:33 UTC by Alex Botelho
Modified: 2021-09-29 22:35 UTC (History)
2 users (show)

See Also:
Kernel Version: 5.4.126 and 5.14.0
Tree: Mainline
Regression: No


Attachments
boot error (273.53 KB, image/png)
2021-09-02 18:33 UTC, Alex Botelho
Details

Description Alex Botelho 2021-09-02 18:33:47 UTC
Created attachment 298649 [details]
boot error

We are running HPE ProLiant BL460c Gen9 blades, and encountering this issue.

On booting, we see "bnx2x: probe of 0000:06:00.X  failed with error -22" where we have an X for every interface that doesn't appear once booted. In the case of blades that use iSCSI boot, we drop to a dracut prompt because root cannot be found.

5.4.125 boots fine, but 5.4.126 does not. We also tried 5.14.0, and that does not work either.

We are seeing this issue on CentOS 7 using the kernel-lt and kernel-ml packages provided by ELRepo.

I've attached a screen capture taken from the HPE ILO web GUI console.

Apologies if there is a lack of detail, this is my first bug report against the Linux kernel. Please let me know if there is anything more specific I can provide.
Comment 1 Alex Botelho 2021-09-02 19:10:27 UTC
As a note, digging deeper, I've found other bug reports downstream seeing this issue: https://bugzilla.proxmox.com/show_bug.cgi?id=3558
Comment 2 Alex Botelho 2021-09-29 16:10:59 UTC
It appears the Proxmox bug report references an upstream fix that has been applied to the Proxmox kernel which has resolved the issue. I am unsure what patch is being referred to or where progress is being tracked.
Comment 3 Alex Botelho 2021-09-29 22:35:51 UTC
It looks like commit 2f725420339eefe283cc1d8035015e5768e8eee0 has resolved the issue.

Closing.

Cheers.

Note You need to log in before you can comment on or make changes to this bug.