Bug 214079 - [xfstests xfs/168] xfs_repair failed with shrinking 776672
Summary: [xfstests xfs/168] xfs_repair failed with shrinking 776672
Status: RESOLVED DUPLICATE of bug 214077
Alias: None
Product: File System
Classification: Unclassified
Component: XFS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: FileSystem/XFS Default Virtual Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-16 12:45 UTC by Zorro Lang
Modified: 2021-08-20 13:20 UTC (History)
1 user (show)

See Also:
Kernel Version: v5.14-rc4 + xfs-5.15-merge-1
Tree: Mainline
Regression: No


Attachments
xfs-168.full file (28.85 KB, text/plain)
2021-08-16 12:46 UTC, Zorro Lang
Details

Description Zorro Lang 2021-08-16 12:45:48 UTC
xfstests xfs/168 fails on ppc64le with xfs-linux kernel xfs-5.15-merge-1:

FSTYP         -- xfs (debug)
PLATFORM      -- Linux/ppc64le ibm-p9z-06-lp1 5.14.0-rc4+ #1 SMP Mon Aug 16 05:26:46 EDT 2021
MKFS_OPTIONS  -- -f -m crc=1,finobt=1,reflink=1,rmapbt=1,bigtime=1,inobtcount=1 -b size=1024 /dev/sda3
MOUNT_OPTIONS -- -o context=system_u:object_r:root_t:s0 /dev/sda3 /mnt/xfstests/scratch

xfs/168	[failed, exit status 1]- output mismatch (see /var/lib/xfstests/results//xfs/168.out.bad)
    --- tests/xfs/168.out	2021-08-16 08:00:55.599141174 -0400
    +++ /var/lib/xfstests/results//xfs/168.out.bad	2021-08-16 08:03:59.237993851 -0400
    @@ -1,2 +1,3 @@
     QA output created by 168
    -Silence is golden
    +xfs_repair failed with shrinking 776672
    +(see /var/lib/xfstests/results//xfs/168.full for details)
    ...
    (Run 'diff -u /var/lib/xfstests/tests/xfs/168.out /var/lib/xfstests/results//xfs/168.out.bad'  to see the entire diff)
Ran: xfs/168
Failures: xfs/168
Failed 1 of 1 tests


Part of .full output:
...
...
xfs_growfs: XFS_IOC_FSGROWFSDATA xfsctl failed: No space left on device
meta-data=/dev/sda3              isize=512    agcount=2, agsize=517120 blks
         =                       sectsz=512   attr=2, projid32bit=1
         =                       crc=1        finobt=1, sparse=1, rmapbt=1
         =                       reflink=1    bigtime=1 inobtcount=1
data     =                       bsize=1024   blocks=776673, imaxpct=25
         =                       sunit=0      swidth=0 blks
naming   =version 2              bsize=4096   ascii-ci=0, ftype=1
log      =internal log           bsize=1024   blocks=6011, version=2
         =                       sectsz=512   sunit=0 blks, lazy-count=1
realtime =none                   extsz=4096   blocks=0, rtextents=0
fsstress: check_cwd failure
fsstress: check_cwd failure
fsstress: check_cwd failure
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
xfs_growfs: /mnt/xfstests/scratch is not a mounted XFS filesystem
Phase 1 - find and verify superblock...
Phase 2 - using internal log
        - zero log...
ALERT: The filesystem has valuable metadata changes in a log which is being
ignored because the -n option was used.  Expect spurious inconsistencies
which may be resolved by first mounting the filesystem to replay the log.
        - scan filesystem freespace and inode maps...
        - found root inode chunk
Phase 3 - for each AG...
        - scan (but don't clear) agi unlinked lists...
        - process known inodes and perform inode discovery...
        - agno = 0
        - agno = 1
        - process newly discovered inodes...
Phase 4 - check for duplicate blocks...
        - setting up duplicate extent list...
        - check for inodes claiming duplicate blocks...
        - agno = 0
        - agno = 1
No modify flag set, skipping phase 5
Phase 6 - check inode connectivity...
        - traversing filesystem ...
        - traversal finished ...
        - moving disconnected inodes to lost+found ...
Phase 7 - verify link counts...
No modify flag set, skipping filesystem flush and exiting.
xfs_repair failed with shrinking 776672

Please check the attachment to get full .full output file
Comment 1 Zorro Lang 2021-08-16 12:46:37 UTC
Created attachment 298335 [details]
xfs-168.full file
Comment 2 Artem S. Tashkinov 2021-08-20 13:20:48 UTC

*** This bug has been marked as a duplicate of bug 214077 ***

Note You need to log in before you can comment on or make changes to this bug.