Bug 213977 - Unable to lock HW IRQ 44 :: TigerLake Proc :: Clevo NH58HPQ
Summary: Unable to lock HW IRQ 44 :: TigerLake Proc :: Clevo NH58HPQ
Status: RESOLVED DUPLICATE of bug 213579
Alias: None
Product: Drivers
Classification: Unclassified
Component: Platform_x86 (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: drivers_platform_x86@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-04 19:52 UTC by Ben Long
Modified: 2021-08-05 08:40 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.13.6-200
Tree: Mainline
Regression: No


Attachments
acpidump -o clevo-tables.dat (1.90 MB, text/plain)
2021-08-04 19:52 UTC, Ben Long
Details

Description Ben Long 2021-08-04 19:52:54 UTC
Created attachment 298201 [details]
acpidump -o clevo-tables.dat

Hey,

I was told to open another report with an acpi dump. I do not have anything else custom in my kernel except for including the .patch file in the following post. I added to the .patch file to the SOURCES dir and added in to the kernel.spec and rebuilt the kernel package and installed it. Still getting the below error. 

RE: https://bugzilla.kernel.org/show_bug.cgi?id=213579

[  924.443744] tigerlake-pinctrl INT34C6:00: pin 57 cannot be used as IRQ
[  924.443746] genirq: Setting trigger mode 8 for irq 131 failed (intel_gpio_irq_type+0x0/0x130)
[  924.448165] gpio gpiochip0: (INT34C6:00): gpiochip_lock_as_irq: cannot get GPIO direction
[  924.448166] gpio gpiochip0: (INT34C6:00): unable to lock HW IRQ 44 for IRQ
[  924.448167] genirq: Failed to request resources for ELAN0412:01 (irq 131) on irqchip INT34C6:00
[  924.448174] i2c_hid_acpi i2c-ELAN0412:01: Could not register for ELAN0412:01 interrupt, irq = 131, ret = -22
[  924.448201] i2c_hid_acpi: probe of i2c-ELAN0412:01 failed with error -22
Comment 1 Ben Long 2021-08-04 20:53:53 UTC
Sorry, please close this out.

My Response from the other thread.

Hey Again,

So, yeah, I didn't patch the kernel, terribly sorry. Been a minute aince I had to patch something and I was just running -bb flag, using -ba or -bp and then -bb fixed the patch issue.

And with that, I can confirm that this is fixed on my Clevo NH58HPQ.

It also fixed another weird bug where the keyboard waits for the screen to poll (a little horz liine would go through each line of grub) and keyboard wouldnt be usable until that got to the bottom. Keyboard works fine now as soon as grub starts.

Thanks guys! Cant wait for it to hit upstream.
Comment 2 Ben Long 2021-08-04 21:21:03 UTC
The patch posted in the referenced report actually does work.
Comment 3 Andy Shevchenko 2021-08-05 08:40:05 UTC

*** This bug has been marked as a duplicate of bug 23 ***
Comment 4 Andy Shevchenko 2021-08-05 08:40:24 UTC

*** This bug has been marked as a duplicate of bug 213579 ***

Note You need to log in before you can comment on or make changes to this bug.