Bug 213939 - Intel wifi card "Killer Wi-Fi 6 AX1650 (2x2)" in new Dell XPS 15 doesn't work with kernel 5.10.x versions
Summary: Intel wifi card "Killer Wi-Fi 6 AX1650 (2x2)" in new Dell XPS 15 doesn't work...
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless-intel (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Default virtual assignee for network-wireless-intel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-01 19:39 UTC by Julien Wajsberg
Modified: 2021-08-28 10:39 UTC (History)
3 users (show)

See Also:
Kernel Version: 5.10.54
Tree: Mainline
Regression: No


Attachments

Description Julien Wajsberg 2021-08-01 19:39:47 UTC
Hi,

I just successfully installed the latest version of Debian testing bullseye on a brand new Dell XPS 15, but I got some issues with the integrated WiFi card. Of course I installed the non-free firmware.

The Linux image package is linux-image-5.10.0-8-amd64, version 5.10.46-2.
I also tried version 5.10.54 from kernel.org.

Here is the log (grepped for iwlwifi):

```
[   14.352938] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[   14.358907] iwlwifi: No config found for PCI dev 43f0/1651,
rev=0x354, rfid=0x10a100
[   14.368948] iwlwifi: probe of 0000:00:14.3 failed with error -22
```

Then I tried to install the latest stable kernel version (5.13.6), I built it and installed, and now the WiFi card works just fine ! Here is the log of the working kernel:

```
[   67.899239] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[   67.901544] iwlwifi 0000:00:14.3: Direct firmware load for
iwlwifi-QuZ-a0-hr-b0-63.ucode failed with error -2
[   67.903867] iwlwifi 0000:00:14.3: api flags index 2 larger than
supported by driver
[   67.904108] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version:
89.3.35.37
[   67.904350] iwlwifi 0000:00:14.3: loaded firmware version 62.49eeb572.0
QuZ-a0-hr-b0-62.ucode op_mode iwlmvm
[   67.916597] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX203,
REV=0x354
[   68.104800] iwlwifi 0000:00:14.3: base HW address: 4c:79:6e:d9:d7:c1
[   68.649015] iwlwifi 0000:00:14.3 wlp0s20f3: renamed from wlan0
```

According to Dell, it's supposed to be "Killer Wi-Fi 6 AX1650 (2x2)" but it looks like the linux kernel doesn't agree.

While looking at this problem, I found other some strange issues.

It looks like that that the lines for this device were in the kernel since 5.1 [1] but were removed in 5.8 [2]. So v5.10 includes this change.
I'm not understanding this change properly, and I'm not sure what could have brought the support back between 5.10 and 5.13. I'd be happy to try a patch on my machine, and answer any additional question you may have.

Thanks!

[1] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=5b74a9368958d9d424425f6e89b59fed49df6f96
[2]
https://lore.kernel.org/r/iwlwifi.20200424194456.ec0e04102d2c.Ia36f2c7bbf06cb6436424d40d6adb2376f2962ee@changeid

See also the debian bug I reported about this: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=991712
Comment 1 Julien Wajsberg 2021-08-01 20:26:57 UTC
I forgot that the goal would be to find a commit to backport in 5.10.
Comment 2 Juan Francisco 2021-08-28 10:39:24 UTC
Hi, I have the same problem on my Dell XPS 17 9710.

Note You need to log in before you can comment on or make changes to this bug.