Bug 213419 - Outdated limitation for powerpc in vdso(7)
Summary: Outdated limitation for powerpc in vdso(7)
Status: RESOLVED DOCUMENTED
Alias: None
Product: Documentation
Classification: Unclassified
Component: man-pages (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: documentation_man-pages@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-12 06:47 UTC by Christophe Leroy
Modified: 2021-07-03 16:50 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description Christophe Leroy 2021-06-12 06:47:44 UTC
https://man7.org/linux/man-pages/man7/vdso.7.html (as of today, flagged 2021-03-22)

ppc/32 and ppc/64 sections both have the following note:

The CLOCK_REALTIME_COARSE and CLOCK_MONOTONIC_COARSE clocks are
       not supported by the __kernel_clock_getres and
       __kernel_clock_gettime interfaces; the kernel falls back to the
       real system call

This note has been wrong from quite some time now, since commit 654abc69ef2e ("powerpc/vdso32: Add support for CLOCK_{REALTIME/MONOTONIC}_COARSE") and commit 5c929885f1bb ("powerpc/vdso64: Add support for CLOCK_{REALTIME/MONOTONIC}_COARSE")
Comment 1 Alejandro Colomar (man-pages) 2021-07-03 16:50:43 UTC
Hi Christophe,

Thanks for the report.
I applied the following patch.

Thanks,

Alex

---
Author: Alejandro Colomar <alx.manpages@gmail.com>
Date:   Sat Jul 3 18:43:16 2021 +0200

    vdso.7: Remove outdated limitation for powerpc
    
    Christophe Leroy via Bugzilla:
    
    [
    https://man7.org/linux/man-pages/man7/vdso.7.html
    (as of today, flagged 2021-03-22)
    
    ppc/32 and ppc/64 sections both have the following note:
    
           The CLOCK_REALTIME_COARSE and CLOCK_MONOTONIC_COARSE clocks
           are not supported by the __kernel_clock_getres and
           __kernel_clock_gettime interfaces; the kernel falls back to
           the real system call
    
    This note has been wrong from quite some time now,
    since commit 654abc69ef2e
    ("powerpc/vdso32: Add support for CLOCK_{REALTIME/MONOTONIC}_COARSE")
    and commit 5c929885f1bb
    ("powerpc/vdso64: Add support for CLOCK_{REALTIME/MONOTONIC}_COARSE")
    ]
    
    Reported-by: Christophe Leroy <christophe.leroy@csgroup.eu>
    Signed-off-by: Alejandro Colomar <alx.manpages@gmail.com>

diff --git a/man7/vdso.7 b/man7/vdso.7
index ef6bef5bd..1d527c38e 100644
--- a/man7/vdso.7
+++ b/man7/vdso.7
@@ -385,19 +385,6 @@ __kernel_sync_dicache_p5	LINUX_2.6.15
 .in
 .ft P
 \}
-.PP
-The
-.B CLOCK_REALTIME_COARSE
-and
-.B CLOCK_MONOTONIC_COARSE
-clocks are
-.I not
-supported by the
-.I __kernel_clock_getres
-and
-.I __kernel_clock_gettime
-interfaces;
-the kernel falls back to the real system call.
 .SS ppc/64 functions
 .\" See linux/arch/powerpc/kernel/vdso64/vdso64.lds.S
 The table below lists the symbols exported by the vDSO.
@@ -423,19 +410,6 @@ __kernel_sync_dicache_p5	LINUX_2.6.15
 .in
 .ft P
 \}
-.PP
-The
-.B CLOCK_REALTIME_COARSE
-and
-.B CLOCK_MONOTONIC_COARSE
-clocks are
-.I not
-supported by the
-.I __kernel_clock_getres
-and
-.I __kernel_clock_gettime
-interfaces;
-the kernel falls back to the real system call.
 .SS riscv functions
 .\" See linux/arch/riscv/kernel/vdso/vdso.lds.S
 The table below lists the symbols exported by the vDSO.

Note You need to log in before you can comment on or make changes to this bug.