Bug 213109 - ideapad-laptop: Regression in 5.12.x for Battery conservation mode
Summary: ideapad-laptop: Regression in 5.12.x for Battery conservation mode
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Platform_x86 (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_platform_x86@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-17 16:05 UTC by Fouad
Modified: 2021-05-19 13:46 UTC (History)
2 users (show)

See Also:
Kernel Version: 5.12.4
Tree: Mainline
Regression: Yes


Attachments

Description Fouad 2021-05-17 16:05:01 UTC
Enabling battery conservation mode no longer works on Linux 5.12.x for Lenovo Legion 5 15ARH05.

It works with kernel versions 5.11 and 5.10 on Arch Linux.

Modifying `/sys/bus/platform/drivers/ideapad_acpi/VPC2004:00/conservation_mode` fails with message : `Input/output error`
Comment 1 Barnabás Pőcze 2021-05-17 16:21:59 UTC
Thanks for bringing this up. The issue has already been reported in https://bugzilla.kernel.org/show_bug.cgi?id=212985 and a patch has been sent to fix it ( https://lore.kernel.org/platform-driver-x86/20210507235333.286505-1-pobrn@protonmail.com/ ).
Comment 2 Hans de Goede 2021-05-19 13:46:35 UTC
I've added the patch fixing this to the fixes branch of the pdx86 kernel tree:
https://git.kernel.org/pub/scm/linux/kernel/git/pdx86/platform-drivers-x86.git/log/?h=fixes

The contents of this branch will be in the next pdx86-fixes pull-req which I send to Linus for 5.13. Since the patch has a fixes tag it will get added automatically to the 5.12 kernels once Linus has merged it, so this bug can be closed now.

Note You need to log in before you can comment on or make changes to this bug.