Bug 212469 - plymouth animation freezes during shutdown
Summary: plymouth animation freezes during shutdown
Status: RESOLVED ANSWERED
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: Intel Linux
: P1 low
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-28 21:25 UTC by Amir
Modified: 2021-09-05 07:12 UTC (History)
6 users (show)

See Also:
Kernel Version: 5.11.10
Tree: Mainline
Regression: No


Attachments
plymouth animation freezes during shutdown (2.96 MB, video/quicktime)
2021-03-28 21:25 UTC, Amir
Details
cat /etc/X11/xorg.conf.d/20-intel.conf (119 bytes, text/plain)
2021-03-28 21:36 UTC, Amir
Details

Description Amir 2021-03-28 21:25:18 UTC
Created attachment 296125 [details]
plymouth animation freezes during shutdown

Overview:
    plymouth animation during shutdown freezes. the system would shutdown without 
    any problem.

Steps to reproduce:
    with plymouth installed and lightdm-plymouth/sddm-plymouth.service enabled, 
    after pressing restart or shutdown button, plymouth animation appears 
    normally then the screen would turn off and then it turn on again, this 
    time it shows a frozen plymouth animation. after about 5sec the system 
    would shutdown/restart normally.

Expected Results:
    plymouth animation will work during shutdown and won't freeze.

Build Date & Hardware:
    archlinux-kernel 5.11.6 build 1
    CPU: intel i5 7200u
    GPU: Intel HD 620 + Nivida 940mx
    Video Driver: modsettings driver for Intel HD + Nvidia-proprietary 460.67 
    in prime render offloading mode
    DE: KDE Plasma 5.21.3
    plymouth: latest git build

Additional Builds and Platforms:
    this problem doesn't occur with kernel 5.10.16.

Additional Information:
    see attached video bellow
Comment 1 Amir 2021-03-28 21:36:01 UTC
Created attachment 296127 [details]
cat /etc/X11/xorg.conf.d/20-intel.conf

I use a xorg.conf for my intel GPU. thought it might help reproducing the bug.
Comment 2 Francesco Minnocci 2021-03-29 13:43:15 UTC
I can also reproduce the same behaviour, here are my system specifications:

Build Date & Hardware
- Kernel: 5.11.10-zen1-1-zen (but can also reproduce on `linux` 5.11.10.arch1-1)
- CPU: Intel i7-7500U
- GPU: Intel HD Graphics 620 (+ nvidia 940mx, but I don't use it)
- Video Drivers: Intel modesetting driver (+ I deactivated nouveau)
- WM: dwm
- plymouth version: 0.9.5-6 from official Arch repos

I didn't customize any xorg settings for the intel video drivers.
Comment 3 Arnas 2021-04-17 13:39:36 UTC
I also have this same issue on my system. When I hit shutdown, the aniamtioj plays, then screen goes black, then turns back on and shows frozen animation, then finally shuts down.

Here is my system - 

Kernel - 5.11.14.arch1-1
CPU - Intel Core i5-1035G1
GPU - Intel UHD G1 Graphics, modesetting driver
DE - KDE Plasma 5.21.4
Plymouth - plymouth AUR package (non-git)

I can also confirm that the issue is only present from 5.11.x. The issue does not exist with kernel 5.10.16.
Comment 4 DieKleene 2021-04-26 09:40:54 UTC
Similar problem
Shutdown / restart:

Computer hangs on shutdown or restart and shows the following symptoms:
Watchdog error message and then takes up to 15 minutes to shut down / restart
Or
Computer shuts down with black screens (both monitors are switched off). But then alternately activates one of the two monitors (one remains switched off and the other is switched on).

In addition:
Occasionally only one of the two monitors is activated when the system is started. Or, both monitors are activated. But the attitudes regarding the position are no longer correct. Or: Mirror mode has been activated.

My system:

Arch Linux
XFCE


AMD Ryzen 7 2700 Eight-Core Processor
AMD Radeon (TM) R9 380 Series (TONGA, DRM 3.40.0, 5.11.16-arch1-1, LLVM 11.1.0)
The X.Org Foundation 1.20.11

Current Display Name		: :0.0
Hersteller		: The X.Org Foundation
Version		: 1.20.11
Release Number		: 12011000
-Screens-
Screen 0		: 1920x2160 pixels
-Outputs (XRandR)-
DP-1		: Disconnected; Unused
HDMI-1		: Disconnected; Unused
DVI-D-1		: Connected; 1920x1080 pixels, offset (0, 0)
DVI-D-2		: Connected; 1920x1080 pixels, offset (0, 1080)
Comment 5 Amir 2021-05-25 12:34:48 UTC
Installing plymouth built from git, resolves the issue!
Comment 6 DieKleene 2021-05-25 13:33:02 UTC
That is no solution. 
The same error occurs on Ubuntu Studio with playmouth. 

Only Sparky Linux, with Kernel 4.9, runs without any problems. 

This is a problem with the 5.x kernel. 
I've already reported a bug for this.
Comment 7 popov895 2021-06-24 08:09:38 UTC
I still don't understand, is it a kernel or plymouth issue? If it's a kernel issue, which version fixes it?

> Installing plymouth built from git, resolves the issue!
What version it was?
Comment 8 Norbert 2021-07-02 18:22:24 UTC
I tried plymouth_0.9.5git20210323-0ubuntu1_amd64 without any change.
Comment 9 Norbert 2021-07-10 07:22:25 UTC
With Linux 5.13.0-11-generic #11-Ubuntu SMP Tue Jun 29 06:57:28 UTC 2021 no change.
Comment 10 Amir 2021-07-10 07:29:07 UTC
The problem introduced with Kernel 5.10
But then I installed the git build of plymouth and it was gone! So I assume the problem brought up by changes in kernel, and plymouth patched their app to resolve the issue.
Your git build seems fairly outdated. Could you build directly from git and test again?
Comment 11 Arnas 2021-07-10 10:58:46 UTC
The problem was not introduced with 5.10, 5.10 always worked fine. The problem appeared with kernel 5.11.
Comment 12 Norbert 2021-09-05 07:12:46 UTC
The plymouth git works (Ubuntu 21.10).

Note You need to log in before you can comment on or make changes to this bug.