Bug 211707 - BUG: unable to handle page fault for address: ffffa147bdf6b91d
Summary: BUG: unable to handle page fault for address: ffffa147bdf6b91d
Status: RESOLVED OBSOLETE
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Page Allocator (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-11 14:27 UTC by Erhard F.
Modified: 2021-07-29 00:47 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.11-rc7
Tree: Mainline
Regression: No


Attachments
kernel dmesg (5.11-rc7, eMachines E620) (195.10 KB, text/plain)
2021-02-11 14:27 UTC, Erhard F.
Details
kernel .config (5.11-rc7, eMachines E620) (103.82 KB, text/plain)
2021-02-11 14:28 UTC, Erhard F.
Details
kernel dmesg (5.12-rc3, eMachines E620) (74.38 KB, text/plain)
2021-03-18 22:10 UTC, Erhard F.
Details
kernel .config (5.12-rc3, eMachines E620) (104.84 KB, text/plain)
2021-03-18 22:13 UTC, Erhard F.
Details

Description Erhard F. 2021-02-11 14:27:43 UTC
Created attachment 295231 [details]
kernel dmesg (5.11-rc7, eMachines E620)

[...]
BUG: unable to handle page fault for address: ffffa147bdf6b91d
#PF: supervisor read access in kernel mode
#PF: error_code(0x0000) - not-present page
PGD 52001067 P4D 52001067 PUD 0 
Oops: 0000 [#1] SMP NOPTI
CPU: 1 PID: 623 Comm: udevd Not tainted 5.11.0-rc7-E620 #2
Hardware name: eMachines        eMachines E620  /Nile       , BIOS V1.03       09/30/2008
RIP: 0010:get_freepointer+0x6/0x1a
Code: 89 f0 48 89 d6 48 89 ca 48 83 ef 70 49 8b 48 30 48 c7 c0 fb ff ff ff 48 85 c9 74 07 e8 f2 47 87 00 48 98 c3 8b 47 28 48 01 c6 <48> 8b 06 48 89 f2 48 33 87 b0 00 00 00 48 0f ca 48 31 d0 c3 48 8b
RSP: 0018:ffffac5c807cb898 EFLAGS: 00010286
RAX: 0000000000000030 RBX: ffffa14707082078 RCX: 000000000000022a
RDX: ffffa14702180980 RSI: ffffa147bdf6b91d RDI: ffffa14700042a00
RBP: 0000000000000dc0 R08: ffffa147bdf6b8ed R09: 0000000000000229
R10: 0000000000000000 R11: ffffa147070822d0 R12: ffffa14700042a00
R13: ffffa14700042a00 R14: 0000000000000050 R15: ffffffffc08b1d88
FS:  00007ff6aaf13b68(0000) GS:ffffa1472df00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffffa147bdf6b91d CR3: 0000000104156000 CR4: 00000000000006e0
Call Trace:
 kmem_cache_alloc_trace+0x97/0x157
 radeon_ttm_tt_create+0x21/0x66 [radeon]
 ttm_tt_create+0x8d/0xa3 [ttm]
 ttm_bo_handle_move_mem+0x85/0xf9 [ttm]
 ? radeon_update_memory_usage+0x4b/0x4b [radeon]
 ttm_bo_validate+0x138/0x1aa [ttm]
 ttm_bo_init_reserved+0x282/0x2ba [ttm]
 ttm_bo_init+0x56/0x8f [ttm]
 ? radeon_update_memory_usage+0x4b/0x4b [radeon]
 radeon_bo_create+0x17d/0x255 [radeon]
 ? radeon_update_memory_usage+0x4b/0x4b [radeon]
 radeon_ring_init+0x3e/0x12d [radeon]
 r100_cp_init+0x1ea/0x469 [radeon]
 rs690_startup+0x114/0x196 [radeon]
 ? radeon_pm_init+0x607/0x626 [radeon]
 rs690_init+0x29f/0x2eb [radeon]
 radeon_device_init+0x899/0xa7d [radeon]
 radeon_driver_load_kms+0x83/0x15c [radeon]
 drm_dev_register+0xf4/0x1bc [drm]
 radeon_pci_probe+0x134/0x178 [radeon]
 pci_device_probe+0x95/0x104
 really_probe+0x144/0x326
 driver_probe_device+0x63/0x92
 device_driver_attach+0x37/0x50
 __driver_attach+0x8d/0x93
 ? device_driver_attach+0x50/0x50
 bus_for_each_dev+0x71/0xa7
 bus_add_driver+0x106/0x1b7
 driver_register+0x99/0xd2
 ? 0xffffffffc09da000
 do_one_initcall+0xe2/0x24a
 ? trace_kmalloc+0x9a/0xc7
 ? kmem_cache_alloc_trace+0x130/0x157
 do_init_module+0x56/0x1f5
 __do_sys_finit_module+0x94/0xbb
 do_syscall_64+0x33/0x40
 entry_SYSCALL_64_after_hwframe+0x44/0xa9
RIP: 0033:0x7ff6aaea39d8
Code: 4c 89 4c 24 48 4c 8b 4c 24 60 48 89 54 24 10 48 8b 7e 08 48 89 74 24 18 48 8b 51 18 c7 44 24 08 08 00 00 00 48 8b 76 10 0f 05 <48> 89 c7 e8 40 08 fe ff 48 83 c4 58 c3 66 2e 0f 1f 84 00 00 00 00
RSP: 002b:00007fffffd2e470 EFLAGS: 00000202 ORIG_RAX: 0000000000000139
RAX: ffffffffffffffda RBX: 00007ff6aae1c9d0 RCX: 00007ff6aaea39d8
RDX: 0000000000000000 RSI: 00007ff6aae168e7 RDI: 000000000000001b
RBP: 0000000000020000 R08: 0000000000000000 R09: 00007ff6aaebb6dd
R10: 000000000000001b R11: 0000000000000202 R12: 0000000000000000
R13: 00007ff6aa487d30 R14: 00007ff6aae168e7 R15: 0000000000000000
Modules linked in: radeon(+) snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio mac80211 snd_hda_intel evdev snd_intel_dspcfg input_leds snd_hda_codec led_class ath snd_hwdep psmouse snd_hda_core i2c_algo_bit lm83 drm_ttm_helper snd_pcm ohci_pci ttm snd_timer k8temp drm_kms_helper adm1021 hwmon snd ohci_hcd ehci_pci cfbfillrect soundcore syscopyarea cfbimgblt cfg80211 ehci_hcd sysfillrect i2c_piix4 sysimgblt fb_sys_fops sr_mod usbcore cfbcopyarea usb_common cdrom drm video drm_panel_orientation_quirks rfkill fb battery libarc4 ac font fbdev backlight thermal button processor
CR2: ffffa147bdf6b91d
---[ end trace 1a80b76ad6066c81 ]---


Some data about the machine:

 # inxi -b
System:    Kernel: 5.11.0-rc7-E620 x86_64 bits: 64 Desktop: MATE 1.24.0 Distro: Gentoo Base System release 2.7 
Machine:   Type: Laptop System: eMachines product: eMachines E620 v: V1.03 serial: LXN270Y0048480D3CA1601 
           Mobo: eMachines model: Nile serial: LXN270Y0048480D3CA1601 BIOS: eMachines v: 1.03 date: 09/30/2008 
Battery:   ID-1: BAT1 charge: N/A condition: N/A 
CPU:       Info: Dual Core AMD Athlon X2 3250e [MCP] speed: 1496 MHz 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270] driver: radeon v: kernel 
           Display: x11 server: X.Org 1.20.10 driver: ati,radeon unloaded: fbdev,modesetting resolution: 1280x800~60Hz 
           OpenGL: renderer: ATI RS690 v: 2.1 Mesa 20.2.6 
Network:   Device-1: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter driver: ath5k 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
Drives:    Local Storage: total: 256.17 GiB used: 10.38 GiB (4.1%) 
Info:      Processes: 150 Uptime: 2m Memory: 3.59 GiB used: 403.2 MiB (11.0%) Shell: Bash inxi: 3.1.06 


Probably connected to bug #211537.
Comment 1 Erhard F. 2021-02-11 14:28:53 UTC
Created attachment 295233 [details]
kernel .config (5.11-rc7, eMachines E620)
Comment 2 Erhard F. 2021-03-18 22:10:14 UTC
Created attachment 295935 [details]
kernel dmesg (5.12-rc3, eMachines E620)

Same on kernel v5.12-rc3. Though a different module is affected as the stacktrace shows.

[...]
BUG: unable to handle page fault for address: ffff9f00fac8b91d
#PF: supervisor read access in kernel mode
#PF: error_code(0x0000) - not-present page
PGD 40e05067 P4D 40e05067 PUD 0 
Oops: 0000 [#1] SMP NOPTI
CPU: 0 PID: 146 Comm: systemd-udevd Not tainted 5.12.0-rc3-E620 #2
Hardware name: eMachines        eMachines E620  /Nile       , BIOS V1.03       09/30/2008
RIP: 0010:get_freepointer+0x6/0x1a
Code: 00 48 01 c7 48 c1 ef 0c 48 c1 e7 06 48 03 3d d7 4a ab 00 eb bc 66 66 66 66 90 31 c0 eb 02 b0 01 83 f0 01 c3 8b 47 28 48 01 c6 <48> 8b 06 48 89 f2 48 33 87 b0 00 00 00 48 0f ca 48 31 d0 c3 48 0f
RSP: 0018:ffffbb9dc03fbad0 EFLAGS: 00010286
RAX: 0000000000000030 RBX: ffff9f0005320c80 RCX: 000000000000091e
RDX: 0000000000400140 RSI: ffff9f00fac8b91d RDI: ffff9f0000042600
RBP: 0000000000000b20 R08: ffff9f00fac8b8ed R09: 000000000000091d
R10: ffffffffad4558b0 R11: 0000000000000002 R12: ffff9f0000042600
R13: ffff9f0000042600 R14: 0000000000000050 R15: ffffffffc0504f78
FS:  00007faa17f9bc40(0000) GS:ffff9f002de00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: ffff9f00fac8b91d CR3: 00000001049aa000 CR4: 00000000000006f0
Call Trace:
 kmem_cache_alloc_trace+0x9f/0x15f
 minstrel_ht_alloc+0x1c/0x128 [mac80211]
 ieee80211_init_rate_ctrl_alg+0x117/0x18f [mac80211]
 ieee80211_register_hw+0x7b6/0xa21 [mac80211]
 ? ath5k_txq_release+0x37/0x37 [ath5k]
 ath5k_init_ah+0xa02/0xbc0 [ath5k]
 ath5k_pci_probe+0x1c3/0x221 [ath5k]
 pci_device_probe+0x95/0x104
 really_probe+0x144/0x326
 driver_probe_device+0x63/0x92
 device_driver_attach+0x37/0x50
 __driver_attach+0x8d/0x93
 ? device_driver_attach+0x50/0x50
 bus_for_each_dev+0x71/0xa7
 bus_add_driver+0x106/0x1b7
 driver_register+0x99/0xd2
 ? 0xffffffffc0584000
 do_one_initcall+0xe2/0x24a
 ? trace_kmalloc+0x9a/0xc7
 ? kmem_cache_alloc_trace+0x138/0x15f
 do_init_module+0x56/0x1f5
 __do_sys_finit_module+0x94/0xbb
 do_syscall_64+0x33/0x40
 entry_SYSCALL_64_after_hwframe+0x44/0xae
RIP: 0033:0x7faa182e15c9
Code: 00 c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 6f 18 0c 00 f7 d8 64 89 01 48
RSP: 002b:00007ffdeaaff188 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
RAX: ffffffffffffffda RBX: 000056105093b950 RCX: 00007faa182e15c9
RDX: 0000000000000000 RSI: 00007faa18438ab5 RDI: 0000000000000013
RBP: 0000000000020000 R08: 0000000000000000 R09: 00005610509b0b80
R10: 0000000000000013 R11: 0000000000000246 R12: 00007faa18438ab5
R13: 0000000000000000 R14: 00005610509da830 R15: 000056105093b950
Modules linked in: joydev snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio ath5k(+) snd_hda_intel snd_intel_dspcfg evdev snd_hda_codec input_leds snd_hwdep led_class psmouse snd_hda_core radeon snd_pcm mac80211 k8temp snd_timer snd sr_mod soundcore cdrom hwmon i2c_algo_bit ath drm_ttm_helper ttm battery drm_kms_helper cfbfillrect syscopyarea video cfbimgblt cfg80211 sysfillrect ac sysimgblt fb_sys_fops cfbcopyarea fb rfkill libarc4 font fbdev thermal ohci_pci button i2c_piix4 ehci_pci ohci_hcd ehci_hcd usbcore usb_common processor drm drm_panel_orientation_quirks backlight fuse configfs
CR2: ffff9f00fac8b91d
---[ end trace d2130d96d0e7a74b ]---
Comment 3 Erhard F. 2021-03-18 22:13:25 UTC
Created attachment 295937 [details]
kernel .config (5.12-rc3, eMachines E620)
Comment 4 Erhard F. 2021-07-29 00:47:03 UTC
Have not seen this since bug #211537 got fixed. So this one is probably a side-effect of #211537...

Closing for now. In case I hit it again I will re-open.

Note You need to log in before you can comment on or make changes to this bug.