Bug 211569 - ath11k for Wi-Fi 6 AX500-DBS makes kernel freeze
Summary: ath11k for Wi-Fi 6 AX500-DBS makes kernel freeze
Status: RESOLVED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 high
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-04 23:38 UTC by Lucas Zanella
Modified: 2021-02-19 17:32 UTC (History)
1 user (show)

See Also:
Kernel Version: ubuntu 5.10.0-1008-oem
Tree: Mainline
Regression: No


Attachments

Description Lucas Zanella 2021-02-04 23:38:37 UTC
I'm using the athk11 kernel driver for Wi-Fi 6 AX500-DBS (I guess this is the device, I'm not sure because lspci gives me only 0000:55:00.0 Network controller: Qualcomm Device 1101 (rev 01).

It freezes my Dell XPS 9310 after some minutes of usage. 

I'm using Ubuntu with 5.10.0-1008-oem kernel, which is the latest available.

I've hear of people using it for a month and didn't have any issues, but for me I cannot use it for more than 1 hour. On the majority of times it simply freezes. Right now the wifi simply died and when I typed lspci everything froze.
Comment 1 Kalle Valo 2021-02-11 19:18:05 UTC
I don't know what Ubuntu kernels contain so I cannot comment on that. If you are able to compile the kernel on your own, I have received good feedback with tag ath11k-qca6390-bringup-202012140938 from my tree:

https://lore.kernel.org/ath11k/87blew3e4q.fsf@codeaurora.org/

What's your BIOS version? Upgrading BIOS might also help.
Comment 2 Lucas Zanella 2021-02-11 21:06:08 UTC
Thank you. I installed this ubuntu kernel because someone with XPS 15 said it was working ok for one month. I guess it has some partial changes from your tree. I currently cannot install custom kernels for security reasons. Do you know when your changes will land on the latest linux kernel on kernel.org?

I'm gonna take a look on my bios version, I have too much things opened now but I'll comment on that in the future. Thank you for your amazing work.
Comment 3 Kalle Valo 2021-02-12 06:34:53 UTC
(In reply to Lucas Zanella from comment #2)
> Thank you. I installed this ubuntu kernel because someone with XPS 15 said
> it was working ok for one month. I guess it has some partial changes from
> your tree. I currently cannot install custom kernels for security reasons.
> Do you know when your changes will land on the latest linux kernel on
> kernel.org?

Currently I know of two options to use AX500 on Dell XPS 13 9310:

1) Update BIOS to version 1.1.4 or newer, that way ath11k will get 32 MSI vectors. Upgrade kernel to v5.11-rc1 or newer, based on the reports it should work reasonably well with 32 MSI vectors. I expect Linus to release final v5.11 this Sunday. At least back in the day Ubuntu packaged mainline kernels and provided them for testing purposes.

2) If updating BIOS is not possible, tag ath11k-qca6390-bringup-202012140938 is the only option to get ath11k working 1 MSI vectors.
Comment 4 Kalle Valo 2021-02-12 06:40:42 UTC
(In reply to Kalle Valo from comment #3)
> 1) Update BIOS to version 1.1.4 or newer, that way ath11k will get 32 MSI
> vectors. Upgrade kernel to v5.11-rc1 or newer, based on the reports it
> should work reasonably well with 32 MSI vectors. I expect Linus to release
> final v5.11 this Sunday. At least back in the day Ubuntu packaged mainline
> kernels and provided them for testing purposes.

I forgot that there's one regression in v5.11 within MHI subsystem:

https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/char-misc.git/commit/?h=char-misc-next&id=db4e8de1935b0202960e9ebb88ab93e8bd1e66b1

Oddly I don't see that in my XPS 13 with AX500, I guess because I have all debug checks disabled. But I'll try to get the fix to v5.11.x stable releases.
Comment 5 Lucas Zanella 2021-02-12 07:03:20 UTC
Will ath11k-qca6390-bringup-202012140938 eventually get into 5.12 or newer?

Or my only option for the future is to update BIOS?
Comment 6 Kalle Valo 2021-02-12 11:14:46 UTC
bugzilla-daemon@bugzilla.kernel.org writes:

> https://bugzilla.kernel.org/show_bug.cgi?id=211569
>
> --- Comment #5 from Lucas Zanella (me@lucaszanella.com) ---
> Will ath11k-qca6390-bringup-202012140938 eventually get into 5.12 or newer?

Only missing feature from ath11k-qca6390-bringup-202012140938 is 1 MSI
vector support and there's a patchset here:

https://patchwork.kernel.org/project/linux-wireless/cover/20201223030225.2345-1-cjhuang@codeaurora.org/

But unfortunately it was crashing and I couldn't take it to v5.12 (the
deadline was yesterday). So it will have to wait for v5.13, if we can
fix the crashes. And I'm optimistic we can, but I cannot promise
anything.
Comment 7 Lucas Zanella 2021-02-12 18:07:57 UTC
Ok, I updated BIOS to the latest and updated kernel to 5.11.0-051100rc7-lowlatency, rebooted and there's no wifi yet. Do I need to download some firmware?
Comment 8 Lucas Zanella 2021-02-12 18:10:51 UTC
My dmesg:

[   10.849434] mhi mhi0: Direct firmware load for ath11k/QCA6390/hw2.0/amss.bin failed with error -2
Comment 9 Kalle Valo 2021-02-12 18:49:22 UTC
(In reply to Lucas Zanella from comment #8)
> My dmesg:
> 
> [   10.849434] mhi mhi0: Direct firmware load for
> ath11k/QCA6390/hw2.0/amss.bin failed with error -2

If you don't have the firmware installed clearly 5.10.0-1008-oem has something else than upstream ath11k. I'm closing this as INVALID. If you find bugs in the ubuntu kernel please report them to Ubuntu, this bugzilla is for upstream drivers.

Here are instructions how to install the firmware for upstream ath11k:

https://wireless.wiki.kernel.org/en/users/drivers/ath11k/installation
Comment 10 Lucas Zanella 2021-02-19 17:32:56 UTC
It worked after installing sudo apt-get install -y linux-firmware. I've been using for 1 week without any freezes. I've only had some sleep problems. When I open the lid the screen is black and I have to force reboot. It looks like it happens always if not only if I unplug the cable while sleeping and replug it.

Anyways, I know it's related to the wifi driver because if I don't force reboot, it comes to life after 30 seconds or so, and the wifi card is not even recognized.

I undersrand that my kernel is the ubuntu one, not the upstream, I already reported this to ubuntu but I'm telling here just in case it's an upstream bug also. Maybe you can test unplugging and replugging power when sleep and the opening the lid.

Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.