Bug 21152 - kernel crash on boot in acpi_init() - Toshiba L505D-SP6905R Notebook
kernel crash on boot in acpi_init() - Toshiba L505D-SP6905R Notebook
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: BIOS
All Linux
: P1 high
Assigned To: acpi_bios
:
: 21162 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-26 04:47 UTC by Mario
Modified: 2011-07-30 06:53 UTC (History)
3 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments
error (542.68 KB, image/jpeg)
2010-10-26 05:00 UTC, Mario
Details

Description Mario 2010-10-26 04:47:49 UTC
Hi,

It's not possible to install Ubuntu 10.10 to the Toshiba L505D-SP6905R Notebook.

This is, where the Live CD get stuck (you don't even get to the menu)

I made ist with the alternate DVD to the menu, disabled ACPI by pressing F6, but then if you go for installation the screen keeps black.
Comment 1 Mario 2010-10-26 05:00:41 UTC
Created attachment 35072 [details]
error
Comment 2 Zhang Rui 2010-10-29 03:24:19 UTC
*** Bug 21162 has been marked as a duplicate of this bug. ***
Comment 3 Len Brown 2010-10-29 05:09:16 UTC
Can you identify what kernel is being used here,
or reproduce the problem with kernel.org 2.6.36.stable or later?

do other distros or other versions of Linux boot on this machine?
Comment 4 Zhang Rui 2010-10-29 05:13:46 UTC
can you please boot with boot option "acpi=copy_dsdt"?
Comment 5 Mario 2010-10-29 14:43:23 UTC
I try to install debian but I could not, and the kernel is that it brings in Ubuntu 10.10, and let me try acpi = copy_dsdt hopefully works sorry for the English and thanks for answering about my problem
Comment 6 Zhang Rui 2010-11-01 01:53:00 UTC
(In reply to comment #5)
> let me try acpi = copy_dsdt hopefully works

just a reminder, you should use "acpi=copy_dsdt", no space.
Comment 7 Len Brown 2010-11-30 03:42:16 UTC
Has any version of Linux been able to boot on this box in the past?
Comment 8 Mario 2010-11-30 23:31:38 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > let me try acpi = copy_dsdt hopefully works
> 
> just a reminder, you should use "acpi=copy_dsdt", no space.

thanks
Comment 9 Mario 2010-11-30 23:36:10 UTC
acpi=copy_dsdt
Comment 10 Len Brown 2010-12-09 22:02:09 UTC
Is there still a problem here?
Comment 11 Mario 2010-12-10 05:58:53 UTC
fixed acpi=copy_dsdt thx
Comment 12 Len Brown 2011-07-30 06:53:05 UTC
no cmdline should be necessary as of 2.6.37,
as we now invoke this param automatically for all toshiba satellite.
please re-open if cmdline is necessary on such a kernel.

commit 100cf87788c0e9104f6fb1b0ff5f72f73fbbbea3
Author: Len Brown <len.brown@intel.com>
Date:   Tue Sep 28 22:57:02 2010 -0400

    ACPI: invoke DSDT corruption workaround on all Toshiba Satellite
    
    Our list of Toshiba Satellite models that require this workaround
    is growing -- so invoke the workaround for the entire product line.
    
    https://bugzilla.kernel.org/show_bug.cgi?id=14679
    
    Signed-off-by: Len Brown <len.brown@intel.com>

Note You need to log in before you can comment on or make changes to this bug.