Bug 210801 - TopSeed Technology Corp. eHome Infrared Transceiver spams log with Error: urb status = -71
Summary: TopSeed Technology Corp. eHome Infrared Transceiver spams log with Error: urb...
Status: RESOLVED IMPLEMENTED
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Default virtual assignee for Drivers/USB
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-20 16:19 UTC by Hans-Peter Jansen
Modified: 2021-02-05 18:08 UTC (History)
5 users (show)

See Also:
Kernel Version: 5.10.1
Tree: Mainline
Regression: No


Attachments

Description Hans-Peter Jansen 2020-12-20 16:19:01 UTC
Hi,

using a TopSeed Technology Corp. eHome Infrared Transceiver here, my kernel log is spammed with:

Dec 20 17:03:46 kernel: mceusb 6-10.4:1.0: Error: urb status = -71

with the rate of > 40/second.

Device is shown as:
Bus 006 Device 006: ID 1784:0006 TopSeed Technology Corp. eHome Infrared Transceiver

lsusb -vs 006:048

Bus 006 Device 048: ID 1784:0006 TopSeed Technology Corp. eHome Infrared Transceiver
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x1784 TopSeed Technology Corp.
  idProduct          0x0006 eHome Infrared Transceiver
  bcdDevice            1.01
  iManufacturer           1 TopSeed Technology Corp.
  iProduct                2 eHome Infrared Transceiver
  iSerial                 3 TS002j0C
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x0020
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0020  1x 32 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0020  1x 32 bytes
        bInterval               0
can't get device qualifier: Resource temporarily unavailable
can't get debug descriptor: Resource temporarily unavailable
Device Status:     0x0001
  Self Powered

When plugged in, these messages are triggered:

Dec 20 17:13:57 kernel: usb 6-10.4: new full-speed USB device number 49 using xhci_hcd
Dec 20 17:13:58 kernel: usb 6-10.4: config 1 interface 0 altsetting 0 endpoint 0x1 has an invalid bInterval 0, changing to 10
Dec 20 17:13:58 kernel: usb 6-10.4: config 1 interface 0 altsetting 0 endpoint 0x81 has an invalid bInterval 0, changing to 10
Dec 20 17:13:58 kernel: usb 6-10.4: New USB device found, idVendor=1784, idProduct=0006, bcdDevice= 1.01
Dec 20 17:13:58 kernel: usb 6-10.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec 20 17:13:58 kernel: usb 6-10.4: Product: eHome Infrared Transceiver
Dec 20 17:13:58 kernel: usb 6-10.4: Manufacturer: TopSeed Technology Corp.
Dec 20 17:13:58 kernel: usb 6-10.4: SerialNumber: TS002j0C
Dec 20 17:13:58 kernel: Registered IR keymap rc-rc6-mce
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: rc rc0: Media Center Ed. eHome Infrared Remote Transceiver (1784:0006) as /devices/pci0000:00/0000:00:14.0/usb6/6-10/6-10.4/6-10.4:1.0/rc/rc0
Dec 20 17:13:58 kernel: rc rc0: lirc_dev: driver mceusb registered at minor = 0, raw IR receiver, raw IR transmitter
Dec 20 17:13:58 kernel: input: Media Center Ed. eHome Infrared Remote Transceiver (1784:0006) as /devices/pci0000:00/0000:00:14.0/usb6/6-10/6-10.4/6-10.4:1.0/rc/rc0/input50
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Registered TopSeed Technology Corp. eHome Infrared Transceiver with mce emulator interface version 1
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: 2 tx ports (0x0 cabled) and 2 rx sensors (0x0 active)
Dec 20 17:13:58 mtp-probe[6430]: checking bus 6, device 49: "/sys/devices/pci0000:00/0000:00:14.0/usb6/6-10/6-10.4"
Dec 20 17:13:58 mtp-probe[6430]: bus: 6, device: 49 was not an MTP device 
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 upowerd[5834]: treating change event as add on /sys/devices/pci0000:00/0000:00:14.0/usb6/6-10/6-10.4
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: mce write urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 systemd-logind[1892]: Watching system buttons on /dev/input/event26 (Media Center Ed. eHome Infrared Remote Transceiver (1784:0006))
Dec 20 17:13:58 upowerd[5834]: treating change event as add on /sys/devices/pci0000:00/0000:00:14.0/usb6/6-10/6-10.4/6-10.4:1.0
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 mtp-probe[6449]: checking bus 6, device 49: "/sys/devices/pci0000:00/0000:00:14.0/usb6/6-10/6-10.4"
Dec 20 17:13:58 mtp-probe[6449]: bus: 6, device: 49 was not an MTP device 
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kcminit[6453]: Initializing  "kcm_mouse" :  "kcminit_mouse"
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:58 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
Dec 20 17:13:59 kernel: mceusb 6-10.4:1.0: Error: urb status = -71


It used to work fine with earlier kernels.

openSUSE Tumbleweed 20201216
5.10.1-7-preempt #1 SMP PREEMPT Tue Dec 15 08:33:02 UTC 2020 (c8c5afb) x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Jiri Slaby 2020-12-21 06:46:43 UTC
(In reply to Hans-Peter Jansen from comment #0)
> 5.10.1-7-preempt #1 SMP PREEMPT Tue Dec 15 08:33:02 UTC 2020 (c8c5afb)
> x86_64 x86_64 x86_64 GNU/Linux

I suppose this is a Kernel:stable kernel?

> Dec 20 17:03:46 kernel: mceusb 6-10.4:1.0: Error: urb status = -71
> 
> with the rate of > 40/second.

Maybe Oliver has an idea?
Comment 2 Alan Stern 2020-12-21 17:09:10 UTC
There are two things you can do to help solve the problem.  The first is to use git bisect to find the kernel change which caused the error messages to start appearing.

The second is to capture some usbmon traces (see Documentation/usb/usbmon.rst in the kernel source).  Comparing a trace from the current kernel with a trace from an earlier kernel where the errors don't appear might provide some clues.
Comment 3 sganes 2020-12-23 06:45:46 UTC
Hi Jansen,

Please enable the dynamic debug for USB to get more logs for easily get debug.

Please enter the below command and reconnect the device and share the logs.

echo "file drivers/usb/* +p" > /sys/kernel/debug/dynamic_debug/control

Thanks,
Sganes
Comment 4 Hans-Peter Jansen 2021-01-06 15:34:01 UTC
Hi guys, sorry for silence: kbo bug mails were incorrectly routed by sieve here and ended up in some junk space :-( Fixed now.

@Jiri: yes, this is the stable branch from https://github.com/frispete/kernel-source.git, directly forked from https://github.com/openSUSE/kernel-source.git, with minor config changes added. I'm build stable and master branches in home:frispete:kernel{:HEAD}.

@Alan: I started with reverting 528222d853f92, which messes with rc timer durations.
While I cannot see any obvious flaws in the changeset (in the mceusb module at least), which doesn't mean *anything* of course, it might be a good start.

@Alan and @sganes: if that doesn't change the behavior, I will try to do the monitoring/tracing, as you suggested.

I've cc'ed Sean Young now, since he's in change of 528222d853f92.
Comment 5 Hans-Peter Jansen 2021-01-07 14:02:32 UTC
Okay, reverting 528222d853f92 does the trick. 

My RC is working fine again for VDR, I can pull and plug the RC controller, VDR is complaining, but after restarting VDR, all is fine again. 

This is the kernel log of pulling and plugging the RC controller:
```
[    4.903556] rc rc0: lirc_dev: driver mceusb registered at minor = 0, raw IR receiver, raw IR transmitter
[    5.084059] mceusb 5-10.4:1.0: long-range (0x1) receiver active
[    5.127510] mceusb 5-10.4:1.0: Registered TopSeed Technology Corp. eHome Infrared Transceiver with mce emulator interface version 1
[    5.127512] mceusb 5-10.4:1.0: 2 tx ports (0x0 cabled) and 2 rx sensors (0x1 active)
[    5.127530] usbcore: registered new interface driver mceusb
[ 1537.725685] mceusb 5-10.4:1.0: Error: urb status = -71
[ 1537.733681] mceusb 5-10.4:1.0: Error: urb status = -71
[ 1537.741680] mceusb 5-10.4:1.0: Error: urb status = -71
[ 1537.749683] mceusb 5-10.4:1.0: Error: urb status = -71
[ 1537.757670] mceusb 5-10.4:1.0: Error: urb status = -71
[ 1537.765684] mceusb 5-10.4:1.0: Error: urb status = -71
[ 1537.773662] mceusb 5-10.4:1.0: Error: urb status = -71
[ 1537.781659] mceusb 5-10.4:1.0: Error: urb status = -71
[ 1537.789654] mceusb 5-10.4:1.0: Error: urb status = -71
[ 1540.361827] rc rc0: lirc_dev: driver mceusb registered at minor = 0, raw IR receiver, raw IR transmitter
[ 1540.541769] mceusb 5-10.4:1.0: long-range (0x1) receiver active
[ 1540.585785] mceusb 5-10.4:1.0: Registered TopSeed Technology Corp. eHome Infrared Transceiver with mce emulator interface version 1
[ 1540.585787] mceusb 5-10.4:1.0: 2 tx ports (0x0 cabled) and 2 rx sensors (0x1 active)
```

With 528222d853f92 applied, I wasn't able to recover at all, I had to stop VDR and pulling the RC controller in order to stop flooding the log with the urb status = -71 errors.

Sean, do you have any idea, what could have changed with 528222d853f92 resulting in this behavior?
Comment 6 Sean Young 2021-01-07 16:13:38 UTC
I've been looking at commit 528222d853f92 for some time now and I can't see how this broke anything.

Can you please try again with mceusb dynamic debug enabled?

echo "file drivers/media/rc/mceusb.c +p" > /sys/kernel/debug/dynamic_debug/control

(Both with and without the patch please.)

The output should tell us what command is causing problem and what command changed (if anything) between the commits.

Thanks
Comment 7 Sean Young 2021-01-14 14:17:07 UTC
Also could you post a picture of the mceusb device itself? Maybe I can track it down on ebay add it to my collection.

Thanks.
Comment 8 Hans-Peter Jansen 2021-01-14 15:41:12 UTC
Sorry Sean, was distracted from day job(s) the last couple of days. 

I hereby promise to do my homework soon...

Device: Hewlett Packard TSGI-IR01

https://paste.opensuse.org/19971413

There are two similar models, this one is easily distinguished from the other by the cable attachment on the rear side, our's is asymmetric. 

Send me your post address and I'm happy to send you one! (I bought a bundle due to a couple of my friends operate similar VDR setups, based on my packages on OBS). While the device is somewhat chunky, it does support RC06 well, as being used by the most common Hauppauge IR remote, that we all accumulated over time:

https://hauppauge.co.uk/site/webstore/webstore_product.html?prod=7

Cheers,
Pete
Comment 9 Hans-Peter Jansen 2021-02-04 15:06:35 UTC
Plugging in the rc controller with dynamic debug enabled:

```

Feb 04 15:44:50 xrated kernel: usb 3-10.4: new full-speed USB device number 64 using xhci_hcd
Feb 04 15:44:50 xrated kernel: usb 3-10.4: config 1 interface 0 altsetting 0 endpoint 0x1 has an invalid bInterval 0, changing to 10
Feb 04 15:44:50 xrated kernel: usb 3-10.4: config 1 interface 0 altsetting 0 endpoint 0x81 has an invalid bInterval 0, changing to 10
Feb 04 15:44:50 xrated kernel: usb 3-10.4: New USB device found, idVendor=1784, idProduct=0006, bcdDevice= 1.01
Feb 04 15:44:50 xrated kernel: usb 3-10.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Feb 04 15:44:50 xrated kernel: usb 3-10.4: Product: eHome Infrared Transceiver
Feb 04 15:44:50 xrated kernel: usb 3-10.4: Manufacturer: TopSeed Technology Corp.
Feb 04 15:44:50 xrated kernel: usb 3-10.4: SerialNumber: TS002j0C
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: mceusb_dev_probe called
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: acceptable interrupt outbound endpoint found
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: acceptable interrupt inbound endpoint found
Feb 04 15:44:50 xrated kernel: Registered IR keymap rc-rc6-mce
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 0c 00 fd (len=4 sz=4)
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: Request receive timeout of 12 ms
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 976, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 0d (len=2 sz=2)
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: Get receive timeout
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 980, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:50 xrated kernel: rc rc0: Media Center Ed. eHome Infrared Remote Transceiver (1784:0006) as /devices/pci0000:00/0000:00:14.0/usb3/3-10/3-10.4/3-10.4:1.0/rc/rc0
Feb 04 15:44:50 xrated kernel: rc rc0: lirc_dev: driver mceusb registered at minor = 0, raw IR receiver, raw IR transmitter
Feb 04 15:44:50 xrated kernel: input: Media Center Ed. eHome Infrared Remote Transceiver (1784:0006) as /devices/pci0000:00/0000:00:14.0/usb3/3-10/3-10.4/3-10.4:1.0/rc/rc0/input48
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: Flushing receive buffers
Feb 04 15:44:50 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: ff 22 (len=2 sz=2)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 980, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 00 ff aa (len=3 sz=3)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Device resume requested
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 980, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: ff 18 (len=2 sz=2)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 981, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 05 (len=2 sz=2)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Unknown command 0x9f 0x05
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 981, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 16 (len=2 sz=2)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 980, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 07 (len=2 sz=2)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Get carrier mode and freq
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 981, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 13 (len=2 sz=2)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Get transmit blaster mask
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 980, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 0d (len=2 sz=2)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Get receive timeout
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 981, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 15 (len=2 sz=2)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Get receive sensor
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 980, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: ff 11 00 (len=3 sz=3)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 980, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: ff 11 01 (len=3 sz=3)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 981, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Registered TopSeed Technology Corp. eHome Infrared Transceiver with mce emulator interface version 1
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: 2 tx ports (0x0 cabled) and 2 rx sensors (0x0 active)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated mtp-probe[12138]: checking bus 3, device 64: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-10/3-10.4"
Feb 04 15:44:51 xrated mtp-probe[12138]: bus: 3, device: 64 was not an MTP device
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated upowerd[5598]: treating change event as add on /sys/devices/pci0000:00/0000:00:14.0/usb3/3-10/3-10.4
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 0c 00 fd (len=4 sz=4)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Request receive timeout of 12 ms
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 975, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx data[0]: 9f 0d (len=2 sz=2)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Get receive timeout
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: mce write urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: tx done status = -71 (wait = 980, expire = 1000 (1000ms), urb->actual_length = 0, urb->status = -71)
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated systemd-logind[2071]: Watching system buttons on /dev/input/event25 (Media Center Ed. eHome Infrared Remote Transceiver (1784:0006))
Feb 04 15:44:51 xrated upowerd[5598]: treating change event as add on /sys/devices/pci0000:00/0000:00:14.0/usb3/3-10/3-10.4/3-10.4:1.0
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated mtp-probe[12161]: checking bus 3, device 64: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-10/3-10.4"
Feb 04 15:44:51 xrated mtp-probe[12161]: bus: 3, device: 64 was not an MTP device
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kcminit[12165]: Initializing  "kcm_mouse" :  "kcminit_mouse"
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:51 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:44:52 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
...
Feb 04 15:45:00 xrated kernel: usb 3-10.4: USB disconnect, device number 64
Feb 04 15:45:00 xrated kernel: mceusb 3-10.4:1.0: Error: urb status = -71
Feb 04 15:45:00 xrated kernel: mceusb 3-10.4:1.0: mceusb_dev_disconnect called
```

lsusb:
```
Bus 005 Device 002: ID 8087:8001 Intel Corp. Integrated Hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8009 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 002: ID 11b0:6368 ATECH FLASH TECHNOLOGY Multi-Reader
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 005: ID 046a:010d Cherry GmbH MX-Board 3.0 Keyboard
Bus 003 Device 003: ID 046a:0114 Cherry GmbH CHERRY Wireless Device
Bus 003 Device 065: ID 1784:0006 TopSeed Technology Corp. eHome Infrared Transceiver
Bus 003 Device 063: ID 0bda:0307 Realtek Semiconductor Corp. Card Reader
Bus 003 Device 060: ID 046d:085b Logitech, Inc. Logitech Webcam C925e
Bus 003 Device 059: ID 0451:8043 Texas Instruments, Inc. Hub
Bus 003 Device 058: ID 0451:8043 Texas Instruments, Inc. Hub
Bus 003 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 004: ID 0d46:3014 Kobil Systems GmbH Smart Token
Bus 007 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
```

lsusb -vt:
```
/:  Bus 07.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/4p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        ID 05e3:0608 Genesys Logic, Inc. Hub
        |__ Port 4: Dev 4, If 0, Class=Chip/SmartCard, Driver=usbfs, 12M
            ID 0d46:3014 Kobil Systems GmbH Smart Token
/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 5000M
    ID 1d6b:0003 Linux Foundation 3.0 root hub
    |__ Port 4: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 5000M
        ID 11b0:6368 ATECH FLASH TECHNOLOGY 
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        ID 8087:8001 Intel Corp. Integrated Hub
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
    ID 1d6b:0001 Linux Foundation 1.1 root hub
    |__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        ID 046d:c52f Logitech, Inc. Unifying Receiver
    |__ Port 1: Dev 2, If 1, Class=Human Interface Device, Driver=usbhid, 12M
        ID 046d:c52f Logitech, Inc. Unifying Receiver
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/14p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 10: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        ID 1a40:0101 Terminus Technology Inc. Hub
        |__ Port 3: Dev 58, If 0, Class=Hub, Driver=hub/3p, 480M
            ID 0451:8043 Texas Instruments, Inc. Hub
            |__ Port 3: Dev 59, If 0, Class=Hub, Driver=hub/3p, 480M
                ID 0451:8043 Texas Instruments, Inc. Hub
                |__ Port 3: Dev 63, If 0, Class=Mass Storage, Driver=usb-storage, 480M
                    ID 0bda:0307 Realtek Semiconductor Corp. Card Reader
                |__ Port 1: Dev 60, If 0, Class=Video, Driver=uvcvideo, 480M
                    ID 046d:085b Logitech, Inc. 
                |__ Port 1: Dev 60, If 3, Class=Audio, Driver=snd-usb-audio, 480M
                    ID 046d:085b Logitech, Inc. 
                |__ Port 1: Dev 60, If 1, Class=Video, Driver=uvcvideo, 480M
                    ID 046d:085b Logitech, Inc. 
                |__ Port 1: Dev 60, If 2, Class=Audio, Driver=snd-usb-audio, 480M
                    ID 046d:085b Logitech, Inc. 
        |__ Port 4: Dev 65, If 0, Class=Vendor Specific Class, Driver=mceusb, 12M
            ID 1784:0006 TopSeed Technology Corp. eHome Infrared Transceiver
    |__ Port 13: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        ID 046a:0114 Cherry GmbH 
    |__ Port 13: Dev 3, If 1, Class=Human Interface Device, Driver=usbhid, 12M
        ID 046a:0114 Cherry GmbH 
    |__ Port 14: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        ID 046a:010d Cherry GmbH MX-Board 3.0 Keyboard
    |__ Port 14: Dev 5, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
        ID 046a:010d Cherry GmbH MX-Board 3.0 Keyboard
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
    ID 1d6b:0001 Linux Foundation 1.1 root hub
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    ID 1d6b:0002 Linux Foundation 2.0 root hub
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        ID 8087:8009 Intel Corp. 
```

The device is connected to a USB 2.0 hub from LogiLink, which is connected to a USB 3.0 port on the ATX plance of the motherboard.

```
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:01.1 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x8 Controller (rev 06)
00:14.0 USB controller: Intel Corporation 9 Series Chipset Family USB xHCI Controller
00:16.0 Communication controller: Intel Corporation 9 Series Chipset Family ME Interface #1
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (2) I218-V
00:1a.0 USB controller: Intel Corporation 9 Series Chipset Family USB EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 9 Series Chipset Family HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root Port 1 (rev d0)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d0)
00:1c.6 PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root Port 7 (rev d0)
00:1d.0 USB controller: Intel Corporation 9 Series Chipset Family USB EHCI Controller #1
00:1f.0 ISA bridge: Intel Corporation Z97 Chipset LPC Controller
00:1f.2 SATA controller: Intel Corporation 9 Series Chipset Family SATA Controller [AHCI Mode]
00:1f.3 SMBus: Intel Corporation 9 Series Chipset Family SMBus Controller
01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)
02:00.0 PCI bridge: Pericom Semiconductor PI7C9X111SL PCIe-to-PCI Reversible Bridge (rev 02)
03:04.0 USB controller: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller (rev 62)
03:04.1 USB controller: VIA Technologies, Inc. VT82xx/62xx UHCI USB 1.1 Controller (rev 62)
03:04.2 USB controller: VIA Technologies, Inc. USB 2.0 (rev 65)
05:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 04)
07:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981/PM983
```

uname -a: 
Linux xrated 5.10.11-2-preempt #1 SMP PREEMPT Thu Jan 28 10:32:01 UTC 2021 (b4718b3) x86_64 x86_64 x86_64 GNU/Linu

I'm preparing 5.10.13, which has some interesting changes in this area, as you know, Sean ;-), and as you might have notices, my reponsiveness is sucking rocks ATM. Sorry.
Comment 10 Hans-Peter Jansen 2021-02-05 18:08:31 UTC
What should I say, with 5.10.13, all is well again!

Note You need to log in before you can comment on or make changes to this bug.