Bug 210593 - EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?) with Ryzen 5600x & B450 chipset
Summary: EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?) with Ryzen 5600...
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_ia-64
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-09 20:48 UTC by Julian Sikorski
Modified: 2021-04-30 14:55 UTC (History)
6 users (show)

See Also:
Kernel Version: 5.9.13-200.fc33.x86_64
Tree: Fedora
Regression: No


Attachments

Description Julian Sikorski 2020-12-09 20:48:33 UTC
I have just upgraded my Ryzen 5 2600 to a 5600x. Now dmesg contains a dozen or so messages like:
[    5.143217] EDAC amd64: F19h detected (node 0).
[    5.143225] EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?)
I am not sure whether it has any negative effects, the system seems stable when running Linux.
Comment 1 Julian Sikorski 2020-12-11 16:46:21 UTC
This is fixed in 5.10rc7.
Comment 2 Priit O. 2021-01-02 19:41:26 UTC
Not fixed! Using kernel 5.10.2, X570 motherboard, 5950X, Vega 64.

EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?)
Comment 3 Julian Sikorski 2021-01-02 20:08:52 UTC
This is strange, I tested it with 5.10rc7 and the error was gone. This is the patch which I believe fixes the issue:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/edac/amd64_edac.c?id=b4210eab9164e3ea647b71e1049391177db9b215
Comment 4 Julian Sikorski 2021-01-16 16:21:47 UTC
With 5.10.6-200.fc33.x86_64:
[    4.899884] EDAC amd64: F19h_M20h detected (node 0).
[    4.899927] EDAC amd64: Node 0: DRAM ECC disabled.
[    4.942858] nct6775: Found NCT6792D or compatible chip at 0x2e:0x290
[    4.942915] EDAC amd64: F19h_M20h detected (node 0).
[    4.943054] EDAC amd64: Node 0: DRAM ECC disabled.
Comment 5 Sophie 2021-01-18 09:44:52 UTC
(In reply to Priit O. from comment #2)
> Not fixed! Using kernel 5.10.2, X570 motherboard, 5950X, Vega 64.
> 
> EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?)

After upgrading to 5.10.7, I don't receive the original EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?) that you mentioned. Can you confirm?
Comment 6 Priit O. 2021-01-18 21:38:30 UTC
Meanwhile I upgraded my MB bios
from 7C84v14 -- AMD AGESA ComboAm4v2PI 1.1.0.0 Patch C
to 7C84v153(Beta version) -- ComboAM4PIV2 1.1.9.0

and kernel remained the same 5.10.2 and I don't see the error anymore...
Comment 7 powderluv 2021-02-09 06:35:26 UTC
This is still reproducible on 5.11-rc7. I am on a 5950x on a MSI MEG X570 Godlike motherboard with their latest bios  


7C34v1C6(Beta version)
- Update to ComboAM4PIV2 1.2.0.0
- Support S.A.M technology (Re-size BAR function) to enhance GPU performance for AMD Radeon RX 6000 series.
Comment 8 powderluv 2021-02-09 18:55:43 UTC
reducing the DDR from 2666 to 2133 (and disable memory fast boot) seems to have solved the issue. Can't recreate it with a few (n=5) reboots.  

Now it says:

[    7.201069] EDAC amd64: F19h_M20h detected (node 0).
[    7.201133] EDAC amd64: Node 0: DRAM ECC disabled.
Comment 9 Gurenko Alex 2021-03-14 12:26:46 UTC
Still happening on kernel 5.11.5:

[6.107573] EDAC amd64: F19h_M20h detected (node 0).
[6.107608] EDAC amd64: Node 0: DRAM ECC disabled.

5900X, MSI X570 Tomahawk
Comment 10 Priit O. 2021-03-14 12:40:26 UTC
@Gurenko your message seems to be "OK" version ;)
"bad" one was with "error" and "(broken BIOS?)" texts:
[    5.143225] EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?)
Comment 11 Gurenko Alex 2021-03-14 12:54:29 UTC
(In reply to Priit O. from comment #10)
> @Gurenko your message seems to be "OK" version ;)
> "bad" one was with "error" and "(broken BIOS?)" texts:
> [    5.143225] EDAC amd64: Error: F0 not found, device 0x1650 (broken BIOS?)

Right, sorry, too many tabs open, confused it with BZ for spamming this message that was also supposed to be fixed back around 5.5 kernel :)
Comment 12 Victor Yon 2021-04-30 14:55:50 UTC
I had a similar issue, same message but with an annoying keyboard problem (it randomly disabled during few seconds).
And the issue wasn't specific to Linux, I had the same keyboard trouble on Windows.

This happened after BIOS update (MPG B550 GAMING EDGE WIFI MS-7C91 V1.5) + installing a new CPU (Ryzen 5800x).

I fixed this with another bios update (v1.5 -> V1.63 beta), without any kernel update.


So it seems to be a BIOS issue, not a kernel issue.

Note You need to log in before you can comment on or make changes to this bug.