Bug 210453 - [BISECTED] rtl8822cu device : "Bluetooth : No device found"
Summary: [BISECTED] rtl8822cu device : "Bluetooth : No device found"
Status: RESOLVED DUPLICATE of bug 210279
Alias: None
Product: Drivers
Classification: Unclassified
Component: Bluetooth (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: linux-bluetooth@vger.kernel.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-02 13:45 UTC by Olivier V
Modified: 2021-01-10 08:08 UTC (History)
3 users (show)

See Also:
Kernel Version: b2cc23398e8166b38f8715026273503b081c2a7a
Tree: Mainline
Regression: No


Attachments

Description Olivier V 2020-12-02 13:45:42 UTC
Hi,

The bluetooth with device rtl8822cu does not work with 5.9.12 mainline kernel (and all 5.9 kernel).

Before it worked fine with 5.8.0 mainline kernel.

A similar problem was solved for rl8822ce in 5.9.11 kernel by arch.
Discussion here : https://bbs.archlinux.org/viewtopic.php?pid=1940003#p1940003

I'm new here, so let me know what attachment you need.

Thank you.

meloli@Asus-A17:~$ sudo dmesg | grep -i bluetooth
[ 1.476073] usb 5-1: Product: Bluetooth Radio
[ 3.977975] Bluetooth: Core ver 2.22
[ 3.978022] Bluetooth: HCI device and connection manager initialized
[ 3.978030] Bluetooth: HCI socket layer initialized
[ 3.978035] Bluetooth: L2CAP socket layer initialized
[ 3.978043] Bluetooth: SCO socket layer initialized
[ 4.002039] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=000c lmp_ver=0a lmp_subver=8822
[ 4.003996] Bluetooth: hci0: RTL: rom_version status=0 version=3
[ 4.004001] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822cu_fw.bin
[ 4.006885] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822cu_config.bin
[ 4.007705] Bluetooth: hci0: RTL: cfg_sz 6, total sz 31422
[ 4.283989] Bluetooth: hci0: RTL: fw version 0x09993aa1
[ 4.933204] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 4.933207] Bluetooth: BNEP filters: protocol multicast
[ 4.933214] Bluetooth: BNEP socket layer initialized
[ 1422.650815] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=000c lmp_ver=0a lmp_subver=8822
[ 1422.652695] Bluetooth: hci0: RTL: rom_version status=0 version=3
[ 1422.652725] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822cu_fw.bin
[ 1422.652877] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822cu_config.bin
[ 1422.653058] Bluetooth: hci0: RTL: cfg_sz 6, total sz 31422
[ 1422.931399] Bluetooth: hci0: RTL: fw version 0x09993aa1
[ 1632.862056] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=0999 lmp_ver=0a lmp_subver=3aa1
[ 1632.862064] Bluetooth: hci0: RTL: unknown IC info, lmp subver 3aa1, hci rev 0999, hci ver 000a
[ 1632.862065] Bluetooth: hci0: RTL: assuming no firmware upload needed
meloli@Asus-A17:~$ lsmod|grep blue
bluetooth 647168 12 btrtl,btintel,btbcm,bnep,btusb
ecdh_generic 16384 1 bluetooth

meloli@Asus-A17:~$ lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 002: ID 13d3:3548 IMC Networks Bluetooth Radio
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 0951:1666 Kingston Technology DataTraveler 100 G3/G4/SE9 G2
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 13d3:56a2 IMC Networks USB2.0 HD UVC WebCam
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

meloli@Asus-A17:~$ rfkill list all
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
3: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu27.13
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: KDE
DistroRelease: Ubuntu 20.04
InstallationDate: Installed on 2020-09-18 (75 days ago)
InstallationMedia: Kubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
NonfreeKernelModules: nvidia_modeset nvidia
Package: linux (not installed)
Tags: focal
Uname: Linux 5.9.12-050912-generic x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lp lpadmin lxd plugdev sambashare sudo vboxusers
_MarkForUpload: True
Comment 1 Olivier V 2020-12-05 18:01:25 UTC
Something about patches here :
http://patchwork.ozlabs.org/project/ubuntu-kernel/list/?series=138556

But I don't understand how to do something with this.
Comment 2 Olivier V 2020-12-18 11:42:55 UTC
As asked here https://bugs.launchpad.net/ubuntu/+s...x/+bug/1906515 I've done a git bisect.

Here is the answer :

meloli@Asus-A17:~/Bureau/meloli/GITBISECT/linux$ git bisect bad
b2cc23398e8166b38f8715026273503b081c2a7a is the first bad commit
commit b2cc23398e8166b38f8715026273503b081c2a7a
Author: Sathish Narasimman <nsathish41@gmail.com>
Date:   Thu Jul 23 18:09:02 2020 +0530

    Bluetooth: Enable RPA Timeout
    
    Enable RPA timeout during bluetooth initialization.
    The RPA timeout value is used from hdev, which initialized from
    debug_fs
    
    Signed-off-by: Sathish Narasimman <sathish.narasimman@intel.com>
    Signed-off-by: Marcel Holtmann <marcel@holtmann.org>

 include/net/bluetooth/hci.h | 2 ++
 net/bluetooth/hci_core.c    | 8 ++++++++
 2 files changed, 10 insertions(+)
Comment 3 Olivier V 2020-12-18 14:12:02 UTC
The bug is confirmed.
b2cc23398e8166b38f8715026273503b081c2a7a is the offending commit

 
$ git checkout b2cc23398e8166b38f8715026273503b081c2a7a
# give a bad kernel

$ git checkout b2cc23398e8166b38f8715026273503b081c2a7a^
# give a good kernel
Comment 5 Olivier V 2020-12-20 21:45:09 UTC
But it is still not in 5.10.1 ubuntu kernel.
Is this normal ?
Comment 6 Michael C 2020-12-20 21:57:17 UTC
The fix will be in the next stable kernel.
Comment 7 Olivier V 2020-12-21 19:30:19 UTC
Not solved in 5.10.2... wait later...
Comment 8 Olivier V 2020-12-27 13:53:01 UTC
Not solved in 5.10.3
Comment 9 Michael C 2020-12-27 19:08:06 UTC
The fix will be in 5.11. You could try to get the ubuntu folks downstream to integrate the fix in their 5.10.* builds. Otherwise, you could follow the ubuntu instructions for building your own kernel, and apply the patch yourself and build / install your own kernel with the fix. That is what I've been doing with the Fedora kernel since this problem appeared.
Comment 10 Olivier V 2020-12-28 10:44:57 UTC
OK thank you.
I already have build my own kernel (based on 5.10.1) and it works.
Comment 11 Olivier V 2021-01-04 19:44:24 UTC
Solved in 5.11.0-rc2
Comment 12 Olivier V 2021-01-10 08:07:05 UTC
Solved in 5.10.6 (installed and tried today).

Bug can be marked as solved.
Comment 13 Olivier V 2021-01-10 08:08:40 UTC

*** This bug has been marked as a duplicate of bug 210279 ***

Note You need to log in before you can comment on or make changes to this bug.