Bug 20982 - Radeon: Display doesn't fit the screen size
Radeon: Display doesn't fit the screen size
Status: RESOLVED DUPLICATE of bug 20142
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-23 14:01 UTC by Anthony Bourguignon
Modified: 2012-08-14 11:21 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.36
Tree: Mainline
Regression: No


Attachments
The dmesg with 2.6.36 kernel (50.00 KB, application/octet-stream)
2010-10-23 14:01 UTC, Anthony Bourguignon
Details
The display with 2.6.35.7 kernel. No black lines. (209.48 KB, image/jpeg)
2010-10-23 14:02 UTC, Anthony Bourguignon
Details
Display with 2.6.36 kernel. Black lines around. (185.97 KB, image/jpeg)
2010-10-23 14:02 UTC, Anthony Bourguignon
Details

Description Anthony Bourguignon 2010-10-23 14:01:11 UTC
Created attachment 34512 [details]
The dmesg with 2.6.36 kernel

Hello,

I've got a strange bug since I've installed the new 2.6.36 kernel. KMS configure my screen with the right resolution, but the display doesn't seem to fit the actual screen size. When I look at the properties into the screen OSD, it shows that it works at 1920x1080 (1080P). As a result of this, the resolution is correct but the display is smaller than this, so I've got black lines and my display is blurred.

I could reproduce the bug on two different screens, two different radeon GPUs and with two different configurations of the kernel.

As I use an HDMI connection, I tried with the VGA one but it doesn't permit me to display such a large resolution.
Comment 1 Anthony Bourguignon 2010-10-23 14:02:09 UTC
Created attachment 34522 [details]
The display with 2.6.35.7 kernel. No black lines.
Comment 2 Anthony Bourguignon 2010-10-23 14:02:51 UTC
Created attachment 34532 [details]
Display with 2.6.36 kernel. Black lines around.
Comment 3 Alex Deucher 2010-10-23 14:27:05 UTC
This is a new feature to compensate for the overscan imposed by lots of TVs.  To disable it:
xrandr --output HDMI-0 --set underscan off
Comment 4 Alex Deucher 2010-10-23 14:28:31 UTC
This bug is a duplicate of:
https://bugzilla.kernel.org/show_bug.cgi?id=20142
Comment 5 Alan 2012-08-14 11:21:05 UTC

*** This bug has been marked as a duplicate of bug 20142 ***

Note You need to log in before you can comment on or make changes to this bug.