Bug 209403 - c123 Realtek Bluetooth Radio not detected with Kernel 5.9
Summary: c123 Realtek Bluetooth Radio not detected with Kernel 5.9
Status: RESOLVED IMPLEMENTED
Alias: None
Product: Drivers
Classification: Unclassified
Component: Bluetooth (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: linux-bluetooth@vger.kernel.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-26 10:40 UTC by Simon
Modified: 2021-01-22 20:17 UTC (History)
6 users (show)

See Also:
Kernel Version: 5.9-rc7
Tree: Mainline
Regression: No


Attachments
lscpi, lsusb and dmesg output (13.49 KB, text/plain)
2020-09-26 10:40 UTC, Simon
Details

Description Simon 2020-09-26 10:40:20 UTC
Created attachment 292661 [details]
lscpi, lsusb and dmesg output

Bluetooth stopped working after switching to kernel 5.9, it still works if I boot kernel 5.8 again.

Hardware:
Lenovo IdeaPad5 14are05
Realtek Semiconductor Co., Ltd. RTL8822CE 802.11ac PCIe Wireless Network Adapter
with integrated Bluetooth 2.1/3.0/4.2 USB interface controller

bluetoothhctl list doesn't show the controller

lsusb -v shows a Realtek Bluetooth Radio controller.

lspci -vv show also the Realtek Wireless Network Adapter.
Comment 1 Simon 2020-09-26 10:44:03 UTC
Kernel version: 5.9.0-050900rc6-generic #202009202030 SMP Mon Sep 21 00:36:09 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
Comment 2 Simon 2020-09-29 18:28:57 UTC
Same with Kernel 5.9.0-050900rc7-generic #202009272231 SMP Sun Sep 27 22:33:57 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Dominikus Gierlach 2020-10-17 18:20:54 UTC
The issue is still present with 5.9.1.

Additional information: dmesg output from module loading to `hciconfig hci0 up':

[  741.324397] usbcore: registered new interface driver btusb
[  741.326030] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=000c lmp_ver=0a lmp_subver=8822
[  741.327752] Bluetooth: hci0: RTL: rom_version status=0 version=3
[  741.327757] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822cu_fw.bin
[  741.327889] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822cu_config.bin
[  741.327940] Bluetooth: hci0: RTL: cfg_sz 6, total sz 31422
[  741.605079] Bluetooth: hci0: RTL: fw version 0x09993aa1
[  772.977433] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=0999 lmp_ver=0a lmp_subver=3aa1
[  772.977446] Bluetooth: hci0: RTL: unknown IC info, lmp subver 3aa1, hci rev 0999, hci ver 000a
[  772.977447] Bluetooth: hci0: RTL: assuming no firmware upload needed
[  772.994449] debugfs: File 'dut_mode' in directory 'hci0' already present!



hciconfig hci0 up prints:

envy# hciconfig hci0 up
Can't init device hci0: Protocol not supported (93)
Comment 4 waffen03 2020-10-28 13:01:00 UTC
(In reply to Dominikus Gierlach from comment #3)
> The issue is still present with 5.9.1.
> 
> Additional information: dmesg output from module loading to `hciconfig hci0
> up':
> 
> [  741.324397] usbcore: registered new interface driver btusb
> [  741.326030] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=000c
> lmp_ver=0a lmp_subver=8822
> [  741.327752] Bluetooth: hci0: RTL: rom_version status=0 version=3
> [  741.327757] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822cu_fw.bin
> [  741.327889] Bluetooth: hci0: RTL: loading rtl_bt/rtl8822cu_config.bin
> [  741.327940] Bluetooth: hci0: RTL: cfg_sz 6, total sz 31422
> [  741.605079] Bluetooth: hci0: RTL: fw version 0x09993aa1
> [  772.977433] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=0999
> lmp_ver=0a lmp_subver=3aa1
> [  772.977446] Bluetooth: hci0: RTL: unknown IC info, lmp subver 3aa1, hci
> rev 0999, hci ver 000a
> [  772.977447] Bluetooth: hci0: RTL: assuming no firmware upload needed
> [  772.994449] debugfs: File 'dut_mode' in directory 'hci0' already present!
> 
> 
> 
> hciconfig hci0 up prints:
> 
> envy# hciconfig hci0 up
> Can't init device hci0: Protocol not supported (93)

Edward's patch https://marc.info/?l=linux-bluetooth&m=160378222632366 
in https://bugzilla.kernel.org/show_bug.cgi?id=208965 worked for me on kernel version 5.9.1.
Comment 5 Dominikus Gierlach 2020-10-28 21:21:25 UTC
Thanks! Perfect. Works for me, too.
Comment 6 Sven Kaa 2020-10-29 20:33:43 UTC
Can confirm Edward's patch working. Realtek 8822CU on HP Probook 440 G7.
Thanks :)
Comment 7 Vishal Patil 2020-11-30 01:21:58 UTC
Is there a workaround for this problem, besides the patch ?
Comment 8 Simon 2021-01-22 20:09:46 UTC
With Kernel 5.10.9-051009-generic this Bug seems to be fixed. Haven't tried previous versions of 5.10.
Comment 9 Simon 2021-01-22 20:17:05 UTC
Sorry I don't know if i'm allowed to set this bug to RESOLVED IMPLEMENTED because I don't fixed it, but with Kernel 5.10.9 bluetooth works again. Many thanks for the programmer who did it!

Note You need to log in before you can comment on or make changes to this bug.