Bug 209389 - Thinkpad T460P ACPI errors
Summary: Thinkpad T460P ACPI errors
Status: CLOSED DOCUMENTED
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: acpi_bios
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-25 11:01 UTC by nc-duenkekl3
Modified: 2021-01-03 13:07 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.4.67
Tree: Mainline
Regression: No


Attachments

Description nc-duenkekl3 2020-09-25 11:01:07 UTC
On my Thinkpad T460P I always get several ACPI errors in the journalctl running the 5.4 LTS kernel

Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Added _OSI(Module Device)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Added _OSI(Processor Device)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Added _OSI(3.0 _SCP Extensions)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Added _OSI(Processor Aggregator Device)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Added _OSI(Linux-Dell-Video)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: 10 ACPI AML tables successfully acquired and loaded
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: EC: EC started
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: EC: interrupt blocked
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: \: Used as first EC
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: \: GPE=0x16, EC_CMD/EC_SC=0x66, EC_DATA=0x62
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: EC: Boot ECDT EC used to handle transactions
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Dynamic OEM Table Load:
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: SSDT 0xFFFF94661D15A800 000649 (v02 PmRef  Cpu0Ist  00003000 INTL 20141107)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Failure creating named object [\_PR.CPU0._PPC], AE_ALREADY_EXISTS (20190816/dswload2-326)
Sep 25 11:18:46 deus-ex-machina kernel: fbcon: Taking over console
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Skipping parse of AML opcode: Method (0x0014)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Failure creating named object [\_PR.CPU0._PCT], AE_ALREADY_EXISTS (20190816/dswload2-326)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Skipping parse of AML opcode: Method (0x0014)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Failure creating named object [\_PR.CPU0._PSS], AE_ALREADY_EXISTS (20190816/dswload2-326)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Skipping parse of AML opcode: Method (0x0014)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Failure creating named object [\_PR.CPU0.LPSS], AE_ALREADY_EXISTS (20190816/dswload2-326)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Failure creating named object [\_PR.CPU0.TPSS], AE_ALREADY_EXISTS (20190816/dswload2-326)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Failure creating named object [\_PR.CPU0.PSDF], AE_ALREADY_EXISTS (20190816/dswload2-326)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Failure creating named object [\_PR.CPU0._PSD], AE_ALREADY_EXISTS (20190816/dswload2-326)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Skipping parse of AML opcode: Method (0x0014)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Failure creating named object [\_PR.CPU0.HPSD], AE_ALREADY_EXISTS (20190816/dswload2-326)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Failure creating named object [\_PR.CPU0.SPSD], AE_ALREADY_EXISTS (20190816/dswload2-326)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: \_PR_.CPU0: _OSC native thermal LVT Acked
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Dynamic OEM Table Load:
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: SSDT 0xFFFF94661D141800 0003CF (v02 PmRef  Cpu0Cst  00003001 INTL 20141107)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Dynamic OEM Table Load:
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: SSDT 0xFFFF94661D1A8000 00008E (v02 PmRef  Cpu0Hwp  00003000 INTL 20141107)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Dynamic OEM Table Load:
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: SSDT 0xFFFF94661D151C00 000130 (v02 PmRef  HwpLvt   00003000 INTL 20141107)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Dynamic OEM Table Load:
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: SSDT 0xFFFF94661D236800 0005AA (v02 PmRef  ApIst    00003000 INTL 20141107)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Dynamic OEM Table Load:
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: SSDT 0xFFFF94661D150400 000119 (v02 PmRef  ApHwp    00003000 INTL 20141107)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Dynamic OEM Table Load:
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: SSDT 0xFFFF94661D21F200 000119 (v02 PmRef  ApCst    00003000 INTL 20141107)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Interpreter enabled
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: (supports S0 S3 S4 S5)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Using IOAPIC for interrupt routing
Sep 25 11:18:46 deus-ex-machina kernel: PCI: MMCONFIG for domain 0000 [bus 00-3f] at [mem 0xf8000000-0xfbffffff] (base 0xf8000000)
Sep 25 11:18:46 deus-ex-machina kernel: PCI: MMCONFIG at [mem 0xf8000000-0xfbffffff] reserved in ACPI motherboard resources
Sep 25 11:18:46 deus-ex-machina kernel: PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Enabled 5 GPEs in block 00 to 7F
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Power Resource [PUBS] (on)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Power Resource [PG00] (on)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Power Resource [PG01] (on)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Power Resource [PG02] (on)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 *11)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 *10 11)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 10 *11)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 *11)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 9 10 *11)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 9 10 *11)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 9 10 11) *0, disabled.
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 9 10 *11)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-80])
Sep 25 11:18:46 deus-ex-machina kernel: acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI HPX-Type3]
Sep 25 11:18:46 deus-ex-machina kernel: acpi PNP0A08:00: _OSC: platform does not support [SHPCHotplug PCIeCapability LTR]
Sep 25 11:18:46 deus-ex-machina kernel: acpi PNP0A08:00: _OSC: not requesting control; platform does not support [PCIeCapability]
Sep 25 11:18:46 deus-ex-machina kernel: acpi PNP0A08:00: _OSC: OS requested [PCIeHotplug SHPCHotplug PME AER PCIeCapability LTR]
Sep 25 11:18:46 deus-ex-machina kernel: acpi PNP0A08:00: _OSC: platform willing to grant [PCIeHotplug PME AER]
Sep 25 11:18:46 deus-ex-machina kernel: acpi PNP0A08:00: _OSC failed (AE_SUPPORT); disabling ASPM
Sep 25 11:18:46 deus-ex-machina kernel: acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge


Sep 25 11:18:46 deus-ex-machina kernel: intel_idle: MWAIT substates: 0x11142120
Sep 25 11:18:46 deus-ex-machina kernel: intel_idle: v0.4.1 model 0x5E
Sep 25 11:18:46 deus-ex-machina kernel: intel_idle: lapic_timer_reliable_states 0xffffffff
Sep 25 11:18:46 deus-ex-machina kernel: input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Lid Switch [LID]
Sep 25 11:18:46 deus-ex-machina kernel: input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Sleep Button [SLPB]
Sep 25 11:18:46 deus-ex-machina kernel: input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Power Button [PWRF]
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU1._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU2._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU3._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU4._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU5._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU6._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU7._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: thermal LNXTHERM:00: registered as thermal_zone0
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Thermal Zone [THM0] (50 C)


Sep 25 11:18:46 deus-ex-machina kernel: intel_idle: MWAIT substates: 0x11142120
Sep 25 11:18:46 deus-ex-machina kernel: intel_idle: v0.4.1 model 0x5E
Sep 25 11:18:46 deus-ex-machina kernel: intel_idle: lapic_timer_reliable_states 0xffffffff
Sep 25 11:18:46 deus-ex-machina kernel: input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Lid Switch [LID]
Sep 25 11:18:46 deus-ex-machina kernel: input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Sleep Button [SLPB]
Sep 25 11:18:46 deus-ex-machina kernel: input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
Sep 25 11:18:46 deus-ex-machina kernel: ACPI: Power Button [PWRF]
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU1._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU2._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU3._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU4._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU5._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU6._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_PR.CPU0._CPC.CPC1], AE_NOT_FOUND (20190816/psargs-330)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU0._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Sep 25 11:18:46 deus-ex-machina kernel: ACPI Error: Aborting method \_PR.CPU7._CPC due to previous error (AE_NOT_FOUND) (20190816/psparse-529)
Comment 1 Zhang Rui 2021-01-03 13:06:58 UTC
Most of these errors are related with buggy BIOS code, which we will not fix in kernel.

Bug closed first. Please feel free to reopen it if there are some functionality issues that are related with these ACPI errors.

Note You need to log in before you can comment on or make changes to this bug.