Bug 209367 - brcmsmac: Kernel panic with BCM4313 wireless device since 5.8
Summary: brcmsmac: Kernel panic with BCM4313 wireless device since 5.8
Status: RESOLVED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: Intel Linux
: P1 high
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-23 21:16 UTC by Laz Lev
Modified: 2021-04-28 19:17 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.8.10
Tree: Mainline
Regression: No


Attachments

Description Laz Lev 2020-09-23 21:16:11 UTC
On Arch Linux since kernel version 5.8 (also tested latest version 5.8.10) I get kernel panics when I for example use the command "sudo pacman -Syu" and multiple updates are downloaded simultaneously.

Downgrading to kernel 5.7.12 fixes the issue for me, so I'm guessing one of the commits that came with kernel 5.8 is causing this:
https://github.com/torvalds/linux/commits/cb8e59cc87201af93dfbb6c3dccc8fcad72a09c2/drivers/net/wireless/broadcom/brcm80211/brcmsmac

There are already multiple other reports about this issue:
[1] https://lore.kernel.org/linux-wireless/87tuwgi92n.fsf@yujinakao.com/
[2] https://lore.kernel.org/linux-wireless/CAGzOMfGZ9nYk7ESvWYspBOQMWre7WnCVLO4Q6+8mvSQOkoXUKg@mail.gmail.com/
[3] https://bbs.archlinux.org/viewtopic.php?id=258428

$ sudo lspci -vnn -d 14e4:
44:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
	DeviceName: WLAN
	Subsystem: Hewlett-Packard Company Device [103c:145c]
	Flags: bus master, fast devsel, latency 0, IRQ 19
	Memory at d0500000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [58] Vendor Specific Information: Len=78 <?>
	Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [d0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [13c] Virtual Channel
	Capabilities: [160] Device Serial Number 00-00-82-ff-ff-ce-00-26
	Capabilities: [16c] Power Budgeting <?>
	Kernel driver in use: bcma-pci-bridge
	Kernel modules: bcma

I can provide a picture of the kernel panic but I think that the bug report in [1] already contains all the information.
Comment 1 Laz Lev 2021-04-28 19:17:00 UTC
fixed with this commit (https://github.com/torvalds/linux/commit/01c195de620bb6c3ecda0dbf295fe685d8232e10) since linux 5.11

Note You need to log in before you can comment on or make changes to this bug.