Bug 20892 - PROBLEM: kernel 2.6.35.7 crashes under I/O load
Summary: PROBLEM: kernel 2.6.35.7 crashes under I/O load
Status: RESOLVED OBSOLETE
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: io_other
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-10-21 18:21 UTC by Maciej Rutecki
Modified: 2012-08-14 11:19 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.35.7
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-10-21 18:21:26 UTC
Subject    : PROBLEM: kernel 2.6.35.7 crashes under I/O load
Submitter  : Etienne Vogt <evogt@free.fr>
Date       : 2010-10-20 21:20
Message-ID : alpine.DEB.1.10.1010202300540.3989@coniglio.vogt-bodving.test
References : http://marc.info/?l=linux-kernel&m=128761179615272&w=2

This entry is being used for tracking a regression from 2.6.34. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Sean Busby 2010-10-23 14:21:06 UTC
I've seen this since 2.6.31.*, mostly when doing multiple simultaneous video encodes which produced heavy I/O load.  Finally found this solution: http://ubuntuforums.org/showthread.php?t=1363283

Setting libata.force=noncq kernel option at boot and turning off the HDD's write caching with hdparm seems to have solved it.
Comment 2 Etienne Vogt 2010-10-23 16:25:02 UTC
The problem reported by Sean Busby is probably different : I'm using the legacy IDE stack, not libata and it never crashed for me under 2.6.34.
I upgraded to 2.6.36 yesterday and for the moment, no crashes. I reprocessed the mpeg file that crashed under 2.6.35.7 and it worked fine under 2.6.36.
It's perhaps a bit early to say the problem is no longer present under 2.6.36, but at least it looks better.

Note You need to log in before you can comment on or make changes to this bug.