Bug 208783 - Lenovo ThinkPad X390 won’t boot while plugged in
Summary: Lenovo ThinkPad X390 won’t boot while plugged in
Status: NEW
Alias: None
Product: Power Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: Rafael J. Wysocki
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-03 11:12 UTC by Matej
Modified: 2020-08-04 14:14 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.19.0-10-amd64, 5.4.0-42-generic
Tree: Mainline
Regression: No


Attachments
cpuinfo (10.25 KB, text/plain)
2020-08-04 14:12 UTC, Matej
Details
iomem (3.45 KB, text/plain)
2020-08-04 14:13 UTC, Matej
Details
ioports (1.13 KB, text/plain)
2020-08-04 14:13 UTC, Matej
Details
lspci (59.93 KB, text/plain)
2020-08-04 14:14 UTC, Matej
Details
modules (9.33 KB, text/plain)
2020-08-04 14:14 UTC, Matej
Details

Description Matej 2020-08-03 11:12:01 UTC
Hello. I’m using Lenovo ThinkPad X390 Yoga (model type: 20NN002NMC). I have been using dual boot of the preinstalled Windows 10 x64 and Linux (formerly Debian based distro. I have tried the latest versions of Debian and Ubuntu). About 6 weeks ago, after updating the BIOS to N2LET76W 1.75 (https://download.lenovo.com/pccbbs/mobiles/n2lur14w.txt) and the Intel Management Engine Firmware (12.0.67.1579), an issue arose.
When I boot to Debian 10 Buster/Ubuntu 20.04.1 (kernel 4.19.0-10-amd64 and 5.4.0-42-generic) using the Grub bootloader with active Secure Boot (fully supported), and then I turn the notebook off or restart it in Debian/Ubuntu, it won’t turn back on – it won’t POST, the screen is black, etc. After that time, I need to unplug the notebook from the power adapter, or remove it from the dock, and it will boot on battery. But it won’t boot while plugged in until it boots into Windows and is turned off/restart from it. After booting to Windows, it works fine while plugged in, until it is turned off in Debian/Ubuntu again. I have tried install firmware-linux-nonfree etc...
It looks like a BIOS/Firmware error related to power management. I’m using the latest BIOS/Firmware updated via the official Lenovo software – Lenovo Vantage (bios version 1.76). Notebook was sent to Lenovo for repairs, the motherboard was replaced, yet the problem persists – hence thinking it’s BIOS/Firmware related.
Lenovo claims it’s Linux’s issue, even though the list it as officially supported (https://support.lenovo.com/sk/en/solutions/pd031426) and there refer me to the community. Lenovo stuff inform me too, that this issue may be related to requirements Windows 10 v2004.
Many thanks for your help.
Comment 1 Matej 2020-08-04 14:12:43 UTC
Created attachment 290761 [details]
cpuinfo
Comment 2 Matej 2020-08-04 14:13:08 UTC
Created attachment 290763 [details]
iomem
Comment 3 Matej 2020-08-04 14:13:55 UTC
Created attachment 290765 [details]
ioports
Comment 4 Matej 2020-08-04 14:14:20 UTC
Created attachment 290767 [details]
lspci
Comment 5 Matej 2020-08-04 14:14:42 UTC
Created attachment 290769 [details]
modules

Note You need to log in before you can comment on or make changes to this bug.