Bug 208763 - Lenovo 14ARE05 Internal Microphone not working
Summary: Lenovo 14ARE05 Internal Microphone not working
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-01 07:35 UTC by Alex Maras
Modified: 2020-08-10 14:20 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.7.11-arch1-1
Tree: Mainline
Regression: No


Attachments

Description Alex Maras 2020-08-01 07:35:39 UTC
The internal microphone input is not working with a Lenovo 14ARE05.

I have disabled pulseaudio in order to test. ALSA shows a "Capture" meter as well as 2 "Mic Boost" meters. Increasing any of these and ensuring "Capture" is enabled has not helped. 

I've run alsa-info.sh, results here: http://alsa-project.org/db/?f=cdc89e314d1d213595ded34fb6721e3317d2cc2b

I've tested with arecord, which just seems to just get light noise (less with higher sample rates). Audio output works perfectly. Running audacity and trying to record shows an error determining sample rate. No other applications are successfully detecting a microphone. pavucontrol when pulseaudio is running just shows "microphone (unplugged)"

I've also tried with 5.8rc7 via the arch-mainline package in the AUR. No change there.
Comment 1 Alex Maras 2020-08-01 10:37:44 UTC
Just a clarification - I imported the arecord-created file, and can confirm there's absolutely no sound recording. The light noise I heard must have just been speakers activating.
Comment 2 Theorlangur 2020-08-10 09:51:59 UTC
Didn't work for me in 5.7 but works with 5.8 (5.8.0-2 on Manjaro)

also-info.sh here: http://alsa-project.org/db/?f=ec99d2e55ad0fa34bd0c00fcae79df0678283a09

Is this possibly the relevant commit that should've addressed the issue:
https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git/commit/?h=for-5.8&id=bc5c7f55f5ea91e137fc7939435ed2e2bb6e5a15

?
Comment 3 Alex Maras 2020-08-10 13:58:00 UTC
Updated alsa-info.sh from 5.8.0.1-mainline aur package: http://alsa-project.org/db/?f=acee22c67fdb9b99d86988600d39c880184683a3 - no change from 5.7 for me.
Comment 4 Alex Maras 2020-08-10 14:20:03 UTC
Ah, 5.8 from the testing repo in arch has fixed the issue - looks like the kernel config was missing necessary modules in the AUR package.

Note You need to log in before you can comment on or make changes to this bug.