Bug 20872 - [tip] NULL pointer dereference in free_irte()
[tip] NULL pointer dereference in free_irte()
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-10-21 18:11 UTC by Maciej Rutecki
Modified: 2010-11-16 17:38 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.36-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-10-21 18:11:10 UTC
Subject    : [tip] NULL pointer dereference in free_irte()
Submitter  : Mike Galbraith <efault@gmx.de>
Date       : 2010-10-19 3:25
Message-ID : 1287458731.7546.9.camel@marge.simson.net
References : http://marc.info/?l=linux-kernel&m=128745875505836&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Dan Carpenter 2010-10-26 18:59:06 UTC
This is not a kernel.org kernel it's an experimental -tip kernel.
Comment 2 Thomas Gleixner 2010-10-26 20:28:27 UTC
On Tue, 26 Oct 2010, bugzilla-daemon@bugzilla.kernel.org wrote:
> --- Comment #1 from Dan Carpenter <error27@gmail.com>  2010-10-26 18:59:06 ---
> This is not a kernel.org kernel it's an experimental -tip kernel.

That's fixed with 9717967c4b704ce344c954afb5bb160aa9c01c34. Dan, can
you please check if that commit exist in your experimental tree ?

Thanks,

	tglx
Comment 3 Mike Galbraith 2010-10-27 02:49:22 UTC
(In reply to comment #2)
> On Tue, 26 Oct 2010, bugzilla-daemon@bugzilla.kernel.org wrote:
> > --- Comment #1 from Dan Carpenter <error27@gmail.com>  2010-10-26 18:59:06 ---
> > This is not a kernel.org kernel it's an experimental -tip kernel.
> 
> That's fixed with 9717967c4b704ce344c954afb5bb160aa9c01c34. Dan, can
> you please check if that commit exist in your experimental tree ?
> 
> Thanks,
> 
>     tglx

(Mike actually;)

Fix confirmed.

Note You need to log in before you can comment on or make changes to this bug.