Bug 208583 - Regression - nvme not detected
Summary: Regression - nvme not detected
Status: RESOLVED CODE_FIX
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: NVMe (show other bugs)
Hardware: Intel Linux
: P1 blocking
Assignee: IO/NVME Virtual Default Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-16 06:55 UTC by plamen.lyutov
Modified: 2021-10-19 11:29 UTC (History)
0 users

See Also:
Kernel Version: 5.7.8
Tree: Mainline
Regression: No


Attachments

Description plamen.lyutov 2020-07-16 06:55:40 UTC
After upgrade to kernel 5.7.8 and lts-5.4.51 linux is not detecting nvme drive and won't boot with both linux and linux-lts

device is:
01:00.0 Non-Volatile memory controller: Silicon Motion, Inc. Device 2263 (rev 03)

Motherboard is Gigabyte J4005ND2P-CF

This happened again last year with some kernel versions until get fixed in next releases. And again now.
I had to rollback to kernel 5.7.7 to get it work.
Comment 1 Ingo Brunberg 2020-07-17 12:03:02 UTC
I have already reported the problem to the linux nvme mailing list, because bugzilla is mostly ignored. Until a fix gets into stable, you can manually revert the offending commit (essentially just one line):
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.7.y&id=e2cb0c5635ecf7d8f2bde9971edbe00a0b8b8536
Comment 2 Artem S. Tashkinov 2021-10-18 15:13:33 UTC
Is this still an issue?
Comment 3 Artem S. Tashkinov 2021-10-19 11:29:16 UTC
If the issue is still present in kernels 5.13.14, 5.10.74 or 5.4.154, please reopen.

Note You need to log in before you can comment on or make changes to this bug.