Bug 208573 - Black screen on boot if two displays plugged in with NAVI 10
Summary: Black screen on boot if two displays plugged in with NAVI 10
Status: CLOSED DUPLICATE of bug 206903
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-15 18:36 UTC by Thomas Langkamp
Modified: 2021-05-24 18:03 UTC (History)
2 users (show)

See Also:
Kernel Version: 5.8.0-2-MANJARO
Tree: Mainline
Regression: No


Attachments
dmesg just after plugging in second display (97.01 KB, text/plain)
2020-07-15 19:01 UTC, Thomas Langkamp
Details
xorg.log just after connecting second display (55.75 KB, text/plain)
2020-07-15 19:01 UTC, Thomas Langkamp
Details
reproducable error messages after suspend, then reboot (419.20 KB, image/jpeg)
2020-08-10 11:46 UTC, Thomas Langkamp
Details
signature.asc (207 bytes, application/pgp-signature)
2020-08-10 15:55 UTC, Thomas Langkamp
Details

Description Thomas Langkamp 2020-07-15 18:36:51 UTC
With Radeon R9 Fury X and 2 4k displays @60hz, one LG TV@HDMI, one iiyama@DP => everything fine

With new Radeon 5700 from Asus 
=> black screen after grub menu and after some time the gpu-fans spin up a bit and the mainboard debug LED starts flashing. Then reset-button is the only option.

With new Radeon 5700 XT from Gigabyte 
=> same

So I can already rule out a hardware fault.

What helps:
- Starting a recovery boot entry in grub 
- OR disconecting one display before reboot

Both 5700 cards work always fine with only one display connected. If I connect the second display later, when I am already on desktop environment - also everything works. 

Other things I tried
- changing to 30 hz then reboot
- kernels from 5.4 onwards
- different ports on the gpu
- DP to HDMI-adapter


sudo dmesg | grep amdgpu
[sudo] Passwort für tom: 
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=74886ca0-4a71-4692-aa0c-b2a539ec6b48 rw quiet loglevel=3 rd.systemd.show_status=auto rd.udev.log_priority=3 amdgpu.ppfeaturemask=0xfffd7fff resume=LABEL=swap libahci.ignore_sss=1
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=74886ca0-4a71-4692-aa0c-b2a539ec6b48 rw quiet loglevel=3 rd.systemd.show_status=auto rd.udev.log_priority=3 amdgpu.ppfeaturemask=0xfffd7fff resume=LABEL=swap libahci.ignore_sss=1
[    2.597324] [drm] amdgpu kernel modesetting enabled.
[    2.597526] fb0: switching to amdgpudrmfb from EFI VGA
[    2.597631] amdgpu 0000:0d:00.0: vgaarb: deactivate vga console
[    2.597664] amdgpu 0000:0d:00.0: enabling device (0006 -> 0007)
[    2.615476] amdgpu 0000:0d:00.0: VRAM: 8176M 0x0000008000000000 - 0x00000081FEFFFFFF (8176M used)
[    2.615477] amdgpu 0000:0d:00.0: GART: 512M 0x0000000000000000 - 0x000000001FFFFFFF
[    2.615580] [drm] amdgpu: 8176M of VRAM memory ready
[    2.615583] [drm] amdgpu: 8176M of GTT memory ready.
[    3.433349] amdgpu 0000:0d:00.0: RAS: optional ras ta ucode is not available
[    3.528083] snd_hda_intel 0000:0d:00.1: bound 0000:0d:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[    3.628396] fbcon: amdgpudrmfb (fb0) is primary device
[    3.739398] amdgpu 0000:0d:00.0: fb0: amdgpudrmfb frame buffer device
[    3.783482] amdgpu 0000:0d:00.0: ring gfx_0.0.0 uses VM inv eng 0 on hub 0
[    3.783485] amdgpu 0000:0d:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[    3.783487] amdgpu 0000:0d:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[    3.783489] amdgpu 0000:0d:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[    3.783491] amdgpu 0000:0d:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[    3.783492] amdgpu 0000:0d:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[    3.783494] amdgpu 0000:0d:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[    3.783496] amdgpu 0000:0d:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[    3.783498] amdgpu 0000:0d:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[    3.783499] amdgpu 0000:0d:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[    3.783501] amdgpu 0000:0d:00.0: ring sdma0 uses VM inv eng 12 on hub 0
[    3.783503] amdgpu 0000:0d:00.0: ring sdma1 uses VM inv eng 13 on hub 0
[    3.783505] amdgpu 0000:0d:00.0: ring vcn_dec uses VM inv eng 0 on hub 1
[    3.783506] amdgpu 0000:0d:00.0: ring vcn_enc0 uses VM inv eng 1 on hub 1
[    3.783508] amdgpu 0000:0d:00.0: ring vcn_enc1 uses VM inv eng 4 on hub 1
[    3.783510] amdgpu 0000:0d:00.0: ring jpeg_dec uses VM inv eng 5 on hub 1
[    3.784426] [drm] Initialized amdgpu 3.37.0 20150101 for 0000:0d:00.0 on minor 0
[ 2050.217010] amdgpu 0000:0d:00.0: RAS: optional ras ta ucode is not available
[ 2050.416499] [drm:dpcd_set_source_specific_data [amdgpu]] *ERROR* Error in DP aux read transaction, not writing source specific data
[ 2050.925049] [drm:retrieve_link_cap [amdgpu]] *ERROR* retrieve_link_cap: Read dpcd data failed.
[ 2050.934845] amdgpu 0000:0d:00.0: ring gfx_0.0.0 uses VM inv eng 0 on hub 0
[ 2050.934846] amdgpu 0000:0d:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[ 2050.934846] amdgpu 0000:0d:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[ 2050.934847] amdgpu 0000:0d:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[ 2050.934847] amdgpu 0000:0d:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[ 2050.934848] amdgpu 0000:0d:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[ 2050.934849] amdgpu 0000:0d:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[ 2050.934849] amdgpu 0000:0d:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[ 2050.934850] amdgpu 0000:0d:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[ 2050.934850] amdgpu 0000:0d:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[ 2050.934851] amdgpu 0000:0d:00.0: ring sdma0 uses VM inv eng 12 on hub 0
[ 2050.934851] amdgpu 0000:0d:00.0: ring sdma1 uses VM inv eng 13 on hub 0
[ 2050.934852] amdgpu 0000:0d:00.0: ring vcn_dec uses VM inv eng 0 on hub 1
[ 2050.934852] amdgpu 0000:0d:00.0: ring vcn_enc0 uses VM inv eng 1 on hub 1
[ 2050.934853] amdgpu 0000:0d:00.0: ring vcn_enc1 uses VM inv eng 4 on hub 1
[ 2050.934853] amdgpu 0000:0d:00.0: ring jpeg_dec uses VM inv eng 5 on hub 1



lspci -v
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Root Complex
        Subsystem: ASRock Incorporation Device 1450
        Flags: fast devsel

00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
        Flags: fast devsel

00:01.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 25
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: fcf00000-fcffffff [size=1M]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

00:01.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 26
        Bus: primary=00, secondary=02, subordinate=0a, sec-latency=0
        I/O behind bridge: 0000f000-0000ffff [size=4K]
        Memory behind bridge: fcc00000-fcdfffff [size=2M]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
        Flags: fast devsel

00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
        Flags: fast devsel

00:03.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 27
        Bus: primary=00, secondary=0b, subordinate=0d, sec-latency=0
        I/O behind bridge: 0000e000-0000efff [size=4K]
        Memory behind bridge: fca00000-fcbfffff [size=2M]
        Prefetchable memory behind bridge: 00000000e0000000-00000000f01fffff [size=258M]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

00:04.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
        Flags: fast devsel

00:07.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
        Flags: fast devsel

00:07.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Internal PCIe GPP Bridge 0 to Bus B (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 28
        Bus: primary=00, secondary=0e, subordinate=0e, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: fc700000-fc9fffff [size=3M]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
        Flags: fast devsel

00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Internal PCIe GPP Bridge 0 to Bus B (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 30
        Bus: primary=00, secondary=0f, subordinate=0f, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: fce00000-fcefffff [size=1M]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 59)
        Subsystem: ASRock Incorporation Device 790b
        Flags: 66MHz, medium devsel
        Kernel driver in use: piix4_smbus
        Kernel modules: i2c_piix4, sp5100_tco

00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
        Subsystem: ASRock Incorporation Device 790e
        Flags: bus master, 66MHz, medium devsel, latency 0

00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 0
        Flags: fast devsel

00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 1
        Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 2
        Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 3
        Flags: fast devsel
        Kernel driver in use: k10temp
        Kernel modules: k10temp

00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 4
        Flags: fast devsel

00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 5
        Flags: fast devsel

00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 6
        Flags: fast devsel

00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 7
        Flags: fast devsel

01:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981/PM983 (prog-if 02 [NVM Express])
        Subsystem: Samsung Electronics Co Ltd Device a801
        Flags: bus master, fast devsel, latency 0, IRQ 45, NUMA node 0
        Memory at fcf00000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: nvme

02:00.0 USB controller: Advanced Micro Devices, Inc. [AMD] Device 43d0 (rev 01) (prog-if 30 [XHCI])
        Subsystem: ASRock Incorporation Device 43d0
        Flags: bus master, fast devsel, latency 0, IRQ 29
        Memory at fcda0000 (64-bit, non-prefetchable) [size=32K]
        Capabilities: <access denied>
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci

02:00.1 SATA controller: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset SATA Controller (rev 01) (prog-if 01 [AHCI 1.0])
        Subsystem: ASRock Incorporation Device 43c8
        Flags: bus master, fast devsel, latency 0, IRQ 47
        Memory at fcd80000 (32-bit, non-prefetchable) [size=128K]
        Expansion ROM at fcd00000 [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: ahci

02:00.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Bridge (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 32
        Bus: primary=02, secondary=03, subordinate=0a, sec-latency=0
        I/O behind bridge: 0000f000-0000ffff [size=4K]
        Memory behind bridge: fcc00000-fccfffff [size=1M]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

03:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 33
        Bus: primary=03, secondary=04, subordinate=04, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: [disabled]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

03:01.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 35
        Bus: primary=03, secondary=05, subordinate=05, sec-latency=0
        I/O behind bridge: 0000f000-0000ffff [size=4K]
        Memory behind bridge: fcc00000-fccfffff [size=1M]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

03:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 36
        Bus: primary=03, secondary=06, subordinate=06, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: [disabled]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

03:03.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 38
        Bus: primary=03, secondary=07, subordinate=07, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: [disabled]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

03:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 39
        Bus: primary=03, secondary=08, subordinate=08, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: [disabled]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

03:06.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 40
        Bus: primary=03, secondary=09, subordinate=09, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: [disabled]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

03:07.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset PCIe Port (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 41
        Bus: primary=03, secondary=0a, subordinate=0a, sec-latency=0
        I/O behind bridge: [disabled]
        Memory behind bridge: [disabled]
        Prefetchable memory behind bridge: [disabled]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

05:00.0 Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03)
        Subsystem: ASRock Incorporation Device 1539
        Flags: bus master, fast devsel, latency 0, IRQ 34
        Memory at fcc00000 (32-bit, non-prefetchable) [size=128K]
        I/O ports at f000 [size=32]
        Memory at fcc20000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: igb
        Kernel modules: igb

0b:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 XL Upstream Port of PCI Express Switch (rev c1) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at fcb00000 (32-bit, non-prefetchable) [size=16K]
        Bus: primary=0b, secondary=0c, subordinate=0d, sec-latency=0
        I/O behind bridge: 0000e000-0000efff [size=4K]
        Memory behind bridge: fca00000-fcafffff [size=1M]
        Prefetchable memory behind bridge: 00000000e0000000-00000000f01fffff [size=258M]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

0c:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 XL Downstream Port of PCI Express Switch (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0, IRQ 44
        Bus: primary=0c, secondary=0d, subordinate=0d, sec-latency=0
        I/O behind bridge: 0000e000-0000efff [size=4K]
        Memory behind bridge: fca00000-fcafffff [size=1M]
        Prefetchable memory behind bridge: 00000000e0000000-00000000f01fffff [size=258M]
        Capabilities: <access denied>
        Kernel driver in use: pcieport

0d:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] (rev c1) (prog-if 00 [VGA controller])
        Subsystem: Gigabyte Technology Co., Ltd Device 2316
        Flags: bus master, fast devsel, latency 0, IRQ 111
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at f0000000 (64-bit, prefetchable) [size=2M]
        I/O ports at e000 [size=256]
        Memory at fca00000 (32-bit, non-prefetchable) [size=512K]
        Expansion ROM at fca80000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

0d:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 HDMI Audio
        Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 HDMI Audio
        Flags: bus master, fast devsel, latency 0, IRQ 110
        Memory at fcaa0000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel

0e:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Zeppelin/Raven/Raven2 PCIe Dummy Function
        Subsystem: Advanced Micro Devices, Inc. [AMD] Zeppelin/Raven/Raven2 PCIe Dummy Function
        Flags: fast devsel
        Capabilities: <access denied>

0e:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Platform Security Processor
        Subsystem: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Platform Security Processor
        Flags: bus master, fast devsel, latency 0, IRQ 99
        Memory at fc800000 (32-bit, non-prefetchable) [size=1M]
        Memory at fc900000 (32-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: ccp
        Kernel modules: ccp

0e:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Zeppelin USB 3.0 Host controller (prog-if 30 [XHCI])
        Subsystem: ASRock Incorporation Device 7914
        Flags: bus master, fast devsel, latency 0, IRQ 90
        Memory at fc700000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: <access denied>
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci

0f:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Zeppelin/Renoir PCIe Dummy Function
        Subsystem: Advanced Micro Devices, Inc. [AMD] Zeppelin/Renoir PCIe Dummy Function
        Flags: fast devsel
        Capabilities: <access denied>

0f:00.2 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 51) (prog-if 01 [AHCI 1.0])
        Subsystem: ASRock Incorporation Device 7901
        Flags: bus master, fast devsel, latency 0, IRQ 49
        Memory at fce08000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: ahci

0f:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller
        Subsystem: ASRock Incorporation Device 2220
        Flags: bus master, fast devsel, latency 0, IRQ 46
        Memory at fce00000 (32-bit, non-prefetchable) [size=32K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
Comment 1 Alex Deucher 2020-07-15 18:50:32 UTC
Please attach your full dmesg output and xorg log (if using X).
Comment 2 Thomas Langkamp 2020-07-15 19:01:01 UTC
Created attachment 290305 [details]
dmesg just after plugging in second display
Comment 3 Thomas Langkamp 2020-07-15 19:01:53 UTC
Created attachment 290307 [details]
xorg.log just after connecting second display
Comment 4 Thomas Langkamp 2020-07-16 17:07:23 UTC
Maybe it has something to do with my X470 Board not being PCI-E 4.0?
I switched to a better PSU today, but that did not help either.
Both screens completely black until I pull one cable and reboot.
Comment 5 Thomas Langkamp 2020-08-10 11:46:49 UTC
Created attachment 290817 [details]
reproducable error messages after suspend, then reboot

This error message is reproducable if I boot
- with 1 display
- on KDE connect second display
- suspend, then wakeup (both screens work normal until this point)
- then reboot => error message, then black screen on one and green screen on secondary display.

Because my Mainboard got a new Bios I tried that with no effect. But I realized, that I get the black screen only if I dial in the 3200 Mhz XMP Profile of my RAM. If not - there is no black screen with 2 displays on the new BIOS. On the old BIOS XMP Profile or not made no difference. Thus the mainboard may be part of the problem.
Comment 6 Thomas Langkamp 2020-08-10 12:06:29 UTC
(In reply to Thomas Langkamp from comment #5)
> Created attachment 290817 [details]
> reproducable error messages after suspend, then reboot
> 
> This error message is reproducable if I boot
> - with 1 display
> - on KDE connect second display
> - suspend, then wakeup (both screens work normal until this point)
> - then reboot => error message, then black screen on one and green screen on
> secondary display.
> 
> Because my Mainboard got a new Bios I tried that with no effect. But I
> realized, that I get the black screen only if I dial in the 3200 Mhz XMP
> Profile of my RAM. If not - there is no black screen with 2 displays on the
> new BIOS. On the old BIOS XMP Profile or not made no difference. Thus the
> mainboard may be part of the problem.

Still, Mainboard being part of the problem or not - all was fine til I switched the Fury X to the 5700 XT (first an ASROCK, now a Gigabyte one).
Comment 7 Thomas Langkamp 2020-08-10 12:10:42 UTC
I found a similar bug here: https://bugzilla.kernel.org/show_bug.cgi?id=206903#c51
Comment 8 Alex Deucher 2020-08-10 14:33:28 UTC
Do you only get the MCE errors when you set the XMP profile?
Comment 9 Thomas Langkamp 2020-08-10 15:55:25 UTC
Created attachment 290821 [details]
signature.asc

Yes. With the new BIOS this is reproducible only with XMP enabled.

In the other bugreport I read about

amdgpu.ppfeaturemask=0xffffbffd

I just tried it. Until now this seems to fix it, even with XMP profile 
enabled! I will report back if I get a black screen again.
As far as I know with 2 monitors attached the VRAM is always clocked 
high, so it makes sense that disabling the VRAM power management through 
this featuremask works around the issue. But surely a proper fix would 
be appreciated.

Am 10.08.20 um 16:33 schrieb bugzilla-daemon@bugzilla.kernel.org:
> https://bugzilla.kernel.org/show_bug.cgi?id=208573
> 
> --- Comment #8 from Alex Deucher (alexdeucher@gmail.com) ---
> Do you only get the MCE errors when you set the XMP profile?
>
Comment 10 Alex Deucher 2020-08-10 20:38:09 UTC
You can probably mark this bug as a duplicate of 208573 then.
Comment 11 Thomas Langkamp 2020-08-10 21:14:50 UTC
206903

*** This bug has been marked as a duplicate of bug 206903 ***
Comment 12 Thomas Langkamp 2020-09-03 06:06:37 UTC
This bug is gone!
I think since 5.8.1 or so.
I waited a couple of weeks to see if it comes back, but I can now boot, suspend and whatever with both screens connected.
Cheers :D
Comment 13 Andrej Podzimek 2021-05-23 02:34:17 UTC
And here we go, the bug is back in 5.12.5 or so (probably also in earlier 5.12 kernels).

In my case this occurs with 4 virtual and 2 physical screens connected (dual 5k MST) and a Radeon Pro W5700.

The issue this was deduplicated against has lots of extra investigation.
Comment 14 Alex Deucher 2021-05-24 18:03:22 UTC
Can you bisect?
https://www.kernel.org/doc/html/latest/admin-guide/bug-bisect.html

Note You need to log in before you can comment on or make changes to this bug.