Bug 208421 - iwlwifi: firmware: failed to load iwl-debug-yoyo.bin
Summary: iwlwifi: firmware: failed to load iwl-debug-yoyo.bin
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless-intel (show other bugs)
Hardware: All Linux
: P1 low
Assignee: Default virtual assignee for network-wireless-intel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-03 10:48 UTC by dtl
Modified: 2022-02-14 22:14 UTC (History)
3 users (show)

See Also:
Kernel Version: 5.8.x
Tree: Mainline
Regression: No


Attachments

Description dtl 2020-07-03 10:48:11 UTC
iwlwifi: firmware: failed to load iwl-debug-yoyo.bin (-2)
iwlwifi: Direct firmware load for iwl-debug-yoyo.bin failed with error -2

While these errors do not cause any issue that I can see, they are annoying (at best), and leave a user wondering how to remedy them. I thought maybe iwl-debug-yoyo.bin would be in the Intel firmware repo and I could silence the error, but no.

Addition info:
Debian sid, kernel 5.7.7
iwlwifi loaded firmware version 29.1044073957.0 3168-29.ucode op_mode iwlmvm

Thanks
Comment 1 KP 2020-09-10 04:53:25 UTC
Hi,

I had a look at this. This 'iwl-debug-yoyo.bin' file appears to be a TLV binary used to debug the WiFi FW. And the error code is since the file is not present on the file system. 

You can safely ignore this error, unless you need to debug something in the FW.
Comment 2 dtl 2020-09-10 05:08:36 UTC
Where can a user get this file if not provided by distro?

And yes, I know I *could* ignore it. But my point is that if it's not a serious error and the file is only needed when debugging, it shouldn't be logged as a serious error. 
Or, to be less technical, I shouldn't see bright red lines when I look at dmesg, just because I'm not debugging iwlwifi.
Comment 3 KP 2020-09-23 09:44:05 UTC
Hi,

This warning is suppressed now and available in upstream. Please refer to this patch https://patchwork.kernel.org/patch/11625759/
Comment 4 dtl 2020-09-24 13:47:10 UTC
I feel confident in closing this as 'RESOLVED' even though I am not using 5.9 kernel yet. If I experience the problem with 5.9, I will re-open this or make a new report.

Thank you for the link.
Comment 5 Enrique Garcia 2022-01-21 10:02:44 UTC
Hi,
I have seen this problem in Debian 11 which uses kernel 5.10.0-11. I have retrieved the kernel sources with apt install linux-source-5.10 and I can see that your patch is indeed included in the sources, but for whatever reason the message is still there.
Also others seem to have reported that the problem persists in the Debian bug tracker https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=969264
Thanks!
Comment 6 Enrique Garcia 2022-02-14 22:14:31 UTC
I have now upgraded my system to Debian 12 (testing= which includes linux kernel 5.15.0 and I have not seen the message anymore. So it seems to have been eventually fixed.

Note You need to log in before you can comment on or make changes to this bug.