Bug 208361 - r8169: support RTL8125 rev04
Summary: r8169: support RTL8125 rev04
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 enhancement
Assignee: drivers_network@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-29 03:14 UTC by Xingjian Di
Modified: 2020-07-15 15:42 UTC (History)
1 user (show)

See Also:
Kernel Version: latest
Tree: Mainline
Regression: No


Attachments

Description Xingjian Di 2020-06-29 03:14:56 UTC
A new revision of RTL8125 is installed on the recently released MSI B550M Mortar. 

$ lspci | grep RTL8125
2a:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 04)

The stable kernel 5.7.6 I am running does not support this revision.

$ dmesg | grep r8169
[    3.793254] r8169 0000:2a:00.0: enabling device (0000 -> 0003)
[    3.793340] r8169 0000:2a:00.0: unknown chip XID 641

I checked the master and confirmed that this XID is still not supported.

For reference, the vendor driver r8125 worked for me on a previous stable kernel (but not on 5.7.6,) and worked on the latest LTS kernel.

Since this is the only wired controller on this motherboard, support for this would be very useful for owners of this model.
Comment 1 Heiner Kallweit 2020-06-29 08:44:02 UTC
I'm aware of missing support for new RTL8125B. A direct mail to me would have been better than opening a bug report for something that isn't a bug.
I have a draft of RTL8125B mainline support ready and sent it to the first user for test (as I don't have hw for testing).
Would you be able/willing to apply this draft patch on top of linux-next and test?
Comment 2 Xingjian Di 2020-06-29 13:22:03 UTC
I would be happy to test it!
Comment 3 Heiner Kallweit 2020-07-15 15:42:58 UTC
Support for RTL8125B is available on linux-next and will be included in 5.9.
In addition latest firmware for RTL8125B is needed from https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git.
It may take some time until updated linux-firmware package is available in all distro's.

Note You need to log in before you can comment on or make changes to this bug.