Bug 208317 - sound produced by thunderbolt 3 dock too slow and distorted (USB)
Summary: sound produced by thunderbolt 3 dock too slow and distorted (USB)
Status: RESOLVED DUPLICATE of bug 208353
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: x86-64 Linux
: P1 blocking
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-25 17:39 UTC by subjectdenied
Modified: 2020-07-09 14:15 UTC (History)
9 users (show)

See Also:
Kernel Version: 5.7.6
Tree: Mainline
Regression: No


Attachments

Description subjectdenied 2020-06-25 17:39:55 UTC
since 5.7.6 my elgato thunderbolt3 dock produces slow and distorted sound, for a video exactly showing this for kernel 5.8.x by another user, plz see 208311

i dont see this issue with kernel 5.6.19 btw
Comment 1 subjectdenied 2020-06-25 18:10:26 UTC
before the sound issues came up with 5.7.6, im pretty sure there was already something going on cause, i lost connection to a IR dongle for my keyboard that was plugged into the tb3 dock, removing it and pluging in again, froze my system more than once the past days (could have started with 5.75)
Comment 2 Mark Blakeney 2020-06-27 07:46:40 UTC
I have a Dell Thunderbolt WD19TB dock which connects my sound system via 3.5 mm plug and the same thing happened to me today when I upgraded from stock Arch kernel package 5.7.5 to 5.7.6. I switched back and forth a few times between those versions to confirm it.

I posted on the Arch forum about it at https://bbs.archlinux.org/viewtopic.php?pid=1912484.
Comment 3 Joseph Thommes 2020-06-27 10:16:50 UTC
I have exactly the same issue and setup as Mark Blakeney only that I am using a thinkpad and a Lenovo docking station.
Comment 4 Mark Blakeney 2020-06-29 05:06:30 UTC
I rebuilt my Arch 5.7.6 kernel with commit https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=d288dc74f8cf95cb7ae0aaf245b7128627a49bf3 reverted and can confirm that the audio problem goes away.
Comment 5 Steffen Weber 2020-06-29 09:58:47 UTC
I'm using a ThinkPad X1 Carbon Gen 8 with a ThinkPad Ultra Docking Station (40AJ) on Gentoo with Linux 5.7.6. Reverting the mentioned patch fixes the dock's audio port for external speakers for me, too.

Please let me know if / what debug info you need.
Comment 6 Takashi Iwai 2020-07-09 14:15:41 UTC
.

*** This bug has been marked as a duplicate of bug 208353 ***

Note You need to log in before you can comment on or make changes to this bug.