Bug 208141 - Wireless ac 9560 not working kernel 5.7.2
Summary: Wireless ac 9560 not working kernel 5.7.2
Status: RESOLVED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-11 20:58 UTC by jvr.vela
Modified: 2020-07-29 19:45 UTC (History)
12 users (show)

See Also:
Kernel Version: 5.7.2
Tree: Mainline
Regression: Yes


Attachments
Output dmesg (80.77 KB, text/plain)
2020-06-11 20:58 UTC, jvr.vela
Details
relevant log on 5.7.0 (4.48 KB, text/plain)
2020-06-13 09:52 UTC, manj-a-bug
Details
lspci -v output on 5.6.16 (827 bytes, text/plain)
2020-06-13 09:54 UTC, manj-a-bug
Details
lspci -v output on 5.7.0 (764 bytes, text/plain)
2020-06-13 17:44 UTC, manj-a-bug
Details
ethtool -i wlo1 output on 5.6.16 (260 bytes, text/plain)
2020-06-13 17:51 UTC, manj-a-bug
Details
lspci -v -nn output on 5.7.0 (795 bytes, text/plain)
2020-06-30 19:15 UTC, manj-a-bug
Details
dmesg output when manually added the IDs.txt (12.65 KB, text/plain)
2020-06-30 19:24 UTC, manj-a-bug
Details
lspci -v -nn output from vanja using Linux 5.4.49 (738 bytes, text/plain)
2020-07-01 03:46 UTC, Vanja
Details
0001-Restore-Killer-Wireless-AC-1550i-card-support.patch (1.27 KB, patch)
2020-07-01 18:46 UTC, manj-a-bug
Details | Diff

Description jvr.vela 2020-06-11 20:58:03 UTC
Created attachment 289617 [details]
Output dmesg

Updating from 5.6.15 to 5.7.2 broke wifi intel ac9560. Not detected even using lspci.
Comment 1 manj-a-bug 2020-06-13 09:52:29 UTC
Created attachment 289639 [details]
relevant log on 5.7.0

I can reproduce this with the exact same log (attached) on kernel 5.7.0, while the card works correctly on 5.6.16
Comment 2 manj-a-bug 2020-06-13 09:54:04 UTC
Created attachment 289641 [details]
lspci -v output on 5.6.16

Here is the output of lspci -v using the kernel 5.6.16
Comment 3 manj-a-bug 2020-06-13 17:44:20 UTC
Created attachment 289647 [details]
lspci -v output on 5.7.0

Using lspci I, unlike jvr.vela, was able to find my card even on 5.7.0 (maybe 5.7.2 introduced an additional bug?)
Comment 4 manj-a-bug 2020-06-13 17:51:57 UTC
Created attachment 289649 [details]
ethtool -i wlo1 output on 5.6.16

Here is the output of ethtool with kernel 5.6.16: the firmware version is "46.8902351f.0 9000-pu-b0-jf-b0-". I wasn't able to retrieve it on 5.7.0 because ethtool (and even ip) cannot find the interface of the card.
Comment 5 jvr.vela 2020-06-13 18:23:15 UTC
I just Checked again lspci (because manj-a-bug's third comment) and I have to add that lspci does detect the wifi. Wifi isn't working or detected by any other way or command.
Comment 6 manj-a-bug 2020-06-14 17:33:46 UTC
Note that my BIOS identifies this card as:
"Killer(R) Wireless-AC 1550i Wireless Network Adapter(9560NGW)"
Comment 7 jvr.vela 2020-06-25 12:22:15 UTC
Tested also with: 

5.7.2
5.7.3
5.7.4
5.7.5

Same results, unable to use wireless card.
Comment 8 Stefan I. 2020-06-25 15:07:20 UTC
And the same result with 5.7.6
Comment 9 Stefan I. 2020-06-26 11:49:56 UTC
I tried it today with the mainline-kernel (5.8-rc2). The problem exists there too.
Comment 10 Vanja 2020-06-26 14:06:34 UTC
I can also confirm kernel errors with Intel Wireless AC 9560 on Linux 5.7.2 to 5.7.6 unable to detect the device and kernel logs contain,

iwlwifi: probe of 0000:00:14.3 failed with error -22
Comment 11 Raven King 2020-06-29 17:11:07 UTC
Probably not helpful but I am also having this issue. In 5.6.15, it is correctly detected by lspci as:

00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)

In 5.7+ I have the exact same issue where it does not show on lspci and I get the probe error Vanja lists.
Comment 12 manj-a-bug 2020-06-30 10:23:48 UTC
Could you all check if the your card is an Intel one or is actually a Killer one? I suspect that the problem may occur only on the latter (because I think is really unlikely that Intel broke ITS card like this).
Comment 13 Luchesar ILIEV 2020-06-30 11:29:10 UTC
(In reply to manj-a-bug from comment #12)
> Could you all check if the your card is an Intel one or is actually a Killer
> one? I suspect that the problem may occur only on the latter (because I
> think is really unlikely that Intel broke ITS card like this).

Good point, indeed. I have the same problems and the card in my Lenovo Legion Y740 *is* the Killer AC 1550 (also double-checked with visual inspection).
Comment 14 Vanja 2020-06-30 11:45:55 UTC
(In reply to manj-a-bug from comment #12)
> Could you all check if the your card is an Intel one or is actually a Killer
> one?

Good call, it is indeed a Killer Wireless AC 1550, sorry I did not realize that was the case earlier!
Comment 15 Victor 2020-06-30 12:29:49 UTC
The same, lenovo y730
Comment 16 Stefan I. 2020-06-30 18:36:45 UTC
Yes it is the same device here (Killer Wireless AC 1550 @ Lenovo Legion Y740-17ICHg)
Comment 17 manj-a-bug 2020-06-30 19:15:24 UTC
Created attachment 289979 [details]
lspci -v -nn output on 5.7.0

So, I looked into the source and it looks like that they are removing an hack involving different cards: the point is that, from 5.6 to 5.7, they have ported the Killer Wireless AC 1550 card to a different type of configuration (in order to avoid the hack I mentioned). The problem is that the cards comes with different device and subdevice IDs and the ones of my card haven't been included in the port. Unfortunately I don't think it is just a distraction, because I tried to add the IDs of my card, but then the card still didn't work (I'll add the new log I obtained). Moreover it seams there are also other ids that haven't be ported: I ask you to check yours by running "lscpi -v -nn" as root and check if your IDs are different by comparing your output to the one I attached (in which my device id is "a370" and subdevice id is "1552").
Comment 18 manj-a-bug 2020-06-30 19:24:01 UTC
Created attachment 289981 [details]
dmesg output when manually added the IDs.txt

As I said a tried to manually add the missing IDs (I added "IWL_DEV_INFO(0xA370, 0x1552, iwl9560_2ac_cfg_soc, iwl9560_killer_1550i_name)" to "iwl_dev_info_table[]" in "iwlwifi/pcie/drv.c"), but it didn't work (I attached the new dmesg output if someone could find it useful).
Comment 19 Luchesar ILIEV 2020-06-30 19:26:50 UTC
(In reply to manj-a-bug from comment #17)
> (...) Moreover it seams
> there are also other ids that haven't be ported: I ask you to check yours by
> running "lscpi -v -nn" as root and check if your IDs are different by
> comparing your output to the one I attached (in which my device id is "a370"
> and subdevice id is "1552").

FWIW, my IDs (Lenovo Y740 15IRHg) are exactly the same as yours.
Comment 20 Vanja 2020-07-01 03:46:41 UTC
Created attachment 289987 [details]
lspci -v -nn output from vanja using Linux 5.4.49
Comment 21 manj-a-bug 2020-07-01 18:46:41 UTC
Created attachment 290037 [details]
0001-Restore-Killer-Wireless-AC-1550i-card-support.patch

Ok, the my patch works (the errors were my fault, recompiling the whole kernel fixed them) on my card "Killer(R) Wireless-AC 1550i Wireless Network Adapter(9560NGW)" (that has 0xA370 as device id and 0x1552 as subdevice id). I ask you to try the patch on your systems, so then, if it fix the problem, I will submit it. Please note that this patch actually works only on card with the same id and subdevice id as mine, so, if your card ha different values, please write them here, so I can update my patch (I  suspect that also the card with subdevice id 0x1551 are affected, but I cannot confirm that)
Comment 22 Stefan I. 2020-07-01 19:49:08 UTC
Thank you very much...i think your patch will fix it for my device cause it has the same ID's:

00:14.3 Network controller [0280]: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:a370] (rev 10)
	Subsystem: Bigfoot Networks, Inc. Device [1a56:1552]
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at a6418000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [c8] Power Management version 3
	Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [40] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [80] MSI-X: Enable+ Count=16 Masked-
	Capabilities: [100] Null
	Capabilities: [14c] Latency Tolerance Reporting
	Capabilities: [164] Vendor Specific Information: ID=0010 Rev=0 Len=014 <?>
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
Comment 23 lemonnier.k 2020-07-02 08:21:38 UTC
Thanks @manj-a-bug, I can confirm this works for me too with the same card on 5.7.6.
Comment 24 Vanja 2020-07-02 10:45:30 UTC
Thanks @manj-a-bug your patch works! I'm running right now on Linux 5.7.7 and it's working beautifully! First time I've built a kernel in a few years. By the way my computer is an MSI GS65.
Love your work!
Comment 25 Victor 2020-07-02 18:17:49 UTC
Lenovo y740-15IRHg archlinux 5.7.7 confirm patch is working! thx for your time and job @manj-a-bug

00:14.3 Network controller [0280]: Intel Corporation Wireless-AC 9560 [Jefferson Peak] [8086:a370] (rev 10)
	Subsystem: Bigfoot Networks, Inc. Device [1a56:1552]
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at a6418000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

pacman pkgs with kernek&headers you can download here https://yadi.sk/d/hzQ6hFKYOOuMog
Comment 26 jvr.vela 2020-07-02 22:08:41 UTC
I just finished compiling and can confirm it's working.

Linux archMsiR0Cif 5.7.7-arch1-1-JV #1 SMP PREEMPT Thu, 02 Jul 2020 17:58:37 +0000 x86_64 GNU/Linux

Nice job.
Comment 27 Stefan I. 2020-07-03 08:56:31 UTC
I've compield the iwlwifi module with your patch and it works perfect! Thanks for your work. I hope it will be implemented to 5.7.8
Comment 28 manj-a-bug 2020-07-03 09:16:09 UTC
The patch has been submitted (also with the support of the card with 0x1551 subdevice id), so now it's just matter of time
Comment 29 Victor Gil 2020-07-12 13:44:07 UTC
Not added in 5.7.8, tried a custom compilation and I confirm that works perfectly fine. Tested in MSI GS65.
Comment 30 Vanja 2020-07-16 13:09:43 UTC
5.7.9 is out and they still haven't picked up this patch...
Comment 31 kibipi5174 2020-07-18 09:57:45 UTC
(In reply to Vanja from comment #30)
> 5.7.9 is out and they still haven't picked up this patch...

You can follow the status of the patch here: https://patchwork.kernel.org/patch/11662083/
Comment 32 manj-a-bug 2020-07-26 10:00:20 UTC
The patch has reached the master branch, the next release (5.8-rc7) will include it. Should we close this bug?
Comment 33 Stefan I. 2020-07-26 14:06:28 UTC
Hm....will it be in 5.7.11? Otherwise i think it is not fixed in the current stable. And so it the bug is not fixed to me.
Comment 34 manj-a-bug 2020-07-27 08:19:30 UTC
The patch has now been added to the 5.7 stable tree, so expect it in the 5.7.11 release.
Comment 35 Stefan I. 2020-07-29 09:19:25 UTC
5.7.11 is out and the patch is included. So i think the bug can be closed now.

Note You need to log in before you can comment on or make changes to this bug.