Bug 208139 - Thinkpad X1 Yoga gen 4: Keyboard mute switch mutes main mic array, but not microphone connected to the audio jack
Summary: Thinkpad X1 Yoga gen 4: Keyboard mute switch mutes main mic array, but not mi...
Status: RESOLVED DUPLICATE of bug 208145
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-11 16:20 UTC by Nate Graham
Modified: 2020-06-16 18:22 UTC (History)
0 users

See Also:
Kernel Version: 5.6.14
Tree: Mainline
Regression: No


Attachments
Output of `pacmd list-cards` (3.50 KB, text/plain)
2020-06-11 16:20 UTC, Nate Graham
Details

Description Nate Graham 2020-06-11 16:20:39 UTC
Created attachment 289613 [details]
Output of `pacmd list-cards`

My Thinkpad X1 Yoga gen 4 has a keyboard button to mute the microphone. Pressing it mutes the built-in microphone array, but does not mute any microphones connected to the audio jack--for example a wired headset. This makes it not very useful since the only time I want to mute my microphone is when I'm using a headset for a video call, at which point it does not work for that purpose.

ALSA info is available at http://alsa-project.org/db/?f=f8f00ab594ae7d998aa2a8002dd5202ab1137b4b

Apologies if I've filed this in the wrong place and it's actually a PulseAudio issue, or an issue at some other part of the audio stack.
Comment 1 Nate Graham 2020-06-12 00:18:24 UTC
I have Kernel 5.6.14, sof-firmware, and PulseAudio 14 built from source.
Comment 2 Nate Graham 2020-06-16 18:22:50 UTC
With the fix I found in Bug 208145, this issue is resolved. I had a feeling it would.

*** This bug has been marked as a duplicate of bug 208145 ***

Note You need to log in before you can comment on or make changes to this bug.