Bug 208133 - Thinkpad X1 Yoga gen 4 sound issues: no bass, max volume too low, only stereo channels visible to PA
Summary: Thinkpad X1 Yoga gen 4 sound issues: no bass, max volume too low, only stereo...
Status: RESOLVED DUPLICATE of bug 207407
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-11 02:16 UTC by Nate Graham
Modified: 2020-06-25 13:41 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.6.14
Tree: Mainline
Regression: No


Attachments
Output of `pacmd list-cards` (3.50 KB, text/plain)
2020-06-11 15:54 UTC, Nate Graham
Details

Description Nate Graham 2020-06-11 02:16:45 UTC
With a Thinkpad X1 Yoga gen 4, Kernel 5.6.14, and PulseAudio 14, The sound situation is as follows:

Good:
- The microphone array works properly out of the box
- The front and rear speakers all produce sound out of the box

Bad:
- The maximum volume is a bit low
- The bass speaker is not working  at all
- The speaker system shows up as a stereo device in PulseAudio, not a 4.1 channel audio device (see also https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/914)
- Useless disconnected devices for the DisplayPort and HDMI audio devices are visible to PulseAudio, cluttering up the display (see also https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/913)

ALSA info is available at http://alsa-project.org/db/?f=f8f00ab594ae7d998aa2a8002dd5202ab1137b4b
Comment 1 Nate Graham 2020-06-11 02:18:12 UTC
Possibly relevant useful: if I set `snd_hda_intel.dmic_detect=0` in the kernel parameters, the mic array is no longer detected, but https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/914 and https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/913get fixed.
Comment 2 Nate Graham 2020-06-11 02:53:23 UTC
Dunno if this should be merged with Bug 207407, which is about broadly similar issues in the X1 Carbon. The X1 Yoga and X1 Carbon are basically a chassis swap with the same internals, so it's quite possible that when one is fixed the other will be too.
Comment 3 Nate Graham 2020-06-11 15:53:57 UTC
Another issue, not sure if it's related: the speakers and headphone jack are correctly combined into multiple ports of the same device such that when I plug in headphones, it switches automatically. However the microphone is not combined with the audio jack's mic input in this way, so it's presented as two microphones rather than one mic device with two ports. Is this an issue at the ALSA level or something  PulseAudio can fix?
Comment 4 Nate Graham 2020-06-11 15:54:48 UTC
Created attachment 289611 [details]
Output of `pacmd list-cards`
Comment 5 Jaroslav Kysela 2020-06-25 13:40:18 UTC

*** This bug has been marked as a duplicate of bug 207407 ***
Comment 6 Jaroslav Kysela 2020-06-25 13:41:23 UTC
There are several merge requests in the pulseaudio gitlab repository to resolve the automatic source / port switch, but it's not related to kernel at all.

Note You need to log in before you can comment on or make changes to this bug.