Bug 208019 - 2 seconds delay during boot - Dell XPS 13 9300
Summary: 2 seconds delay during boot - Dell XPS 13 9300
Status: CLOSED UNREPRODUCIBLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-01 18:48 UTC by ashpil
Modified: 2020-08-04 01:18 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.6.15
Tree: Mainline
Regression: No


Attachments
dmesg (70.01 KB, text/plain)
2020-06-01 18:48 UTC, ashpil
Details
I also attached the acpidump (1.01 MB, text/plain)
2020-06-01 18:51 UTC, ashpil
Details
Acpidump for 1.0.0 (1.01 MB, text/plain)
2020-06-01 22:02 UTC, ashpil
Details

Description ashpil 2020-06-01 18:48:53 UTC
Created attachment 289451 [details]
dmesg

On the Dell XPS 13 9300, there is a two second hang during kernel boot due to some ACPI issue. I understand that a similar warning has been reported in the past and has been dismissed as "harmless." However, in my case, the "Linux query ignored" issue causes a two second hang on boot, which seems not quite harmless. I am running the Dell XPS 13 9300, with the latest firmware. I have also tried many variations of the acpi_osi kernel parameter and nothing seems to change anything. 

I understand that this is possibly a firmware bug rather than an ACPI one, but it seems to me even if it is the laptop manufacturer's issue, ACPI should be able to determine that and continue in less than two seconds, in a similar ~50ms timeframe that this issue has been resolved in in the past.

Please see the attached dmesg for more context. The issue happens at the jump from the 0.48 to the 2.49 second mark.
Comment 1 ashpil 2020-06-01 18:51:14 UTC
Created attachment 289453 [details]
I also attached the acpidump
Comment 2 ashpil 2020-06-01 22:00:38 UTC
Just finished testing the different versions of the XPS 13 9300 firmware - the bug appears on all but 1.0.0. On 1.0.0, the same bug occurs but without the two second delay:

[    0.482091] ACPI: 11 ACPI AML tables successfully acquired and loaded

[    0.484154] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
Comment 3 ashpil 2020-06-01 22:02:25 UTC
Created attachment 289455 [details]
Acpidump for 1.0.0

See acpidump for firmware 1.0.0, if it would be helpful
Comment 4 Zhang Rui 2020-06-30 06:58:10 UTC
First of all, the "ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored" is probably not the reason of the 2 seconds delay.
Seconds, the 2 seconds delay is probably spent in AML code, which sounds like a firmware issue to me.

Anyway, I think Len has a 9300 laptop, maybe he can reproduce the issue and narrow down the problem a little bit.
Comment 5 ashpil 2020-06-30 07:20:57 UTC
Ah, finally, a reply! :)

I can confirm happens to not just me: https://www.reddit.com/r/archlinux/comments/gucz9e/odd_acpi_hang_during_kernel_boot_on_xps_13_9300/fso0la2/

The differences between the working 1.0.0 and the nonworking other versions seem like they would be the key to finding out what the issue is (yay, regressions).

If it is indeed a firmware issue, would this be something the kernel couldn't account for at all? That is, there can't be a shorter timeout set for whatever query is happening at that moment, as whatever it's waiting on doesn't seem to be necessary?

I would report this to Dell as well, but they seem to have no official avenues to report bugs other than the forums, which seldom net a reply. Maybe someone who works on the kernel knows a better avenue for reporting dell firmware bugs, or knows someone this can be passed along to for a greater guarantee of a fix? Thankfully the 9300 is still rather new, so firmware patches seem possible.
Comment 6 ashpil 2020-08-03 23:00:39 UTC
This seems to be fixed in BIOS version 1.1.0, so this can be closed.

https://www.dell.com/support/home/en-us/drivers/driversdetails?driverid=p3nkm

Note You need to log in before you can comment on or make changes to this bug.