Bug 20782 - Warning in suspend_test_finish after resuming from suspend
Warning in suspend_test_finish after resuming from suspend
Status: REJECTED OBSOLETE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-10-19 21:06 UTC by Daniel Hahler
Modified: 2012-01-18 17:26 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.36-rc7-blueyed-00145-g50c6dc9
Tree: Mainline
Regression: No


Attachments
"dmesg" output from reproducing (59.60 KB, text/plain)
2010-10-19 21:06 UTC, Daniel Hahler
Details

Description Daniel Hahler 2010-10-19 21:06:47 UTC
Created attachment 34182 [details]
"dmesg" output from reproducing

I've got the following in "dmesg" after resuming from suspend-to-ram:

[118639.024343] ------------[ cut here ]------------
[118639.024350] WARNING: at kernel/power/suspend_test.c:53 suspend_test_finish+0x85/0x90()
[118639.024352] Hardware name:  
[118639.024354] Component: resume devices, time: 19116
[118639.024355] Modules linked in: aes_i586 aes_generic binfmt_misc nvidia(P) snd_emu10k1 it87 snd_rawmidi snd_ac97_codec hwmon_vid eeprom ac97_bus snd_bt87x snd_util_mem snd_pcm snd_hwdep snd_timer lm90 snd sbp2 i2c_nforce2 ieee1394 psmouse snd_page_alloc serio_raw soundcore emu10k1_gp joydev agpgart gameport k8temp raid10 raid456 async_pq async_xor xor async_memcpy async_raid6_recov raid6_pq async_tx raid0 multipath linear sha256_generic dm_crypt twofish_generic twofish_i586 twofish_common firewire_ohci hid_microsoft raid1 usbhid hid firewire_core usb_storage crc_itu_t pata_amd [last unloaded: sky2]
[118639.024393] Pid: 11772, comm: pm-suspend Tainted: P            2.6.36-rc7-blueyed-00145-g50c6dc9 #2
[118639.024395] Call Trace:
[118639.024401]  [<c0142532>] warn_slowpath_common+0x72/0xa0
[118639.024405]  [<c017c1c5>] ? suspend_test_finish+0x85/0x90
[118639.024409]  [<c017c1c5>] ? suspend_test_finish+0x85/0x90
[118639.024412]  [<c0142603>] warn_slowpath_fmt+0x33/0x40
[118639.024415]  [<c017c1c5>] suspend_test_finish+0x85/0x90
[118639.024419]  [<c017be3f>] suspend_devices_and_enter+0xbf/0x210
[118639.024423]  [<c017c098>] enter_state+0x108/0x130
[118639.024426]  [<c017b70b>] state_store+0x6b/0xb0
[118639.024429]  [<c017b6a0>] ? state_store+0x0/0xb0
[118639.024434]  [<c0358b90>] kobj_attr_store+0x20/0x30
[118639.024438]  [<c026b039>] sysfs_write_file+0x99/0xf0
[118639.024443]  [<c02118fa>] vfs_write+0x9a/0x160
[118639.024446]  [<c026afa0>] ? sysfs_write_file+0x0/0xf0
[118639.024450]  [<c0212262>] sys_write+0x42/0x70
[118639.024453]  [<c0103093>] sysenter_do_call+0x12/0x22
[118639.024456] ---[ end trace c7c64e4b9599bb7d ]---

https://bugzilla.kernel.org/show_bug.cgi?id=20112 might be related, but at least has additional data about my system (kernel config, lspci -vvv).

I can provide more information of course; please just ask.

I have just tried it again (I do not suspend to RAM normally), and it happened again. This time I could get the output of the whole cycle from dmesg, which I am attaching.
Comment 1 Rafael J. Wysocki 2010-10-19 22:34:34 UTC
Can you please unset CONFIG_PM_VERBOSE in your kernel .config file and
see if the problem is still there in that configuration?
Comment 2 Daniel Hahler 2010-10-21 18:31:56 UTC
Yes, still there:

[  858.426346] PM: resume devices took 19.750 seconds
[  858.426348] ------------[ cut here ]------------
[  858.426355] WARNING: at kernel/power/suspend_test.c:53 suspend_test_finish+0x85/0x90()
[  858.426357] Hardware name:  
[  858.426358] Component: resume devices, time: 19750
[  858.426360] Modules linked in: aes_i586 aes_generic binfmt_misc usb_storage nvidia(P) it87 hwmon_vid snd_emu10k1 eeprom snd_rawmidi snd_ac97_codec snd_bt87x lm90 ac97_bus snd_pcm sbp2 snd_util_mem emu10k1_gp ieee1394 snd_hwdep snd_timer psmouse gameport serio_raw snd i2c_nforce2 k8temp agpgart joydev snd_page_alloc soundcore raid10 raid456 async_pq async_xor xor async_memcpy async_raid6_recov raid6_pq async_tx raid0 multipath linear sha256_generic dm_crypt twofish_generic twofish_i586 twofish_common raid1 hid_microsoft firewire_ohci usbhid firewire_core crc_itu_t hid pata_amd [last unloaded: sky2]
[  858.426397] Pid: 6666, comm: pm-suspend Tainted: P            2.6.36-rc8-blueyed-00045-g51ea8a8 #4
[  858.426400] Call Trace:
[  858.426406]  [<c0142522>] warn_slowpath_common+0x72/0xa0
[  858.426409]  [<c017c175>] ? suspend_test_finish+0x85/0x90
[  858.426413]  [<c017c175>] ? suspend_test_finish+0x85/0x90
[  858.426416]  [<c01425f3>] warn_slowpath_fmt+0x33/0x40
[  858.426419]  [<c017c175>] suspend_test_finish+0x85/0x90
[  858.426423]  [<c017bdef>] suspend_devices_and_enter+0xbf/0x210
[  858.426427]  [<c017c048>] enter_state+0x108/0x130
[  858.426430]  [<c017b6bb>] state_store+0x6b/0xb0
[  858.426433]  [<c017b650>] ? state_store+0x0/0xb0
[  858.426438]  [<c0358b10>] kobj_attr_store+0x20/0x30
[  858.426443]  [<c026afa9>] sysfs_write_file+0x99/0xf0
[  858.426448]  [<c02118aa>] vfs_write+0x9a/0x160
[  858.426451]  [<c026af10>] ? sysfs_write_file+0x0/0xf0
[  858.426454]  [<c0212212>] sys_write+0x42/0x70
[  858.426458]  [<c0103093>] sysenter_do_call+0x12/0x22
[  858.426461] ---[ end trace 8abca8d5b843920e ]---
[  858.426506] PM: Finishing wakeup.

But it stopped the message spam I've reported in bug 20112.
Comment 3 Zhang Rui 2012-01-18 02:21:46 UTC
It's great that kernel bugzilla is back.

can you please verify if the problem still exists in the latest upstream
kernel?
Comment 4 Daniel Hahler 2012-01-18 17:26:02 UTC
I do not have access to the system where this happened anymore.

I am closing it as "obsolete".

Note You need to log in before you can comment on or make changes to this bug.