Bug 207603 - S2idle infinite loop
Summary: S2idle infinite loop
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Power Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Rafael J. Wysocki
URL:
Keywords:
Depends on:
Blocks: 178231
  Show dependency tree
 
Reported: 2020-05-06 12:47 UTC by Todd Brandt
Modified: 2020-05-13 18:11 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.7.0-rc2
Tree: Mainline
Regression: No


Attachments
otcpl-dell-p3520-with-loop-stripped.html (842.19 KB, text/html)
2020-05-06 12:47 UTC, Todd Brandt
Details
dmesg.txt (76.29 KB, text/plain)
2020-05-06 12:48 UTC, Todd Brandt
Details
ftrace.txt (3.26 MB, application/gzip)
2020-05-06 12:49 UTC, Todd Brandt
Details
ftrace_with_just_suspend_resume_trace_points.txt (1.34 MB, application/gzip)
2020-05-06 12:50 UTC, Todd Brandt
Details
issue.def (394 bytes, text/plain)
2020-05-13 18:10 UTC, Todd Brandt
Details
issue.def (424 bytes, text/plain)
2020-05-13 18:11 UTC, Todd Brandt
Details

Description Todd Brandt 2020-05-06 12:47:44 UTC
Created attachment 288961 [details]
otcpl-dell-p3520-with-loop-stripped.html

When running stress testing, occasionally the s2idle_enter code will enter an infinite loop instead of waiting. The suspend_machine tracepoints are called hundreds of thousands of times during a 10 second period. It happens on many unrelated machines. It prevents timeline generation because the code html cannot render hundreds of thousands of suspend machine & resume machine phases.

Dell p3520
Whiskey Lake U
Dell XPS 13 9300
Amber Lake Y

Attached are the logs for the Dell p3520 run and a timeline with the infinite loop trimmed out.
Comment 1 Todd Brandt 2020-05-06 12:48:14 UTC
Created attachment 288963 [details]
dmesg.txt
Comment 2 Todd Brandt 2020-05-06 12:49:23 UTC
Created attachment 288965 [details]
ftrace.txt
Comment 3 Todd Brandt 2020-05-06 12:50:13 UTC
Created attachment 288967 [details]
ftrace_with_just_suspend_resume_trace_points.txt
Comment 4 Rafael J. Wysocki 2020-05-09 09:03:00 UTC
This should be fixed by https://patchwork.kernel.org/patch/11538065/ if I'm not mistaken.
Comment 5 Todd Brandt 2020-05-13 18:10:09 UTC
Created attachment 289119 [details]
issue.def
Comment 6 Todd Brandt 2020-05-13 18:11:21 UTC
Created attachment 289121 [details]
issue.def

Note You need to log in before you can comment on or make changes to this bug.