Bug 207515 - When I upgraded from Fedora 31 to 32. The sound stopped working.
Summary: When I upgraded from Fedora 31 to 32. The sound stopped working.
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-29 19:40 UTC by Patrick Kasper
Modified: 2020-05-29 15:36 UTC (History)
1 user (show)

See Also:
Kernel Version: 5.6.6
Tree: Mainline
Regression: No


Attachments
aplay -l (1007 bytes, text/plain)
2020-04-29 19:40 UTC, Patrick Kasper
Details
aplay -L (1.69 KB, text/plain)
2020-04-29 19:40 UTC, Patrick Kasper
Details
lsmod | grep "^snd" | cut -d " " -f 1 (315 bytes, text/plain)
2020-04-29 19:41 UTC, Patrick Kasper
Details
cat /proc/asound/cards (424 bytes, text/plain)
2020-04-29 19:42 UTC, Patrick Kasper
Details
dmesg | egrep -i "alsa|snd" (1.02 KB, text/plain)
2020-04-29 19:43 UTC, Patrick Kasper
Details
lspci (7.07 KB, text/plain)
2020-04-29 19:43 UTC, Patrick Kasper
Details
alsa-info.sh (64.42 KB, text/plain)
2020-04-30 12:20 UTC, Patrick Kasper
Details
alsa-info.txt (31.92 KB, text/plain)
2020-04-30 20:52 UTC, Patrick Kasper
Details

Description Patrick Kasper 2020-04-29 19:40:00 UTC
Created attachment 288825 [details]
aplay -l

I have an Asus ROG Zenith Extreme Mainboard.
The Onboard Sound Chip not found with the kernel version 5.6.6
The Gnome Control Center listet only a dummy device.

I have downgrade the kernel to version 5.5 from Fedora 31 and my Sound works fine.

The exact same problem i have with the newest kernel update on Artix Linux (Arch based) it is the same kernel version 5.6.6. Downgrading to version 5.6.3 also helped here.
Comment 1 Patrick Kasper 2020-04-29 19:40:42 UTC
Created attachment 288827 [details]
aplay -L
Comment 2 Patrick Kasper 2020-04-29 19:41:30 UTC
Created attachment 288829 [details]
lsmod | grep "^snd" | cut -d " " -f 1
Comment 3 Patrick Kasper 2020-04-29 19:42:07 UTC
Created attachment 288831 [details]
cat /proc/asound/cards
Comment 4 Patrick Kasper 2020-04-29 19:43:08 UTC
Created attachment 288833 [details]
dmesg | egrep -i "alsa|snd"
Comment 5 Patrick Kasper 2020-04-29 19:43:57 UTC
Created attachment 288835 [details]
lspci
Comment 6 Jaroslav Kysela 2020-04-29 19:55:21 UTC
Attach output from "alsa-info.sh --no-upload".
Comment 7 Patrick Kasper 2020-04-30 12:20:13 UTC
Created attachment 288839 [details]
alsa-info.sh
Comment 8 Patrick Kasper 2020-04-30 20:50:20 UTC
With the kernel 5.6.7-300 the exact same Problem!
Comment 9 Patrick Kasper 2020-04-30 20:52:03 UTC
Created attachment 288861 [details]
alsa-info.txt
Comment 10 Takashi Iwai 2020-05-29 15:36:06 UTC
This should have been fixed now.  It's been wrongly blacklisted due to another AMD model.

Please reopen if you still suffer from the problem with the latest kernel.

Note You need to log in before you can comment on or make changes to this bug.