Bug 207331 - commit "drm/amdgpu: fix gfx hang during suspend with video playback" breaks reboot/shutdown
Summary: commit "drm/amdgpu: fix gfx hang during suspend with video playback" breaks r...
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
: 207347 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-17 19:39 UTC by Grzegorz Kowal
Modified: 2020-06-15 20:50 UTC (History)
5 users (show)

See Also:
Kernel Version: 5.6.5
Tree: Mainline
Regression: Yes


Attachments
lspci -vvv (77.03 KB, text/plain)
2020-04-17 19:39 UTC, Grzegorz Kowal
Details
dmesg (77.68 KB, text/plain)
2020-04-17 19:40 UTC, Grzegorz Kowal
Details

Description Grzegorz Kowal 2020-04-17 19:39:58 UTC
Created attachment 288569 [details]
lspci -vvv

After updating kernel from 5.6.4 to 5.6.5 reboot and shutdown do not work any more. My laptop Lenovo Thinkpad T495 is simply hanging forever with display turned off, but the keyboard backlit and power led on.

I did bisection and it points to

drm/amdgpu: fix gfx hang during suspend with video playback (v2)

kernel stable 5.6.x commit: a1f57b87ddcc869b576aca73608f35cb436c3fdc
kernel stable 5.4.x commit: bdac1d76a310578b3ad081df2db97da59e241010

Indeed, after reverting this commit, both kernels reboot or shutdown properly.
Comment 1 Grzegorz Kowal 2020-04-17 19:40:31 UTC
Created attachment 288571 [details]
dmesg
Comment 3 Grzegorz Kowal 2020-04-18 12:33:45 UTC
Thanks! I applied the patch and the problem is gone. Both reboot and shutdown work again.
Comment 4 hagar-dunor 2020-04-19 13:18:11 UTC
*** Bug 207347 has been marked as a duplicate of this bug. ***
Comment 5 Grzegorz Kowal 2020-04-21 23:14:11 UTC
Fixed in stable versions 5.6.6 and 5.4.34.

Note You need to log in before you can comment on or make changes to this bug.